source: projects/specs/trunk/q/qscintilla/qscintilla-vl.spec @ 10547

Revision 10547, 6.1 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

RevLine 
[521]1%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
[9071]2%global pyqt4_version 4.11.2
[521]3
[9071]4%define ver 3.3.6
[521]5
[9071]6%define _qt4_version 4.8.6
[5383]7%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
8%define _qt4_libdir %(pkg-config --variable libdir --silence-errors Qt 2>/dev/null || echo %{_libdir})
9%define _qt4_headerdir %(pkg-config --variable headerdir --silence-errors Qt 2>/dev/null || echo %{_includedir})
[1444]10%define _qt4_translationdir %(pkg-config --variable translationdir --silence-errors Qt 2>/dev/null || echo %{_datadir}/qt4/translations)
11
[521]12Summary:        A Scintilla port to Qt
[9071]13Summary(ja):    Scintilla の Qt への移植版
[521]14Name:           qscintilla
[9071]15Version:        2.8.4
[10547]16Release:        2%{?_dist_release}
[2725]17
[521]18# matches up (pretty much) with qt4
19License:        GPLv3 or GPLv2 with exceptions
[9071]20Group:          System Environment/Libraries
[521]21URL:            http://www.riverbankcomputing.co.uk/qscintilla
[2725]22
[521]23Source:         QScintilla-gpl-%{version}.tar.gz
24# TODO: upstream this
25Patch1:         QScintilla-2-gpl-Qt4-incpath.patch
26
27BuildRoot:      %{_tmppath}/%{name}-%{version}-root
[3001]28BuildRequires:  qt4-devel
[521]29BuildRequires:  PyQt4-devel >= %{pyqt4_version}
[9071]30BuildRequires:  sip-devel
[5383]31Requires:       qt4 >= %{_qt4_version}
[521]32
33%description
34QScintilla is a port of Scintilla to the Qt GUI toolkit.
35
36This version of QScintilla is based on Scintilla v%{ver}.
37
38%package designer
39Summary:  QScintilla designer plugin
[9071]40Summary(ja):  QScintilla デザイナプラグイン
41Group:    System Environment/Libraries
[521]42Requires: %{name} = %{version}-%{release}
43Requires: qt4-designer
44
45%description designer
46%{summary}.
47
48%package devel
49Summary: QScintilla Development Files
[9071]50Summary(ja): QScintilla 開発用ファイル
[521]51Group: Development/Libraries
[5383]52Requires: %{name} = %{version}-%{release}
53Requires: qt4-devel >= %{_qt4_version}
[521]54
55%description  devel
56This packages contains the libraries, include and other files
57you can use to develop applications with QScintilla.
58
59%package python
[9071]60Summary:  QScintilla python bindings
61Summary(ja):  QScintilla の Python バインディング
62Group:    System Environment/Libraries
[521]63Requires: %{name} = %{version}-%{release}
64Requires: PyQt4 >= %{pyqt4_version}
[9071]65Provides: python-qscintilla = %{version}-%{release}
[521]66
67%description python
68%{summary}.
69
70%package python-devel
[9071]71Summary:  Development files for QScintilla python bindings
72Summary(ja): QScintilla の Python バインディングの開発用ファイル
[521]73Group:    Development/Libraries
74Requires: %{name}-python = %{version}-%{release}
[5383]75Requires: PyQt4-devel >= %{pyqt4_version}
[521]76
77%description python-devel
78%{summary}.
79
80%prep
81%setup -q -n QScintilla-gpl-%{version}
82
83# fix permissions on doc files
[9071]84find doc example-Qt4Qt5  -type f -exec chmod 0644 {} ';'
[521]85find src include -type f -exec chmod 0644 {} ';'
86
87# fix line endings in license file(s)
88sed -i 's/\r//' LICENSE.GPL2 GPL_EXCEPTION_ADDENDUM.TXT
89
90%build
[1444]91export QTDIR=%{_qt4_prefix}
[521]92%ifarch x86_64
93export QMAKESPEC=$QTDIR/mkspecs/linux-g++-64/
94%else
95export QMAKESPEC=$QTDIR/mkspecs/linux-g++/
96%endif
97
[9071]98cd Qt4Qt5
[521]99$QTDIR/bin/qmake -o Makefile qscintilla.pro
100make %{?_smp_mflags}
[9071]101cd ..
[521]102
[9071]103cd designer-Qt4Qt5
104QMAKEFEATURES=../Qt4Qt5/features \
105$QTDIR/bin/qmake -o Makefile designer.pro INCLUDEPATH+=../Qt4Qt5 LIBS+=-L../Qt4Qt5
[521]106make %{?_smp_mflags}
[9071]107cd ..
[521]108
[9071]109cd Python
[521]110%{__python} configure.py \
[9071]111    --no-timestamp \
112    --qsci-incdir=../Qt4Qt5 \
113    --qsci-libdir=../Qt4Qt5
[521]114make %{?_smp_mflags}
[9071]115cd ..
[521]116
117%install
118rm -rf $RPM_BUILD_ROOT
119
[9071]120make install INSTALL_ROOT=$RPM_BUILD_ROOT -C Qt4Qt5
121make install INSTALL_ROOT=$RPM_BUILD_ROOT -C designer-Qt4Qt5
122make install INSTALL_ROOT=$RPM_BUILD_ROOT  DESTDIR=$RPM_BUILD_ROOT -C Python
[521]123
124
125%clean
126rm -rf $RPM_BUILD_ROOT
127
128%post  -p /sbin/ldconfig
129
130%postun -p /sbin/ldconfig
131
132%files
133%defattr(-, root, root, 755)
[1444]134%doc NEWS README
135%doc LICENSE.GPL3 LICENSE.GPL2 GPL_EXCEPTION.TXT GPL_EXCEPTION_ADDENDUM.TXT
136%{_qt4_libdir}/libqscintilla2.so.*
137%{_qt4_prefix}/qsci/*
138%{_qt4_translationdir}/*
[521]139
140%files designer
141%defattr(-,root,root,-)
[1444]142%{_qt4_prefix}/plugins/designer/libqscintillaplugin.so
[521]143
144%files devel
[1444]145%defattr(-, root, root, -)
[5383]146%{_qt4_headerdir}/*
[1444]147%{_qt4_libdir}/libqscintilla2.so
[9071]148%{_qt4_prefix}/mkspecs/features/qscintilla2.prf
[521]149
150%files python
151%defattr(-,root,root,-)
152%{python_sitearch}/PyQt4/Qsci.so
153
154%files python-devel
155%defattr(-,root,root,-)
156%{_datadir}/sip/PyQt4/Qsci
157
158%changelog
[10547]159* Mon Jul 04 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-2
160- rebuild with gcc-5.4.0
161
[9071]162* Sat Nov  8 2014 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-1
163- new upstream release
164- built with qt-4.8.6, PyQt4-4.11.2
165
[5383]166* Sat Jan  7 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6-1
167- new upstream release
168- built with qt-4.8.0, PyQt4-4.9
169
[3001]170* Sun Mar 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.6-2
171- rebuilt with qt-4.7.2
172
[2725]173* Sun Feb 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.6-1
174- new upstream release
175- fix qt4_ver from 4.6.3 to 4.7.1
176
[1670]177* Wed Aug 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.4-2
178- rebuild with qt4-4.6.3
179- fix qt4_ver from 4.6.1 to 4.6.3
180- fix BuildRequires: qt4-devel = %{qt4_ver} (add version)
181
[1444]182* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.4-1
183- new upstream release
184- updated qt4 macros
185
[521]186* Sat Feb 06 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-1
187- new upstream release
188
189* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.4-3
190- rebuilt with qt4-4.6.1, python-2.6
191- installed translation to %%{_datadir}/qt4/translations now
192
193* Thu Oct 22 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-2
194- updated macro pyqt4_version to 4.6
195- fixed changelog year below (2008 -> 2009)
196
197* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4-1
198- new upstream release
199- added designer, python and python-devel sub-packages
200
201* Sun Aug 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.7.1-1
202- appiled new versioning policy
203
204* Fri Nov 30 2007 Shu KONNO <owa@bg.wakwak.com> 1.7.1-0vl2
205- updated macro QMAKESPEC to linux-g++-64 (if x86_64)
206
207* Thu Sep 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.7.1-0vl1
208- new upstream release (1.71)
209
[9071]210* Sun Jun  4 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6-0vl1
[521]211- new upstream release (1.65)
212- changed Group to System Environment/Libraries
213
214* Sat Jan 15 2005 Satoshi MACHINO <machino@vinelinux.org> 1.4-0vl1
215- initial built for VineLinux
216
Note: See TracBrowser for help on using the repository browser.