source: projects/specs/trunk/q/qrupdate/qrupdate-vl.spec @ 10165

Revision 10165, 1.5 KB checked in by ara_t, 8 years ago (diff)

A Fortran library for fast updates of QR and Cholesky decompositions

Line 
1%define pkg_name    qrupdate
2%define pkg_version 1.1.2
3%define pkg_release 3%{?_dist_release}
4
5%ifarch %{ix86}
6%define LIB_DIR lib
7%endif
8%ifarch x86_64
9%define LIB_DIR lib64
10%endif
11
12
13Summary: A Fortran library for fast updates of QR and Cholesky decompositions
14Name:    %{pkg_name}
15Version: %{pkg_version}
16Release: %{pkg_release}
17
18License: GPLv2
19Group:   System Environment/Libraries
20URL:     https://sourceforge.net/projects/qrupdate/
21Source0: qrupdate-%{version}.tar.gz
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24BuildRequires: gcc-gfortran
25BuildRequires: blas-devel lapack-devel
26Requires: blas lapack
27
28%if %{?_dist_release} == "vl7"
29%ifarch %{ix86}
30Provides: libqrupdate.so.1
31%endif
32%ifarch x86_64
33Provides: libqrupdate.so.1()(64bit)
34%endif
35%endif
36
37Vendor: Project Vine
38Distribution: Vine Linux
39Packager: ara_t
40
41%description
42qrupdate is a Fortran library for fast updates of QR and Cholesky
43decompositions.
44
45
46%prep
47%{__rm} -rf ${RPM_BUILD_ROOT}
48%setup -q
49
50%build
51%{__make} solib %{?_smp_mflags}
52
53%install
54%{__make} install-shlib \
55          PREFIX=%{_prefix} LIBDIR=%{LIB_DIR} DESTDIR=${RPM_BUILD_ROOT}
56
57%clean
58%{__rm} -rf ${RPM_BUILD_ROOT}
59
60%post -p %{_syssbindir}/ldconfig
61%postun -p %{_syssbindir}/ldconfig
62
63
64%files
65%defattr(-,root,root)
66%doc ChangeLog COPYING README
67%{_libdir}/libqrupdate.so*
68
69
70%changelog
71* Mon Apr 11 2016 Toshiaki Ara <ara_t@384.jp> 1.1.2-3
72- correct SPEC file
73
74* Tue Mar 22 2016 Toshiaki Ara <ara_t@384.jp> 1.1.2-2
75- fix %{_syssbindir}/ldconfig
76- add Provides: libqrupdate.so.1()
77
78* Sat Mar 19 2016 Toshiaki Ara <ara_t@384.jp> 1.1.2-1
79- new package
80
Note: See TracBrowser for help on using the repository browser.