source: projects/specs/trunk/q/qoauth/qoauth-vl.spec @ 5383

Revision 5383, 2.7 KB checked in by inagaki, 12 years ago (diff)

update: akonadi, automoc4, herqq, ibus-qt, kdebase-runtime, libqzeitgeist, phonon, PyQt4, qca2, qca-ossl, qt4, qt-assistant-adp, qscintilla, qtsoap, uim

Line 
1%global githash 726325d
2%global gitdate 20100625
3#global posttag .%{?gitdate}git%{?githash}
4
5%define qt4_ver 4.8.0
6%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
7%define _qt4_datadir %(pkg-config --variable datadir --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
8
9Name:           qoauth
10Summary:        Qt-based C++ library for OAuth authorization scheme
11Version:        1.0.1
12Release:        4%{?_dist_release}
13
14Group:          System Environment/Libraries
15License:        LGPLv2+
16URL:            http://github.com/ayoy/qoauth
17
18Source0:        http://files.ayoy.net/qoauth/release/%{version}/src/%{name}-%{version}-src.tar.bz2
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21BuildRequires:  qt4-devel qca2-devel doxygen
22BuildRequires:  qca-ossl
23Requires:       qca-ossl
24
25%description
26QOAuth is a Qt-based C++ implementation of an interface to services using
27OAuth authorization scheme.
28
29%package devel
30Summary:        Development files for the Qt OAuth support library
31Group:          Development/Libraries
32Requires:       %{name} = %{version}-%{release}
33Requires:       qt4-devel >= %{_qt4_version}
34Requires:       qca2-devel
35
36%description devel
37The %{name}-devel package contains libraries, header files and documentations
38for developing applications that use QOAuth library.
39
40%prep
41%setup -q -n %{name}-%{version}-src
42sed -i -e '/^ *docs \\$/d' \
43       -e "s!\(\$\${INSTALL_PREFIX}\)/lib.*!%{_libdir}!" src/src.pro
44sed -i -e 's\/lib\/%{_lib}\g' src/pcfile.sh
45
46%build
47export PATH=%{_qt4_prefix}/bin:$PATH
48%{_qt4_prefix}/bin/qmake PREFIX="%{_prefix}"
49make %{?_smp_mflags}
50
51
52%install
53make install INSTALL="install -p" INSTALL_ROOT=%{buildroot}
54doxygen Doxyfile
55
56# fix the time stamp
57for file in doc/html/*; do
58        touch -r Doxyfile $file
59done
60
61%check
62make check || :
63
64%clean
65rm -rf %{buildroot}
66
67%post -p /sbin/ldconfig
68
69%postun -p /sbin/ldconfig
70
71%files
72%defattr(-,root,root,-)
73%doc README CHANGELOG LICENSE
74%{_libdir}/*.so.*
75
76%files devel
77%defattr(-,root,root,-)
78%doc doc/html doc/examples
79%{_libdir}/*.so
80%{_libdir}/*.prl
81%{_libdir}/pkgconfig/*.pc
82%{_qt4_datadir}/mkspecs/features/*.prf
83%{_includedir}/*
84
85%changelog
86* Mon Jan  9 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-4
87- rebuilt with qt-4.8.0
88
89* Tue Mar  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-3
90- rebuilt with qt4-4.7.2
91
92* Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-2
93- Initial build for Vine Linux
94
95* Sun Aug 08 2010 Chen Lei <supercyper@163.com> - 1.0.1-1
96- Update to 1.0.1
97
98* Fri Jun 25 2010 Chen Lei <supercyper@163.com> - 1.0.1-0.3.20100625git726325d
99- New upstream version
100
101* Tue Jun 22 2010 Chen Lei <supercyper@163.com> - 1.0.1-0.2.20100622git7f69e33
102- New upstream version
103- Add %%check section
104
105* Tue May 25 2010 Chen Lei <supercyper@163.com> - 1.0.1-0.1.20100525gitec7e4d5
106- initial rpm build
Note: See TracBrowser for help on using the repository browser.