source: projects/specs/trunk/q/qoauth/qoauth-vl.spec @ 10570

Revision 10570, 3.2 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1%global githash 726325d
2%global gitdate 20100625
3#global posttag .%{?gitdate}git%{?githash}
4
5%define qt4_ver 4.8.6
6%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
7%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
8%define _qt4_bindir %(pkg-config --variable bindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/bin)
9%define _qt4_datadir %(pkg-config --variable datadir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix})
10
11Name:           qoauth
12Version:        1.0.1
13Release:        6%{?_dist_release}
14Summary:        Qt library OAuth authorization scheme
15Summary(ja):    OAuth 認証スキームのための Qt ライブラリ
16
17Group:          System Environment/Libraries
18License:        LGPLv2+
19URL:            http://github.com/ayoy/qoauth
20
21Source0:        http://files.ayoy.net/qoauth/release/%{version}/src/%{name}-%{version}-src.tar.bz2
22
23BuildRoot:      %{_tmppath}/%{name}-%{version}-root
24BuildRequires:  qt4-devel qca2-devel doxygen
25BuildRequires:  qca-ossl
26Requires:       qca-ossl
27
28%description
29QOAuth is a Qt-based C++ implementation of an interface to services using
30OAuth authorization scheme.
31
32%package devel
33Summary:        Development files for the Qt OAuth support library
34Summary(ja):    Qt OAuth ライブラリの開発用ファイル
35Group:          Development/Libraries
36Requires:       %{name} = %{version}-%{release}
37
38%description devel
39The %{name}-devel package contains libraries, header files and documentations
40for developing applications that use QOAuth library.
41
42%prep
43%setup -q -n %{name}-%{version}-src
44sed -i -e '/^ *docs \\$/d' \
45       -e "s!\(\$\${INSTALL_PREFIX}\)/lib.*!%{_libdir}!" src/src.pro
46sed -i -e 's\/lib\/%{_lib}\g' src/pcfile.sh
47
48%build
49export PATH=%{_qt4_bindir}:$PATH
50qmake PREFIX="%{_prefix}"
51make %{?_smp_mflags}
52
53
54%install
55rm -rf $RPM_BUILD_ROOT
56make install INSTALL="install -p" INSTALL_ROOT=$RPM_BUILD_ROOT
57doxygen Doxyfile
58
59# fix the time stamp
60for file in doc/html/*; do
61        touch -r Doxyfile $file
62done
63
64%check
65make check || :
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70%post -p /sbin/ldconfig
71
72%postun -p /sbin/ldconfig
73
74%files
75%defattr(-,root,root,-)
76%doc README CHANGELOG LICENSE
77%{_libdir}/*.so.*
78
79%files devel
80%defattr(-,root,root,-)
81%doc doc/html doc/examples
82%{_libdir}/*.so
83%{_libdir}/*.prl
84%{_libdir}/pkgconfig/*.pc
85%{_qt4_datadir}/mkspecs/features/*.prf
86%{_includedir}/*
87
88%changelog
89* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-6
90- rebuild with gcc-5.4.0
91
92* Mon Feb  9 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.0.1-5
93- rebuilt on current VineSeed
94- added Japanese summary
95
96* Mon Jan  9 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-4
97- rebuilt with qt-4.8.0
98
99* Tue Mar  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-3
100- rebuilt with qt4-4.7.2
101
102* Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-2
103- Initial build for Vine Linux
104
105* Sun Aug 08 2010 Chen Lei <supercyper@163.com> - 1.0.1-1
106- Update to 1.0.1
107
108* Fri Jun 25 2010 Chen Lei <supercyper@163.com> - 1.0.1-0.3.20100625git726325d
109- New upstream version
110
111* Tue Jun 22 2010 Chen Lei <supercyper@163.com> - 1.0.1-0.2.20100622git7f69e33
112- New upstream version
113- Add %%check section
114
115* Tue May 25 2010 Chen Lei <supercyper@163.com> - 1.0.1-0.1.20100525gitec7e4d5
116- initial rpm build
Note: See TracBrowser for help on using the repository browser.