source: projects/specs/trunk/q/qjson/qjson-vl.spec @ 8430

Revision 8430, 3.9 KB checked in by Takemikaduchi, 10 years ago (diff)

KDE-4.12.5

Line 
1Name:           qjson
2Summary:        A qt-based library that maps JSON data to QVariant objects
3Summary(ja):    JSON データ を QVariant Object にマッピングするためのライブラリ
4Version:        0.8.1
5Release:        1%{?_dist_release}
6
7Group:          System Environment/Libraries
8License:        GPLv2+
9URL:            http://sourceforge.net/projects/qjson/
10
11Source0:        http://downloads.sourceforge.net/project/qjson/qjson/0.8.1/%{name}-%{version}.tar.bz2
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildRequires:  cmake >= 2.6
15BuildRequires:  qt4-devel
16BuildRequires:  doxygen
17
18%description
19JSON is a lightweight data-interchange format. It can represents integer, real
20number, string, an ordered sequence of value, and a collection of
21name/value pairs.QJson is a qt-based library that maps JSON data to
22QVariant objects.
23
24%package devel
25Summary:  Development files for qjson
26Summary(ja): qjson の開発用ファイル
27Group:    Development/Libraries
28Requires: %{name} = %{version}-%{release}
29Requires: qt4-devel
30
31%description devel
32The %{name}-devel package contains the libraries and header files required for
33developing applications that use %{name}.
34
35%prep
36%setup -q
37
38%build
39mkdir -p %{_target_platform}
40pushd %{_target_platform}
41%cmake -DQJSON_BUILD_TESTS=1 \
42    -DCMAKE_MODULES_INSTALL_DIR=%{_datadir}/cmake/Modules/ \
43    ..
44cd %{_builddir}/%{buildsubdir}/doc
45doxygen
46popd
47
48sed -i -e 's/-fno-exceptions -fno-check-new -fno-common//' \
49-e 's/-fno-threadsafe-statics -fvisibility=hidden -fvisibility-inlines-hidden//' \
50-e 's/-ansi//' %{_target_platform}/src/CMakeFiles/qjson.dir/flags.make
51
52make %{?_smp_mflags} -C %{_target_platform}
53
54%install
55rm -rf %{buildroot}
56make install DESTDIR=%{buildroot} -C %{_target_platform}
57
58%clean
59rm -rf %{buildroot}
60
61%post -p /sbin/ldconfig
62
63%postun -p /sbin/ldconfig
64
65%files
66%defattr(-,root,root,-)
67%doc COPYING
68%{_libdir}/libqjson.so.*
69
70%files devel
71%defattr(-,root,root,-)
72%doc doc/html
73%{_includedir}/%{name}
74%{_libdir}/cmake/%{name}
75%{_libdir}/libqjson.so
76%{_libdir}/pkgconfig/QJson.pc
77
78%changelog
79* Mon May 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.1-1
80- new upstream release
81
82* Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.1-6
83- added Japanese summary
84
85* Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.1-5
86- rebuilt with rpm-4.8.1
87
88* Sun Aug 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.1-4
89- re-fixed CMAKE_MODULES_INSTALL_DIR
90
91* Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.1-3
92- fixed CMAKE_MODULES_INSTALL_DIR
93
94* Sun Aug 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.1-2
95- initial build for Vine Linux
96
97* Sat Dec 12 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.7.1-1
98-0.7.1
99- Version upgrade
100- Fixed doxygen documentation (Thanks again Orcan)
101
102* Tue Dec 8 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-6
103-0.6.3
104- Fixed capitalization of the summary
105
106* Tue Dec 8 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-5
107-0.6.3
108- Moved Doxygen docs to the development package.
109- Corrected placement of the cmake project file (Thanks Orcan)
110- Fixed the running of the build tests
111- Corrected column length of the descriptions
112- Changed description of the devlepment package
113
114* Sun Dec 6 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-4
115-0.6.3
116- Additional placment of library files fix
117
118* Fri Dec 4 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-3
119-0.6.3
120- Fixed placment of library files
121- Activated build tests
122- Corrected ownership of include directory
123- Corrected dependacies
124- Added doxygen documentation
125- Fixed reported version in the changelogs
126
127* Sun Nov 22 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-2
128-0.6.3
129- Split off development libraries to its own package
130- Modified licensing in spec file to reflect GPL2 code though docs state that qjson
131-   licensed under LPGL
132- Uncommeted and corrected sed line in this spec file
133
134* Sun Nov 22 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-1
135-0.6.3
136- Initial Build
Note: See TracBrowser for help on using the repository browser.