source: projects/specs/trunk/q/qimageblitz/qimageblitz-vl.spec @ 521

Revision 521, 1.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define kde_major_version 4
2%define qt_ver 4.5.2
3
4Name: qimageblitz
5Version: 0.0.4
6Release: 4%{?_dist_release}
7Summary: Blitz KDE/Qt image filter library
8Source: %{name}-%{version}.tar.bz2
9URL: http://sourceforge.net/projects/qimageblitz
10Group: System Environment/Libraries
11License: LGPL
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: qt4-devel >= %{qt_ver}
15BuildRequires: cmake >= 2.4.5
16BuildRequires: pkgconfig
17Requires: qt4 >= %{qt_ver}
18
19%description
20Blitz is a graphical effect and filter library for KDE4.0 that contains
21many improvements over KDE 3.x's kdefx library including bugfixes, memory
22and speed improvements, and MMX/SSE support.
23
24%package devel
25Summary: Development files for blitz
26Group: Development/Libraries
27Requires: %{name} = %{version}-%{release}
28Requires: qt4-devel
29
30%description devel
31Header files for developing applications using blitz
32
33%prep
34%setup -q
35
36%build
37unset QTDIR || : ; . /etc/profile.d/qt4.sh
38
39mkdir %{name}-build
40pushd %{name}-build
41%cmake -DCMAKE_BUILD_TYPE=release ..
42popd
43make %{?_smp_mflags} -C %{name}-build
44
45%install
46rm -rf $RPM_BUILD_ROOT
47make install DESTDIR=$RPM_BUILD_ROOT -C %{name}-build
48
49%clean
50rm -rf $RPM_BUILD_ROOT
51
52%post -p /sbin/ldconfig
53
54%postun -p /sbin/ldconfig
55
56%files
57%defattr(-,root,root)
58%{_bindir}*
59%{_libdir}/*.so.*
60
61%files devel
62%defattr(-,root,root)
63%{_includedir}/qimageblitz
64%{_libdir}/*.so
65%{_libdir}/pkgconfig/*.pc
66
67%changelog
68* Tue Sep 01 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.0.4-4
69- use %%cmake macro
70- drop redundant cmake options
71
72* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.0.4-3
73- rebuilt with qt-4.5.2
74
75* Thu Oct 23 2008 Shu KONNO <owa@bg.wakwak.com> 0.0.4-2
76- added -DLIB_INSTALL_DIR=%%{_libdir} at cmake
77
78* Sun Oct 12 2008 AKIYAMA KAzuhito <akiyama@yb3.so-net.ne.jp> 0.0.4-1
79- initial release
Note: See TracBrowser for help on using the repository browser.