source: projects/specs/trunk/q/qhull/qhull-vl.spec @ 11789

Revision 11789, 3.9 KB checked in by ara_t, 6 years ago (diff)

qhull: update to 2015.2

Line 
1%define name qhull
2%define version 2015.2
3
4# Upstream's versioning is bizarre
5%global tarvers 2015-src-7.2.0
6
7Summary: General dimension convex hull programs
8Name:    %{name}
9Version: %{version}
10Release: 1%{?_dist_release}
11License: Qhull
12Group:   System Environment/Libraries
13
14URL: http://www.qhull.org
15Source0: http://www.qhull.org/download/qhull-%{tarvers}.tgz
16
17Patch1: 0001-Link-executables-against-shared-libs.patch
18Patch2: 0002-Install-docs-into-subdirs.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21
22BuildRequires: cmake
23BuildRequires: chrpath
24
25Vendor: Project Vine
26Distribution: Vine Linux
27
28
29%description
30Qhull is a general dimension convex hull program that reads a set
31of points from stdin, and outputs the smallest convex set that contains
32the points to stdout.  It also generates Delaunay triangulations, Voronoi
33diagrams, furthest-site Voronoi diagrams, and halfspace intersections
34about a point.
35
36%package -n libqhull
37Group:   System Environment/Libraries
38Summary: -n libqhull
39
40%description -n libqhull
41%{summary}
42
43%package -n libqhull_r
44Group:   System Environment/Libraries
45Summary: libqhull_r
46
47%description -n libqhull_r
48%{summary}
49
50%package -n libqhull_p
51Group:   System Environment/Libraries
52Summary: libqhull_p
53
54%description -n libqhull_p
55%{summary}
56
57%package devel
58Summary: Development files for qhull
59Group:   Development/Libraries
60Requires: lib%{name} = %{version}-%{release}
61Requires: lib%{name}_r = %{version}-%{release}
62Requires: lib%{name}_p = %{version}-%{release}
63
64%description devel
65Qhull is a general dimension convex hull program that reads a set
66of points from stdin, and outputs the smallest convex set that contains
67the points to stdout.  It also generates Delaunay triangulations, Voronoi
68diagrams, furthest-site Voronoi diagrams, and halfspace intersections
69about a point.
70
71
72%prep
73%setup -q -n %{name}-%{version}
74%patch1 -p1
75%patch2 -p1
76
77%build
78cd build
79%cmake ..
80make VERBOSE=1 %{?_smp_mflags}
81cd ..
82
83%install
84rm -rf ${RPM_BUILD_ROOT}
85cd build
86%make_install
87cd ..
88
89chrpath --delete ${RPM_BUILD_ROOT}%{_libdir}/lib*.so.*
90
91## remove unuse files
92rm -rf ${RPM_BUILD_ROOT}%{_libdir}/*.a
93
94## rename doc folder
95mv ${RPM_BUILD_ROOT}%{_docdir}/%{name} \
96   ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101
102%post -p /sbin/ldconfig
103%postun -p /sbin/ldconfig
104
105%post -n libqhull -p /sbin/ldconfig
106%postun -n libqhull -p /sbin/ldconfig
107
108%post -n libqhull_r -p /sbin/ldconfig
109%postun -n libqhull_r -p /sbin/ldconfig
110
111%post -n libqhull_p -p /sbin/ldconfig
112%postun -n libqhull_p -p /sbin/ldconfig
113
114
115%files
116%{_bindir}/*
117%{_docdir}/%{name}-%{version}/
118%{_mandir}/man1/*
119
120%files -n libqhull
121%{_libdir}/libqhull.so.*
122
123%files -n libqhull_r
124%{_libdir}/libqhull_r.so.*
125
126%files -n libqhull_p
127%{_libdir}/libqhull_p.so.*
128
129%files devel
130%defattr(-,root,root)
131%{_includedir}/libqhull*
132%{_libdir}/libqhull.so
133%{_libdir}/libqhull_r.so
134%{_libdir}/libqhull_p.so
135
136
137%changelog
138* Tue Sep 04 2018 Toshiaki Ara <ara_t@384.jp> 2015.2-1
139- update to 2015.2-7.2.0
140- add patches from fedora package
141- split out libqhull, libqhull_p, libqhull_r packages
142- drop Provides: libqhull.so
143- drop Provides: libqhull_p.so
144
145* Tue Apr 12 2016 Toshiaki Ara <ara_t@384.jp> 2012.1-2
146- add Provides: libqhull.so
147- add Provides: libqhull_p.so
148
149* Sun Jan 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2012.1-1
150- update to 2012.1
151
152* Sat Feb 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2003.1-2
153- added Patch0 from upstream
154- added --disable-static to %%configure
155
156* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 2003.1-1vl5
157- applied new versioning policy
158- removed *.la
159
160*Thu Jan 03 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2003.1-0vl2
161- rebuild on VineSeed
162
163*Thu Oct 6 2005 g-staff <g-staff@math.sci.hokudai.ac.jp> 2003.1-0vl1
164- taken from FC
165- rebuild on Vine Linux 3.2
166
167* Sun Aug 08 2004 Ralf Corsepius <ralf[AT]links2linux.de>       - 2003.1-0.fdr.2
168- Use default documentation installation scheme.
169
170* Fri Jul 16 2004 Ralf Corsepius <ralf[AT]links2linux.de>       - 2003.1-0.fdr.1
171- Initial Fedora RPM.
Note: See TracBrowser for help on using the repository browser.