source: projects/specs/trunk/q/qemu-launcher/qemu-launcher-vl.spec @ 521

Revision 521, 3.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:   A graphical front-end to Qemu virtual machines
2Summary(ja): Qemu 仮想マシン用グラフィカルフロントエンド
3Name:      qemu-launcher
4Version:   1.7.4
5Release:   1%{?_dist_release}
6
7Group:     Applications/Emulators
8License:   GPLv2+
9URL:       https://gna.org/projects/qemulaunch/
10
11Source0:   http://download.gna.org/qemulaunch/1.7.x/%{name}_%{version}.tar.gz
12#Patch0 changes:
13# qemu-launcher.desktop: Removed file extension from Icon, changed Categories
14#   to System
15# Makefile: "install" commands given -p switch to preserve timestamps
16Patch0:    %{name}-%{version}.patch
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildArch: noarch
19ExcludeArch: ppc64
20
21BuildRequires: desktop-file-utils
22BuildRequires: gettext
23BuildRequires: libxml2
24Requires:      qemu
25Requires:      perl-Gtk2-GladeXML
26Requires:      perl-gettext
27
28%description
29Qemu Launcher provides a graphical front-end to all basic, and many advanced
30QEMU computer emulator options. It allows you to create, save, and run multiple
31virtual machine configurations, create and convert disk images.
32
33%prep
34%setup -q
35%patch -p1
36
37
38%build
39make PREFIX=%{_prefix} %{?_smp_mflags}
40
41
42%install
43rm -rf %{buildroot}
44make install                                 \
45  PREFIX=%{_prefix} DESTDIR=%{buildroot}     \
46  DOCSDIR="." #Install docs in cwd, and catch them with %doc below
47desktop-file-install --vendor fedora --delete-original  \
48  --dir %{buildroot}/%{_datadir}/applications/          \
49  %{buildroot}/%{_datadir}/applications/%{name}.desktop
50%find_lang %{name}
51
52
53%clean
54rm -rf %{buildroot}
55
56
57%post
58touch --no-create %{_datadir}/icons/hicolor
59if [ -x %{_bindir}/gtk-update-icon-cache ]; then
60  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
61fi
62
63
64%postun
65touch --no-create %{_datadir}/icons/hicolor
66if [ -x %{_bindir}/gtk-update-icon-cache ]; then
67  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
68fi
69
70
71%files -f %{name}.lang
72%defattr(-,root,root,-)
73%doc Changelog COPYING README TODO
74%{_bindir}/*
75%{_datadir}/%{name}
76%{_datadir}/applications/*
77%{_datadir}/pixmaps/*
78%{_datadir}/icons/hicolor/*/apps/*
79%{_mandir}/man1/*
80
81
82%changelog
83* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.4-1
84- initial build for Vine Linux
85
86* Sat Dec 09 2007 Nicholas Boyle <nsboyle@gmail.com> - 1.7.4-4
87- Added ExcludeArch: ppc64, as there is no ppc64 build for qemu
88* Tue Dec 04 2007 Nicholas Boyle <nsboyle@gmail.com> - 1.7.4-3
89- Clean after build now correctly removes buildroot
90- Package now takes ownership of directories it creates
91- Patched Makefile to preserve timestamps on files during install
92- Included source tarball with original timestamps
93* Sat Dec 01 2007 Nicholas Boyle <nsboyle@gmail.com> - 1.7.4-2
94- Changed BuildArch to noarch
95- Changed PREFIX and doc installation behavior during make and make install
96  rather than patching the Makefile
97- Changed package Group to Applications/Emulators
98* Sun Nov 25 2007 Nicholas Boyle <nsboyle@gmail.com> - 1.7.4-1
99- Initial Fedora packaging
Note: See TracBrowser for help on using the repository browser.