source: projects/specs/trunk/q/qedje/qedje-vl.spec @ 868

Revision 868, 4.1 KB checked in by owa, 14 years ago (diff)

rebuilt with python-2.6

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4Name:           qedje
5Version:        0.4.0
6Release:        5%{?_dist_release}
7Summary:        A library combining the benefits of Edje and Qt
8
9Group:          System Environment/Libraries
10License:        GPLv3+
11URL:            http://code.openbossa.org/projects/%{name}
12Source0:        http://code.openbossa.org/projects/%{name}/repos/mainline/archive/0206ec8f2a802bf51455179933d8b7ab3e41a38b.tar.gz
13Patch0:         qedje-0.4.0-fix_python_install.patch
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16
17BuildRequires:  qt4-devel
18BuildRequires:  eet-devel
19BuildRequires:  qzion-devel
20BuildRequires:  qzion-python-devel
21BuildRequires:  cmake
22BuildRequires:  pkgconfig
23BuildRequires:  python-devel
24BuildRequires:  sip-devel
25BuildRequires:  PyQt4-devel
26
27%description
28The main purpose of the QEdje project is to build a bridge among components
29that proved to have great value for open source developers: Edje and Qt. This
30will extend the Qt toolkit with the flexibility of a declarative language, such
31as Edje, and also enable Qt widgets to be embedded into Edje UI design.
32
33%package devel
34Summary:   Development files for %{name}
35Group:     Development/Libraries
36Requires:  cmake
37Requires:  pkgconfig
38Requires:  %{name} = %{version}-%{release}
39Requires:  qzion-devel
40Requires:  eet-devel
41
42%description devel
43The %{name}-devel package contains libraries and header files for
44developing applications that use %{name}.
45
46%package python
47Summary:  Python bindings for %{name}
48Group:    Development/Libraries
49Requires: PyQt4
50Requires: qzion-python
51
52%description python
53The %{name}-python package contains python bindings for %{name}
54
55%package python-devel
56Summary:  Python bindings for %{name}
57Group:    Development/Libraries
58Requires: sip
59Requires: PyQt4-devel
60Requires: qzion-python-devel
61Requires: %{name}-python = %{version}-%{release}
62
63%description python-devel
64The %{name}-python-devel package contains the development files
65for the python bindings for %{name}
66
67%prep
68%setup -q -n %{name}-mainline
69%patch0 -p1
70
71%build
72
73mkdir -p %{_target_platform}
74pushd %{_target_platform}
75%cmake \
76    -DPYTHON_SITE_PACKAGES_DIR=%{python_sitearch} \
77    -DQZION_SIP_DIR=%{_datadir}/sip/qzion \
78    ..
79popd
80
81make %{?_smp_mflags} -C %{_target_platform}
82
83
84%install
85rm -rf %{buildroot}
86make install/fast -C %{_target_platform} DESTDIR=%{buildroot}
87
88%clean
89rm -rf %{buildroot}
90
91%post -p /sbin/ldconfig
92
93%postun -p /sbin/ldconfig
94
95
96%files
97%defattr(-,root,root,-)
98%doc README COPYING
99%{_bindir}/qedje_viewer
100%{_libdir}/*.so.*
101
102%files devel
103%defattr(-,root,root,-)
104%{_libdir}/*.so
105%{_includedir}/*
106%{_libdir}/pkgconfig/%{name}.pc
107
108%files python
109%defattr(-,root,root,-)
110%{python_sitearch}/%{name}
111
112%files python-devel
113%defattr(-,root,root,-)
114%{_datadir}/sip/%{name}
115
116%changelog
117* Mon Apr 19 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.0-5
118- rebuilt with python-2.6
119
120* Sun Sep 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> -0.4.0-3
121- use %%cmake macro
122
123* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.4.0-3
124- Initial build for Vine Linux
125
126* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.0-2
127- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
128
129* Fri Mar 06 2009 John5342 <john5342 at, fedoraproject.org> 0.4.0-1
130- Updated to new upstream release (0.4.0)
131
132* Fri Mar 06 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.3.0-5
133- revert (previous borkage probably due to qt-4.5-rc1)
134
135* Wed Mar 05 2009 Caolán McNamara <caolanm@redhat.com> - 0.3.0-4
136- BR: phonon-devel
137
138* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-3
139- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
140
141* Fri Dec 19 2008 John5342 <john5342 at, fedoraproject.org> 0.3.0-2
142- Fixed a license
143- BR: qzion-devel
144- devel R: qzion-devel, eet-devel
145
146* Fri Dec 19 2008 John5342 <john5342 at, fedoraproject.org> 0.3.0-1
147- Initial package
Note: See TracBrowser for help on using the repository browser.