source: projects/specs/trunk/q/qedje/qedje-vl.spec @ 10570

Revision 10570, 4.4 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4Name:           qedje
5Version:        0.4.0
6Release:        7%{?_dist_release}
7Summary:        A library combining the benefits of Edje and Qt
8
9Group:          System Environment/Libraries
10License:        GPLv3+
11URL:            http://code.openbossa.org/projects/%{name}
12Source0:        http://code.openbossa.org/projects/%{name}/repos/mainline/archive/0206ec8f2a802bf51455179933d8b7ab3e41a38b.tar.gz
13Patch0:         qedje-0.4.0-fix_python_install.patch
14Patch1:         qedje-0.4.0-fix-install.patch
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires:  qt4-devel
19BuildRequires:  eet-devel
20BuildRequires:  qzion-devel
21BuildRequires:  qzion-python-devel
22BuildRequires:  cmake
23BuildRequires:  pkgconfig
24BuildRequires:  python-devel
25BuildRequires:  sip-devel
26BuildRequires:  PyQt4-devel
27
28%description
29The main purpose of the QEdje project is to build a bridge among components
30that proved to have great value for open source developers: Edje and Qt. This
31will extend the Qt toolkit with the flexibility of a declarative language, such
32as Edje, and also enable Qt widgets to be embedded into Edje UI design.
33
34%package devel
35Summary:   Development files for %{name}
36Group:     Development/Libraries
37Requires:  cmake
38Requires:  pkgconfig
39Requires:  %{name} = %{version}-%{release}
40Requires:  qzion-devel
41Requires:  eet-devel
42
43%description devel
44The %{name}-devel package contains libraries and header files for
45developing applications that use %{name}.
46
47%package python
48Summary:  Python bindings for %{name}
49Group:    Development/Libraries
50Requires: PyQt4
51Requires: qzion-python
52
53%description python
54The %{name}-python package contains python bindings for %{name}
55
56%package python-devel
57Summary:  Python bindings for %{name}
58Group:    Development/Libraries
59Requires: sip
60Requires: PyQt4-devel
61Requires: qzion-python-devel
62Requires: %{name}-python = %{version}-%{release}
63
64%description python-devel
65The %{name}-python-devel package contains the development files
66for the python bindings for %{name}
67
68%prep
69%setup -q -n %{name}-mainline
70%patch0 -p1
71%patch1 -p1 -b .fix-install
72
73%build
74
75mkdir -p %{_target_platform}
76pushd %{_target_platform}
77%cmake \
78    -DPYTHON_SITE_PACKAGES_DIR=%{python_sitearch} \
79    -DQZION_SIP_DIR=%{_datadir}/sip/qzion \
80    ..
81popd
82
83make %{?_smp_mflags} -C %{_target_platform}
84
85
86%install
87rm -rf %{buildroot}
88make install/fast -C %{_target_platform} DESTDIR=%{buildroot}
89
90%clean
91rm -rf %{buildroot}
92
93%post -p /sbin/ldconfig
94
95%postun -p /sbin/ldconfig
96
97
98%files
99%defattr(-,root,root,-)
100%doc README COPYING
101%{_bindir}/qedje_viewer
102%{_libdir}/*.so.*
103
104%files devel
105%defattr(-,root,root,-)
106%{_libdir}/*.so
107%{_includedir}/*
108%{_libdir}/pkgconfig/%{name}.pc
109
110%files python
111%defattr(-,root,root,-)
112%{python_sitearch}/%{name}
113
114%files python-devel
115%defattr(-,root,root,-)
116%{_datadir}/sip/%{name}
117
118%changelog
119* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.0-7
120- rebuild with gcc-5.4.0
121
122* Sat Oct 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.0-6
123- rebuilt with rpm-4.8.1 for pkg-config
124- added qedje-0.4.0-fix-install.patch (from mandriva)
125
126* Mon Apr 19 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.0-5
127- rebuilt with python-2.6
128
129* Sun Sep 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> -0.4.0-3
130- use %%cmake macro
131
132* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.4.0-3
133- Initial build for Vine Linux
134
135* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.0-2
136- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
137
138* Fri Mar 06 2009 John5342 <john5342 at, fedoraproject.org> 0.4.0-1
139- Updated to new upstream release (0.4.0)
140
141* Fri Mar 06 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.3.0-5
142- revert (previous borkage probably due to qt-4.5-rc1)
143
144* Wed Mar 05 2009 Caolán McNamara <caolanm@redhat.com> - 0.3.0-4
145- BR: phonon-devel
146
147* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-3
148- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
149
150* Fri Dec 19 2008 John5342 <john5342 at, fedoraproject.org> 0.3.0-2
151- Fixed a license
152- BR: qzion-devel
153- devel R: qzion-devel, eet-devel
154
155* Fri Dec 19 2008 John5342 <john5342 at, fedoraproject.org> 0.3.0-1
156- Initial package
Note: See TracBrowser for help on using the repository browser.