source: projects/specs/trunk/q/qca2/qca2-vl.spec @ 1850

Revision 1850, 4.0 KB checked in by inagaki, 14 years ago (diff)

rebuilt with rpm-4.8.1

Line 
1%define qt4_ver 4.6.3
2
3Name:           qca2
4Summary:        Qt Cryptographic Architecture
5Version:        2.0.2
6Release:        8%{?_dist_release}
7
8Group:          System Environment/Libraries
9License:        LGPLv2+
10URL:            http://delta.affinix.com/qca
11Source0:        http://delta.affinix.com/download/qca/2.0/qca-%{version}.tar.bz2
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildRequires:  qt4-devel = %{qt4_ver}
15BuildRequires:  pkgconfig
16
17%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
18
19%description
20Taking a hint from the similarly-named Java Cryptography Architecture,
21QCA aims to provide a straightforward and cross-platform crypto API,
22using Qt datatypes and conventions. QCA separates the API from the
23implementation, using plugins known as Providers. The advantage of this
24model is to allow applications to avoid linking to or explicitly depending
25on any particular cryptographic library. This allows one to easily change
26or upgrade crypto implementations without even needing to recompile the
27application!
28
29%package        devel
30Summary:        Qt Cryptographic Architecture development files
31Group:          Development/Libraries
32Requires:       %{name} = %{version}-%{release}
33Requires:       qt4-devel = %{_qt4_version}
34
35%description    devel
36This packages contains the development files for QCA
37
38%prep
39%setup -q -n qca-%{version}
40
41%build
42unset QTDIR || : ; . /etc/profile.d/qt4.sh
43MAKE=%{_bindir}/make \
44./configure \
45  --prefix=%{_prefix} \
46  --includedir=%{_includedir} \
47  --libdir=%{_libdir} \
48  --datadir=%{_datadir} \
49  --no-separate-debug-info \
50  --verbose
51
52sed -i -e /strip/d Makefile
53make %{?_smp_mflags}
54
55
56%install
57rm -rf $RPM_BUILD_ROOT
58make install INSTALL_ROOT=$RPM_BUILD_ROOT
59
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%post -p /sbin/ldconfig
65
66%postun -p /sbin/ldconfig
67
68
69%files
70%defattr(-,root,root,-)
71%doc COPYING README TODO
72%{_bindir}/qcatool2
73%{_libdir}/*.so.*
74%{_mandir}/*/*
75
76%files devel
77%defattr(-,root,root,-)
78%{_includedir}/QtCrypto
79%{_libdir}/*.so
80%{_libdir}/pkgconfig/qca2.pc
81%{_libdir}/libqca.prl
82%{_libdir}/qt-%{_qt4_version}/mkspecs/features/crypto.prf
83
84
85%changelog
86* Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-8
87- rebuilt with rpm-4.8.1
88
89* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.0.2-7
90- rebuilt with qt-4.6.3 again
91- change BuildRequires: qt4-devel = %{qt4_ver} (add version)
92
93* Sat Jul 24 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-6
94- rebuilt with qt-4.6.3
95
96* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.0.2-5
97- rebuilt with new toolchain, qt4-4.6.1
98
99* Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-4
100- rebuilt with qt-4.5.3
101
102* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-3
103- Initial build for Vine Linux
104
105* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.2-2
106- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
107
108* Tue May 05 2009 Sven Lankes <sven@lank.es> - 2.0.2-1
109- new upstream release - qt 4.5-compat-fixes
110
111* Wed Apr 08 2009 Sven Lankes <sven@lank.es> - 2.0.1-1
112- new upstream release
113- removed 64bit patch - now upstream
114
115* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-4
116- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
117
118* Fri May 30 2008 Dennis Gilmore <dennis@ausil.us> - 2.0.0-3
119- crypto.prf is in libdir not datadir
120
121* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.0-2
122- Autorebuild for GCC 4.3
123
124* Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-1
125- version 2.0.0 final
126
127* Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.4.beta7
128- fix build on x86_64
129
130* Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.3.beta7
131- missing BR: openssl
132
133* Thu Sep 13 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.2.beta7
134- review from bug 289681 (thanks Rex)
135
136* Sun Sep 09 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.1.beta7
137- initial package
Note: See TracBrowser for help on using the repository browser.