source: projects/specs/trunk/q/qca2/qca2-vl.spec @ 9346

Revision 9346, 4.4 KB checked in by inagaki, 9 years ago (diff)

2015-02-09 Ryoichi INAGAKI <ryo1@…>

  • qca-ossl, qimageblitz, qoauth, qt-assistant-adp, qtsoap: rebuilt
  • qca2: added patch


Line 
1Name:           qca2
2Version:        2.0.3
3Release:        4%{?_dist_release}
4Summary:        Qt Cryptographic Architecture
5Summary(ja):    Qt 暗号アーキテクチャ
6
7Group:          System Environment/Libraries
8License:        LGPLv2+
9URL:            http://delta.affinix.com/qca
10
11Source0:        http://delta.affinix.com/download/qca/2.0/qca-%{version}.tar.bz2
12# Allow gcc to compile qca
13Patch0:         qca-2.0.3-gcc47.patch
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildRequires:  qt4-devel >= 4.2
17BuildRequires:  pkgconfig
18
19%description
20Taking a hint from the similarly-named Java Cryptography Architecture,
21QCA aims to provide a straightforward and cross-platform crypto API,
22using Qt datatypes and conventions. QCA separates the API from the
23implementation, using plugins known as Providers. The advantage of this
24model is to allow applications to avoid linking to or explicitly depending
25on any particular cryptographic library. This allows one to easily change
26or upgrade crypto implementations without even needing to recompile the
27application!
28
29%package        devel
30Summary:        Qt Cryptographic Architecture development files
31Summary(ja):    Qt 暗号アーキテクチャの開発用ファイル
32Group:          Development/Libraries
33Requires:       %{name} = %{version}-%{release}
34Requires:       qt4-devel >= %{_qt4_version}
35
36%description    devel
37This packages contains the development files for QCA
38
39%prep
40%setup -q -n qca-%{version}
41%patch0 -p1
42
43%build
44unset QTDIR
45./configure \
46      --prefix=%{_prefix} \
47      --includedir=%{_includedir} \
48      --libdir=%{_libdir} \
49      --datadir=%{_datadir} \
50      --no-separate-debug-info \
51      --verbose
52
53sed -i -e /strip/d Makefile
54make %{?_smp_mflags}
55
56
57%install
58rm -rf $RPM_BUILD_ROOT
59make install INSTALL_ROOT=$RPM_BUILD_ROOT
60
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%post -p /sbin/ldconfig
66
67%postun -p /sbin/ldconfig
68
69
70%files
71%defattr(-,root,root,-)
72%doc COPYING README TODO
73%{_bindir}/qcatool2
74%{_libdir}/*.so.*
75%{_mandir}/*/*
76
77%files devel
78%defattr(-,root,root,-)
79%{_includedir}/QtCrypto
80%{_libdir}/*.so
81%{_libdir}/pkgconfig/qca2.pc
82%{_libdir}/libqca.prl
83%{_qt4_datadir}/mkspecs/features/crypto.prf
84
85
86%changelog
87* Mon Feb  9 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.0.3-4
88- rebuilt on current VineSeed
89- added patch0 from Fedora
90- added Japanese summary
91
92* Sun Jan  8 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.3-3
93- rebuilt with qt-4.8.0
94
95* Tue Mar  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.3-2
96- rebuilt with qt-4.7.2
97
98* Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.3-1
99- new upstream release
100- built with qt-4.7.1
101
102* Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-8
103- rebuilt with rpm-4.8.1
104
105* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.0.2-7
106- rebuilt with qt-4.6.3 again
107- change BuildRequires: qt4-devel = %{qt4_ver} (add version)
108
109* Sat Jul 24 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-6
110- rebuilt with qt-4.6.3
111
112* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.0.2-5
113- rebuilt with new toolchain, qt4-4.6.1
114
115* Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-4
116- rebuilt with qt-4.5.3
117
118* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-3
119- Initial build for Vine Linux
120
121* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.2-2
122- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
123
124* Tue May 05 2009 Sven Lankes <sven@lank.es> - 2.0.2-1
125- new upstream release - qt 4.5-compat-fixes
126
127* Wed Apr 08 2009 Sven Lankes <sven@lank.es> - 2.0.1-1
128- new upstream release
129- removed 64bit patch - now upstream
130
131* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-4
132- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
133
134* Fri May 30 2008 Dennis Gilmore <dennis@ausil.us> - 2.0.0-3
135- crypto.prf is in libdir not datadir
136
137* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.0-2
138- Autorebuild for GCC 4.3
139
140* Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-1
141- version 2.0.0 final
142
143* Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.4.beta7
144- fix build on x86_64
145
146* Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.3.beta7
147- missing BR: openssl
148
149* Thu Sep 13 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.2.beta7
150- review from bug 289681 (thanks Rex)
151
152* Sun Sep 09 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.1.beta7
153- initial package
Note: See TracBrowser for help on using the repository browser.