source: projects/specs/trunk/q/qca2/qca2-vl.spec @ 1644

Revision 1644, 3.9 KB checked in by Takemikaduchi, 14 years ago (diff)

change BuildRequires?

Line 
1%define qt4_ver 4.6.3
2
3Name:           qca2
4Summary:        Qt Cryptographic Architecture
5Version:        2.0.2
6Release:        7%{?_dist_release}
7
8Group:          System Environment/Libraries
9License:        LGPLv2+
10URL:            http://delta.affinix.com/qca
11Source0:        http://delta.affinix.com/download/qca/2.0/qca-%{version}.tar.bz2
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildRequires:  qt4-devel = %{qt4_ver}
15BuildRequires:  pkgconfig
16
17%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
18
19%description
20Taking a hint from the similarly-named Java Cryptography Architecture,
21QCA aims to provide a straightforward and cross-platform crypto API,
22using Qt datatypes and conventions. QCA separates the API from the
23implementation, using plugins known as Providers. The advantage of this
24model is to allow applications to avoid linking to or explicitly depending
25on any particular cryptographic library. This allows one to easily change
26or upgrade crypto implementations without even needing to recompile the
27application!
28
29%package        devel
30Summary:        Qt Cryptographic Architecture development files
31Group:          Development/Libraries
32Requires:       %{name} = %{version}-%{release}
33Requires:       qt4-devel = %{_qt4_version}
34Requires:       pkgconfig
35
36%description    devel
37This packages contains the development files for QCA
38
39%prep
40%setup -q -n qca-%{version}
41
42%build
43unset QTDIR || : ; . /etc/profile.d/qt4.sh
44MAKE=%{_bindir}/make \
45./configure \
46  --prefix=%{_prefix} \
47  --includedir=%{_includedir} \
48  --libdir=%{_libdir} \
49  --datadir=%{_datadir} \
50  --no-separate-debug-info \
51  --verbose
52
53sed -i -e /strip/d Makefile
54make %{?_smp_mflags}
55
56
57%install
58rm -rf $RPM_BUILD_ROOT
59make install INSTALL_ROOT=$RPM_BUILD_ROOT
60
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%post -p /sbin/ldconfig
66
67%postun -p /sbin/ldconfig
68
69
70%files
71%defattr(-,root,root,-)
72%doc COPYING README TODO
73%{_bindir}/qcatool2
74%{_libdir}/*.so.*
75%{_mandir}/*/*
76
77%files devel
78%defattr(-,root,root,-)
79%{_includedir}/QtCrypto
80%{_libdir}/*.so
81%{_libdir}/pkgconfig/qca2.pc
82%{_libdir}/libqca.prl
83%{_libdir}/qt-%{_qt4_version}/mkspecs/features/crypto.prf
84
85
86%changelog
87* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.0.2-7
88- rebuilt with qt-4.6.3 again
89- change BuildRequires: qt4-devel = %{qt4_ver} (add version)
90
91* Sat Jul 24 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-6
92- rebuilt with qt-4.6.3
93
94* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.0.2-5
95- rebuilt with new toolchain, qt4-4.6.1
96
97* Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-4
98- rebuilt with qt-4.5.3
99
100* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-3
101- Initial build for Vine Linux
102
103* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.2-2
104- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
105
106* Tue May 05 2009 Sven Lankes <sven@lank.es> - 2.0.2-1
107- new upstream release - qt 4.5-compat-fixes
108
109* Wed Apr 08 2009 Sven Lankes <sven@lank.es> - 2.0.1-1
110- new upstream release
111- removed 64bit patch - now upstream
112
113* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-4
114- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
115
116* Fri May 30 2008 Dennis Gilmore <dennis@ausil.us> - 2.0.0-3
117- crypto.prf is in libdir not datadir
118
119* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.0-2
120- Autorebuild for GCC 4.3
121
122* Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-1
123- version 2.0.0 final
124
125* Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.4.beta7
126- fix build on x86_64
127
128* Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.3.beta7
129- missing BR: openssl
130
131* Thu Sep 13 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.2.beta7
132- review from bug 289681 (thanks Rex)
133
134* Sun Sep 09 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.1.beta7
135- initial package
Note: See TracBrowser for help on using the repository browser.