source: projects/specs/trunk/q/qca2/qca2-vl.spec @ 12299

Revision 12299, 7.2 KB checked in by tomop, 4 years ago (diff)

updated 15 packages

ant-1.9.14-1

ccid-1.4.31-1

extra-cmake-modules-5.63.0-1

file-5.37-2

iputils-20190709-1

libarchive-3.4.0-1

libidn2-2.2.0-1

libmodsecurity-3.0.3-4

libxslt-1.1.33-2

ncurses-6.1-3

pcsc-lite-1.8.25-1

polkit-qt-0.112.0-3

qca2-2.2.1-1

rdesktop-1.9.0-1

util-linux-2.34-1

RevLine 
[521]1Name:           qca2
[12299]2Version:        2.2.1
3Release:        1%{?_dist_release}
[1442]4Summary:        Qt Cryptographic Architecture
[9346]5Summary(ja):    Qt 暗号アーキテクチャ
[12299]6Group:          System Environment/Libraries
[521]7
[12299]8Vendor:         Project Vine
9Distribution:   Vine Linux
10
[521]11License:        LGPLv2+
[12299]12URL:            https://userbase.kde.org/QCA
13Source0:        http://download.kde.org/stable/qca/%{version}/qca-%{version}.tar.xz
[9346]14
[521]15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildRequires:  pkgconfig
[12299]17BuildRequires:  cmake
18BuildRequires:  extra-cmake-modules
19BuildRequires:  qt5-rpm-macros
20BuildRequires:  openssl-devel
21BuildRequires:  qt4-devel
22BuildRequires:  qt5-qtbase-devel
23Provides:       qca-qt4 = %{version}-%{release}
[521]24
25%description
26Taking a hint from the similarly-named Java Cryptography Architecture,
27QCA aims to provide a straightforward and cross-platform crypto API,
28using Qt datatypes and conventions. QCA separates the API from the
29implementation, using plugins known as Providers. The advantage of this
30model is to allow applications to avoid linking to or explicitly depending
31on any particular cryptographic library. This allows one to easily change
32or upgrade crypto implementations without even needing to recompile the
33application!
34
[12299]35
[521]36%package        devel
37Summary:        Qt Cryptographic Architecture development files
[9346]38Summary(ja):    Qt 暗号アーキテクチャの開発用ファイル
[521]39Group:          Development/Libraries
40Requires:       %{name} = %{version}-%{release}
[5383]41Requires:       qt4-devel >= %{_qt4_version}
[12299]42Provides:       qca-qt4-devel = %{version}-%{release}
[521]43
44%description    devel
45This packages contains the development files for QCA
46
[12299]47
48%package -n     qca2-qt5
49Summary:        Qt5 Cryptographic Architecture
50Summary(ja):    Qt5 暗号アーキテクチャ
51Group:          System Environment/Libraries
52Provides:       qca-qt5 = %{version}-%{release}
53
54%description -n qca2-qt5
55Taking a hint from the similarly-named Java Cryptography Architecture,
56QCA aims to provide a straightforward and cross-platform crypto API,
57using Qt datatypes and conventions. QCA separates the API from the
58implementation, using plugins known as Providers. The advantage of this
59model is to allow applications to avoid linking to or explicitly depending
60on any particular cryptographic library. This allows one to easily change
61or upgrade crypto implementations without even needing to recompile the
62application!
63
64
65%package -n     qca2-qt5-devel
66Summary:        Qt5 Cryptographic Architecture development files
67Summary(ja):    Qt5 暗号アーキテクチャの開発用ファイル
68Group:          Development/Libraries
69Provides:       qca-qt5-devel = %{version}-%{release}
70Requires:       qca2-qt5 = %{version}-%{release}
71Requires:       qt5-qtbase-devel
72
73%description -n qca2-qt5-devel
74This packages contains the development files for QCA
75
76
[521]77%prep
78%setup -q -n qca-%{version}
79
80%build
81
[12299]82mkdir build_qt5
83pushd build_qt5
84
85%{cmake} .. \
86  -DQCA_BINARY_INSTALL_DIR:STRING=%{_bindir} \
87  -DQCA_FEATURE_INSTALL_DIR:PATH=%{_qt5_archdatadir}/mkspecs/features \
88  -DQCA_INCLUDE_INSTALL_DIR:PATH=%{_qt5_headerdir} \
89  -DQCA_LIBRARY_INSTALL_DIR:PATH=%{_qt5_libdir} \
90  -DQCA_PLUGINS_INSTALL_DIR:PATH=%{_qt5_plugindir} \
91  -DQCA_PRIVATE_INCLUDE_INSTALL_DIR:PATH=%{_qt5_headerdir} \
92  -DQT4_BUILD:BOOL=OFF
93
[521]94make %{?_smp_mflags}
[12299]95popd
[521]96
[12299]97mkdir build_qt4
98pushd build_qt4
99%{cmake} .. \
100  -DQCA_BINARY_INSTALL_DIR:STRING=%{_bindir} \
101  -DQCA_FEATURE_INSTALL_DIR:PATH=%{_qt4_prefix}/mkspecs/features \
102  -DQCA_INCLUDE_INSTALL_DIR:PATH=%{_qt4_headerdir} \
103  -DQCA_LIBRARY_INSTALL_DIR:PATH=%{_qt4_libdir} \
104  -DQCA_PLUGINS_INSTALL_DIR:PATH=%{_qt4_plugindir} \
105  -DQCA_PRIVATE_INCLUDE_INSTALL_DIR:PATH=%{_qt4_headerdir} \
106  -DQT4_BUILD:BOOL=ON
[521]107
[12299]108make %{?_smp_mflags}
109popd
110
111
[521]112%install
[12299]113rm -rf %{buildroot}
114make install/fast DESTDIR=%{buildroot} -C build_qt5
115make install/fast DESTDIR=%{buildroot} -C build_qt4
[521]116
117
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%post -p /sbin/ldconfig
122%postun -p /sbin/ldconfig
123
[12299]124%post -n qca2-qt5 -p /sbin/ldconfig
125%postun -n qca2-qt5 -p /sbin/ldconfig
[521]126
[12299]127
[521]128%files
129%defattr(-,root,root,-)
[12299]130%license COPYING
131%doc README TODO
132%{_qt4_libdir}/libqca.so.2*
133%{_bindir}/mozcerts
134%{_bindir}/qcatool
135%{_mandir}/man1/qcatool.1*
136%dir %{_qt4_plugindir}/crypto/
137%{_qt4_plugindir}/crypto/*
[521]138
139%files devel
140%defattr(-,root,root,-)
141%{_includedir}/QtCrypto
[12299]142%{_libdir}/libqca.so
[521]143%{_libdir}/pkgconfig/qca2.pc
[12299]144%{_libdir}/cmake/Qca/
[5383]145%{_qt4_datadir}/mkspecs/features/crypto.prf
[521]146
[12299]147%files -n qca2-qt5
148%doc README TODO
149%license COPYING
150%{_bindir}/mozcerts-qt5
151%{_bindir}/qcatool-qt5
152%{_mandir}/man1/qcatool-qt5.1*
153%{_qt5_libdir}/libqca-qt5.so.2*
154%dir %{_qt5_plugindir}/crypto/
155%{_qt5_plugindir}/crypto/*
[521]156
[12299]157%files -n qca2-qt5-devel
158%{_qt5_headerdir}/QtCrypto
159%{_qt5_libdir}/libqca-qt5.so
160%{_libdir}/pkgconfig/qca2-qt5.pc
161%{_libdir}/cmake/Qca-qt5/
162%{_qt5_archdatadir}/mkspecs/features/crypto.prf
163
164
[521]165%changelog
[12299]166* Sun Oct 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.2.1-1
167- new upstream release.
168- added Qt5 support.
169
[10547]170* Mon Jul 04 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.0.3-5
171- rebuild with gcc-5.4.0
172
[9346]173* Mon Feb  9 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.0.3-4
174- rebuilt on current VineSeed
175- added patch0 from Fedora
176- added Japanese summary
177
[5383]178* Sun Jan  8 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.3-3
179- rebuilt with qt-4.8.0
180
[2981]181* Tue Mar  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.3-2
182- rebuilt with qt-4.7.2
183
[2612]184* Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.3-1
185- new upstream release
186- built with qt-4.7.1
187
[1850]188* Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-8
189- rebuilt with rpm-4.8.1
190
[1644]191* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.0.2-7
192- rebuilt with qt-4.6.3 again
193- change BuildRequires: qt4-devel = %{qt4_ver} (add version)
194
[1442]195* Sat Jul 24 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-6
196- rebuilt with qt-4.6.3
197
[521]198* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.0.2-5
199- rebuilt with new toolchain, qt4-4.6.1
200
201* Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-4
202- rebuilt with qt-4.5.3
203
204* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-3
205- Initial build for Vine Linux
206
207* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.2-2
208- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
209
210* Tue May 05 2009 Sven Lankes <sven@lank.es> - 2.0.2-1
211- new upstream release - qt 4.5-compat-fixes
212
213* Wed Apr 08 2009 Sven Lankes <sven@lank.es> - 2.0.1-1
214- new upstream release
215- removed 64bit patch - now upstream
216
217* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-4
218- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
219
220* Fri May 30 2008 Dennis Gilmore <dennis@ausil.us> - 2.0.0-3
221- crypto.prf is in libdir not datadir
222
223* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.0-2
224- Autorebuild for GCC 4.3
225
226* Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-1
227- version 2.0.0 final
228
229* Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.4.beta7
230- fix build on x86_64
231
232* Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.3.beta7
233- missing BR: openssl
234
235* Thu Sep 13 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.2.beta7
236- review from bug 289681 (thanks Rex)
237
238* Sun Sep 09 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.1.beta7
239- initial package
Note: See TracBrowser for help on using the repository browser.