source: projects/specs/trunk/p/pyxf86config/pyxf86config-vl.spec @ 521

Revision 521, 4.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Python wrappers for libxf86config
2Summary(ja): libxf86config の Python ラッパー
3Name: pyxf86config
4Version: 0.3.37
5Release: 2%{?_dist_release}
6URL: http://fedoraproject.org/wiki/pyxf86config
7Source0: %{name}-%{version}.tar.bz2
8License: GPL
9Group: System Environment/Libraries
10BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
11Requires: glib2
12BuildRequires: glib2-devel
13BuildRequires: libX11-devel
14BuildRequires: python-devel
15BuildRequires: libxf86config-devel
16ExcludeArch: s390 s390x ppc64
17
18%description
19Python wrappers for the X server config file library libxf86config.
20It is used to read and write X server configuration files.
21
22%prep
23%setup -q
24
25%build
26export CFLAGS="$RPM_OPT_FLAGS -fPIC"
27pyver=$(python -c 'import sys ; print sys.version[:3]')
28w%configure --x-libraries=%{_libdir} --with-python-version=$pyver
29make
30
31%install
32rm -rf $RPM_BUILD_ROOT
33%makeinstall
34
35%clean
36rm -rf $RPM_BUILD_ROOT
37
38%files
39%defattr(-,root,root)
40%doc README NEWS AUTHORS COPYING ChangeLog
41%{_libdir}/python?.?/site-packages/ixf86configmodule.so
42%{_libdir}/python?.?/site-packages/xf86config.py
43
44%changelog
45* Mon Feb 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.37-2
46- rebuild with python-2.6
47
48* Tue Aug 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.37-1
49- new upstream release
50- build with xorg-x11-7.3
51
52* Tue Aug 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.19.4-1
53- initial build for Vine Linux
54
55* Mon Oct 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.19.4-0vl1
56- remove unneeded screen resolution from XF86SupportedResolutions
57
58* Mon Sep 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.19.3-0vl1
59- add v4l module, remove fbdevhw from xorg.conf
60
61* Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.19.2-0vl1
62- add more resolutions
63
64* Tue Aug 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.19.1-0vl1
65- update default xorg.conf
66
67* Sun Aug 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.19-0vl1
68- initial build for Vine Linux
69
70* Wed Aug 11 2004 Jeremy Katz <katzj@redhat.com> - 0.3.19-1
71- Change keyboard driver to kbd
72
73* Thu Apr 15 2004 Mike A. Harris <mharris@redhat.com> - 0.3.18-1
74- Do not write out XkbRules line to config file, as it is unnecessary hard
75  coding the rules file, which has a built in default which should always
76  work. (#120858)
77
78* Thu Apr 15 2004 Jeremy Katz <katzj@redhat.com> - 0.3.17-1
79- xorg for XkbRules
80
81* Wed Apr 14 2004 Alex Larsson <alexl@redhat.com> 0.3.16
82- Rebuild for the new libxf86config
83- remove references to XFree86
84
85* Thu Feb 19 2004 Brent Fox <bfox@redhat.com> 0.3.15-1
86- remove the setupMice() function createTemplate()
87- because the 2.6 kernel puts both PS/2 and USB mice on the same device
88
89* Mon Feb  9 2004 Alexander Larsson <alexl@redhat.com> 0.3.14-1
90- fix range array bug
91
92* Thu Nov  6 2003 Jeremy Katz <katzj@redhat.com> 0.3.13-2
93- rebuild for python 2.3
94- don't build on ppc64 either since X is missing bits there as well
95
96* Tue Jul 29 2003 Elliot Lee <sopwith@redhat.com> 0.3.13-1
97- Rebuild
98
99* Wed Jun  4 2003 Brent Fox <bfox@redhat.com> 0.3.12-1
100- add a 'scrnum' attribute to the adjacency section
101
102* Tue Jun  3 2003 Brent Fox <bfox@redhat.com> 0.3.11-1
103- add a function to xf86config.py called getAllScreens()
104
105* Tue Jun  3 2003 Brent Fox <bfox@redhat.com> 0.3.10-1
106- add a BuildRequires for python-devel
107- add an options attribute to the server layout section (for Xinerama)
108
109* Tue Apr 29 2003 Alexander Larsson <alexl@redhat.com> 0.3.6-1
110- Added laptop resolutions
111
112* Mon Jan 27 2003 Alexander Larsson <alexl@redhat.com> 0.3.5-1
113- Rebuild
114
115* Wed Jan 15 2003 Michael Fulbright <msf@redhat.com> 0.3.4-1
116- remove code in xf86config.py:createTemplate() that inserted a Display
117  section.  We want user to supply this and it shouldnt be in template.
118
119* Sat Jan 11 2003 Florian La Roche <Florian.LaRoche@redhat.de>
120- add ExcludeArch: s390 s390x
121
122* Thu Dec 12 2002 Mike A. Harris <mharris@redhat.com> 0.3.3-1
123- Remove Excludearch alpha
124
125* Tue Nov 12 2002 Michael Fulbright <msf@redhat.com> 0.3.2-1
126- Added some convenience functions.
127
128* Mon Jul  8 2002 Alexander Larsson <alexl@redhat.com>
129- Bump to 0.3.1
130
131* Mon Jun 17 2002 Alexander Larsson <alexl@redhat.com>
132- Bump to 0.3.0
133
134* Fri May 24 2002 Alex Larsson <alexl@redhat.com> 0.2.0-3
135- Excludearch alpha for now
136
137* Fri May 24 2002 Alex Larsson <alexl@redhat.com> 0.2.0-2
138- Add some doc files
139
140* Fri May 24 2002 Alex Larsson <alexl@redhat.com> 0.2.0-1
141- Update version number for new release
142
143* Thu Apr 11 2002 Alex Larsson <alexl@redhat.com> 0.1.0-1
144- Initial release
145
146* Wed Apr 10 2002 Alex Larsson <alexl@redhat.com>
147- Initial specfile
Note: See TracBrowser for help on using the repository browser.