source: projects/specs/trunk/p/python3-setuptools/python3-setuptools-vl.spec @ 9420

Revision 9420, 4.4 KB checked in by iwaim, 9 years ago (diff)

new: python3-setuptools

Line 
1%{!?python3_sitelib: %define python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
2%{!?python3_version: %define python3_version %(python3 -c "import sys; sys.stdout.write(sys.version[:3])")}
3
4Name:           python3-setuptools
5Version:        5.4.2
6Release:        1%{?_dist_release}
7Summary:        Download, build, install, upgrade, and uninstall Python packages
8Summary(ja):     Python パッケージのダウンロード、ビルド、インストール、アップグレードおよびアンインストール用ツール
9Group:          Development/Tools
10License:        PSFL/ZPL
11URL:            https://pypi.python.org/pypi/setuptools
12Source0:        https://pypi.python.org/packages/source/s/setuptools/setuptools-%{version}.tar.gz
13Source1:        psfl.txt
14Source2:        zpl.txt
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16
17Requires(post): alternatives
18BuildArch:      noarch
19BuildRequires:  python3-devel
20
21%description
22setuptools is a collection of enhancements to the Python distutils that allow
23you to more easily build and distribute Python packages, especially ones that
24have dependencies on other packages.
25
26%description -l ja
27setuptools は Python distutils の拡張機能を集めたツールです。
28このツールにより Python パッケージの構築や配布が簡単に行えるように
29なります。特に他のパッケージに依存しているパッケージを扱う際に便利
30です。
31
32
33%prep
34%setup -q -n setuptools-%{version}
35
36
37%build
38CFLAGS="$RPM_OPT_FLAGS" python3 setup.py build
39
40
41%install
42rm -rf $RPM_BUILD_ROOT
43python3 setup.py install -O1 --skip-build \
44    --root $RPM_BUILD_ROOT \
45    --single-version-externally-managed
46install -p -m 0644 %{SOURCE1} %{SOURCE2} .
47find $RPM_BUILD_ROOT%{python3_sitelib} -name '*.exe' | xargs rm -f
48
49# for alternatives
50%__rm -f $RPM_BUILD_ROOT%{_bindir}/easy_install
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55%post
56update-alternatives --install %{_bindir}/easy_install easy_install \
57                              %{_bindir}/easy_install-%{python3_version} 20
58
59%preun
60if [ "$1" = "0" ]
61then
62  update-alternatives --remove easy_install %{_bindir}/easy_install-%{python3_version}
63fi
64
65%files
66%defattr(-,root,root,-)
67%doc *.txt
68%{_bindir}/easy_install-%{python3_version}
69%{python3_sitelib}/*
70
71
72%changelog
73* Mon Mar  9 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 5.4.2-1
74- new package python3-setuptools: based python-setuptools
75
76* Mon Mar  9 2015 IWAI, Masaharu <iwaim.sub@gmail.com> - 5.4.2-2
77- alternatives for easy_install
78
79* Fri Aug 08 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 5.4.2-1
80- new upstream release
81
82* Sat Jul 26 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 5.4.1-1
83- new upstream release
84
85* Sun Jul 06 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 5.4-1
86- new upstream release
87
88* Sat Apr 26 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.4.4-1
89- new upstream release
90
91* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6c11-2
92- rebuild with python-2.7.2
93
94* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.6c11-1
95- new upstream release
96
97* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.6c9-2
98- rebuild with python-2.6
99
100* Sun Dec 07 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6c9-1
101- new upstream release
102- add japanese summary and description
103
104* Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> - 0.6c3-1vl5
105- rebuilt with python-2.5.2
106- applied new versioning policy
107
108* Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6c3-1vl2
109- rebuilt for Vine Linux 4.0
110- changed Group to Development/Tools
111
112* Wed Nov 15 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
113- Refurbished for VineLinux3.2
114
115* Tue Sep 12 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.6c2-1
116- Upstream 0.6c2
117- Ghostbusting
118
119* Mon Jul 31 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.6c1-2
120- Set perms on license files (#200768)
121
122* Sat Jul 22 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.6c1-1
123- Version 0.6c1
124
125* Wed Jun 28 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.6b3-1
126- Taking over from Ignacio
127- Version 0.6b3
128- Ghost .pyo files in sitelib
129- Add license files
130- Remove manual python-abi, since we're building FC4 and up
131- Kill .exe files
132
133* Wed Feb 15 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.6a10-1
134- Upstream update
135
136* Mon Jan 16 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.6a9-1
137- Upstream update
138
139* Sat Dec 24 2005 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.6a8-1
140- Initial RPM release
Note: See TracBrowser for help on using the repository browser.