source: projects/specs/trunk/p/python3-pygobject/python3-pygobject-vl.spec @ 9073

Revision 9073, 2.5 KB checked in by Takemikaduchi, 9 years ago (diff)

GNOME 3.14.1

Line 
1%{!?python3_sitearch: %define python3_sitearch %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
2
3Name: python3-pygobject
4Summary: Python3 bindings for GObject Introspection
5Summary(ja): GObject Introspection の Python3 バインディング
6Version: 3.14.0
7Release: 1%{?_dist_release}
8
9Group: Development/Languages
10License: LGPL
11URL: http://www.pygtk.org/
12
13Source: http://ftp.gnome.org/pub/GNOME/sources/pygobject/3.14/pygobject-%{version}.tar.xz
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: glib2-devel >= 2.26.0
17BuildRequires: python3-devel >= 3.3
18BuildRequires: libffi-devel
19BuildRequires: libtool, automake
20BuildRequires: gobject-introspection-devel >= 0.9.8
21BuildRequires: python3-pycairo-devel >= 1.10.0
22Requires: python3 >= 3.3
23
24Obsoletes:      %{name}-devel < 3.12.0
25Obsoletes:      %{name}-doc < 3.10.0
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: Takemikaduchi
30
31%description
32pygobject provides a convenient wrapper for the GObject library
33for use in Python programs.
34
35
36%prep
37%setup -q -n pygobject-%{version}
38
39%build
40# --disable-docs doesn't work; it builds the docs anyway.
41%configure \
42    --enable-silent-rules \
43    --disable-static \
44    --enable-thread
45export tagname=CC
46make LIBTOOL=/usr/bin/libtool
47
48%install
49rm -rf $RPM_BUILD_ROOT
50export tagname=CC
51make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install
52
53find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
54rm -f examples/Makefile*
55
56# conflict with pygobject
57rm -rf $RPM_BUILD_ROOT%{python_sitearch}/gtk-2.0
58rm -rf $RPM_BUILD_ROOT%{_datadir}/pygobject
59
60# conflict with pygobject3
61rm -f $RPM_BUILD_ROOT%{_includedir}/pygobject-3.0/pygobject.h
62rm -f $RPM_BUILD_ROOT%{_libdir}/pkgconfig/pygobject-3.0.pc
63
64%clean
65rm -fr $RPM_BUILD_ROOT
66
67%files
68%defattr(644, root, root, 755)
69%doc AUTHORS NEWS README ChangeLog
70%{python3_sitearch}/pygtkcompat
71%{python3_sitearch}/*.egg-info
72%{python3_sitearch}/gi
73
74
75%changelog
76* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
77- new upstream release
78
79* Fri Jun 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
80- new upstream release
81
82* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
83- new upstream release
84
85* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
86- new upstream release
87- remove %%{name}-devel subpackage
88
89* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
90- new upstream release
91
92* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
93- initial build
94
Note: See TracBrowser for help on using the repository browser.