source: projects/specs/trunk/p/python3-pygobject/python3-pygobject-vl.spec @ 8011

Revision 8011, 2.5 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release

Line 
1%{!?python3_sitearch: %define python3_sitearch %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
2
3Name: python3-pygobject
4Summary: Python3 bindings for GObject Introspection
5Summary(ja): GObject Introspection の Python3 バインディング
6Version: 3.10.2
7Release: 1%{?_dist_release}
8
9Group: Development/Languages
10License: LGPL
11URL: http://www.pygtk.org/
12
13Source: http://ftp.gnome.org/pub/GNOME/sources/pygobject/3.10/pygobject-%{version}.tar.xz
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: glib2-devel >= 2.26.0
17BuildRequires: python3-devel >= 3.3
18BuildRequires: libffi-devel
19BuildRequires: libtool, automake
20BuildRequires: gobject-introspection-devel >= 0.9.8
21BuildRequires: python3-pycairo-devel >= 1.10.0
22Requires: python3 >= 3.3
23
24Obsoletes:      %{name}-doc < 3.10.0
25
26Vendor: Project Vine
27Distribution: Vine Linux
28Packager: Takemikaduchi
29
30%description
31pygobject provides a convenient wrapper for the GObject library
32for use in Python programs.
33
34%package devel
35Summary: Development files for building add-on libraries
36Group: Development/Libraries
37Requires: %{name} = %{version}-%{release}
38Requires: pygobject3-devel
39Requires: python3-devel
40
41%description devel
42This package contains files required to build wrappers for
43pygobject-based libraries such as pygtk2.
44
45
46%prep
47%setup -q -n pygobject-%{version}
48
49%build
50# --disable-docs doesn't work; it builds the docs anyway.
51%configure \
52    --enable-silent-rules \
53    --disable-static \
54    --enable-thread
55export tagname=CC
56make LIBTOOL=/usr/bin/libtool
57
58%install
59rm -rf $RPM_BUILD_ROOT
60export tagname=CC
61make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install
62
63find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
64rm -f examples/Makefile*
65
66# conflict with pygobject
67rm -rf $RPM_BUILD_ROOT%{python_sitearch}/gtk-2.0
68rm -rf $RPM_BUILD_ROOT%{_datadir}/pygobject
69
70# conflict with pygobject3
71rm -f $RPM_BUILD_ROOT%{_includedir}/pygobject-3.0/pygobject.h
72rm -f $RPM_BUILD_ROOT%{_libdir}/pkgconfig/pygobject-3.0.pc
73
74%clean
75rm -fr $RPM_BUILD_ROOT
76
77%files
78%defattr(644, root, root, 755)
79%doc AUTHORS NEWS README ChangeLog
80%{_libdir}/libpyglib-gi-2.0-python3.so.*
81%{python3_sitearch}/pygtkcompat
82%{python3_sitearch}/*.egg-info
83%{python3_sitearch}/gi
84
85%files devel
86%defattr(644, root, root, 755)
87%{_libdir}/libpyglib-gi-2.0-python3.so
88
89
90%changelog
91* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
92- new upstream release
93
94* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
95- initial build
96
Note: See TracBrowser for help on using the repository browser.