source: projects/specs/trunk/p/python3-pycairo/python3-pycairo-vl.spec @ 7938

Revision 7938, 1.6 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME-3.10.1

Line 
1%{!?python3_sitearch: %define python3_sitearch %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
2
3Name: python3-pycairo
4Summary: Python3 bindings for the cairo library
5Summary(ja): cairo ライブラリの Python3 バインディング
6Version: 1.10.0
7Release: 1%{?_dist_release}
8
9Group: Development/Languages
10License: LGPLv2
11URL: http://cairographics.org/pycairo
12
13Source: http://cairographics.org/releases/pycairo-%{version}.tar.bz2
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: cairo-devel >= 1.10.0
17BuildRequires: python3-devel >= 3.0
18BuildRequires: pkgconfig
19Requires: python3 >= 3.0
20Requires: cairo >= 1.10.0
21
22%description
23Python3 bindings for the cairo library.
24
25%package devel
26Summary: Libraries and headers for pycairo
27Group: Development/Libraries
28Requires: %{name} = %{version}-%{release}
29Requires: cairo-devel >= 1.10.0
30Requires: python3-devel >= 3.0
31
32%description devel
33This package contains files required to build wrappers for cairo add-on
34libraries so that they interoperate with pycairo3.
35
36%prep
37%setup -q -n pycairo-%{version}
38
39%build
40export PYTHON=python3
41python3 ./waf configure \
42                        --prefix=%{_prefix} \
43                        --libdir=%{_libdir}
44
45python3 ./waf build
46
47%install
48rm -rf $RPM_BUILD_ROOT
49
50DESTDIR=$RPM_BUILD_ROOT python3 ./waf install
51find $RPM_BUILD_ROOT -name '*.la' | xargs rm -f
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56%files
57%defattr(-,root,root,-)
58%doc AUTHORS COPYING* INSTALL NEWS README
59%{python3_sitearch}/cairo/
60
61%files devel
62%defattr(-,root,root,-)
63%{_includedir}/pycairo/py3cairo.h
64%{_libdir}/pkgconfig/py3cairo.pc
65
66%changelog
67* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
68- initial build
69
Note: See TracBrowser for help on using the repository browser.