source: projects/specs/trunk/p/python3-pycairo/python3-pycairo-vl.spec @ 9249

Revision 9249, 2.2 KB checked in by Takemikaduchi, 9 years ago (diff)

python3-{pyatspi,pycairo,pygobject},gedit,accerciser,eog-plugins: rebuild with python3
others: new upstream release

Line 
1%{!?python3_sitearch: %define python3_sitearch %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
2
3Name: python3-pycairo
4Summary: Python3 bindings for the cairo library
5Summary(ja): cairo ライブラリの Python3 バインディング
6Version: 1.10.0
7Release: 2%{?_dist_release}
8
9Group: Development/Languages
10License: LGPLv2
11URL: http://cairographics.org/pycairo
12
13Source: http://cairographics.org/releases/pycairo-%{version}.tar.bz2
14
15# patch from http://www.linuxfromscratch.org/blfs/view/svn/general/python-modules.html#pycairo
16Patch0: pycairo-1.10.0-waf_unpack-1.patch
17Patch1: pycairo-1.10.0-waf_python_3_4-1.patch
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: cairo-devel >= 1.10.0
21BuildRequires: python3-devel >= 3.0
22BuildRequires: pkgconfig
23Requires: python3 >= 3.0
24Requires: cairo >= 1.10.0
25
26%description
27Python3 bindings for the cairo library.
28
29%package devel
30Summary: Libraries and headers for pycairo
31Group: Development/Libraries
32Requires: %{name} = %{version}-%{release}
33Requires: cairo-devel >= 1.10.0
34Requires: python3-devel >= 3.0
35
36%description devel
37This package contains files required to build wrappers for cairo add-on
38libraries so that they interoperate with pycairo3.
39
40%prep
41%setup -q -n pycairo-%{version}
42
43# see http://www.linuxfromscratch.org/blfs/view/svn/general/python-modules.html#pycairo
44%patch0 -p1 -b .unpack
45wafdir=$(./waf unpack)
46pushd $wafdir
47%patch1 -p1 -b .py34
48popd
49unset wafdir
50
51%build
52export PYTHON=python3
53./waf configure \
54                        --prefix=%{_prefix} \
55                        --libdir=%{_libdir}
56
57./waf build
58
59%install
60rm -rf $RPM_BUILD_ROOT
61
62DESTDIR=$RPM_BUILD_ROOT python3 ./waf install
63find $RPM_BUILD_ROOT -name '*.la' | xargs rm -f
64
65%clean
66rm -rf $RPM_BUILD_ROOT
67
68%files
69%defattr(-,root,root,-)
70%doc AUTHORS COPYING* INSTALL NEWS README
71%{python3_sitearch}/cairo/
72
73%files devel
74%defattr(-,root,root,-)
75%{_includedir}/pycairo/py3cairo.h
76%{_libdir}/pkgconfig/py3cairo.pc
77
78%changelog
79* Mon Jan 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-2
80- rebuild with python-3.4.2
81- add Patch0 (pycairo-1.10.0-waf_unpack-1.patch)
82- add Patch1 (pycairo-1.10.0-waf_python_3_4-1.patch)
83
84* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
85- initial build
86
Note: See TracBrowser for help on using the repository browser.