source: projects/specs/trunk/p/python/python-vl.spec @ 644

Revision 644, 30.1 KB checked in by owa, 14 years ago (diff)

fixed missing of python-docs files

Line 
1# If you want to run test, add "--define '_run_test 1'" to rpm option
2%define run_test %{?_run_test:1}%{!?_run_test:0}
3%define unicode  ucs4
4%define bsddb_ver 4.8
5%define tcl_major 8.4
6%define tk_major 8.4
7%define tix_major 8.4
8%define pybasever 2.6
9%define python_lib %{_libdir}/python%{pybasever}
10
11Summary: An interpreted, interactive, object-oriented programming language.
12Summary(ja): オブジェクト指向言語 Python インタプリタ
13Name: python
14Version: %{pybasever}.5
15Release: 3%{?_dist_release}
16License: Modified CNRI Open Source License
17Group: Development/Languages
18URL: http://www.python.org/%{pybasever}/
19Source0: http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.bz2
20Source1: http://docs.python.org/archives/python-%{version}-docs-html.tar.bz2
21Source6: shmmodule.c
22
23# For TEST
24Source7: http://people.freebsd.org/~perky/i18n/EUC-CN.TXT
25Source8: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP936.TXT
26Source9: http://people.freebsd.org/~perky/i18n/BIG5HKSCS.TXT
27Source10: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP932.TXT
28Source11: http://people.freebsd.org/~perky/i18n/EUC-JP.TXT
29Source12: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/JIS/SHIFTJIS.TXT
30Source13: http://people.freebsd.org/~perky/i18n/EUC-JISX0213.TXT
31Source14: http://people.freebsd.org/~perky/i18n/SHIFT_JISX0213.TXT
32Source15: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP949.TXT
33Source16: http://people.freebsd.org/~perky/i18n/EUC-KR.TXT
34Source17: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/KSC/JOHAB.TXT
35Source18: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/OTHER/BIG5.TXT
36Source19: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP950.TXT
37Source20: http://www.unicode.org/Public/3.2-Update/NormalizationTest-3.2.0.txt
38
39Patch0: python-2.6.5-Setup.dist.patch
40Patch1: python-2.6.5-lib64.patch
41Patch3: Python-2.2.1-pydocnogui.patch
42Patch5: Python-2.3.3-distutilrpm.patch
43
44Patch10: python-2.6-db48.patch
45Patch11: http://bugs.python.org/file16549/python-support_bdb-4.8-v2.patch
46
47Obsoletes: python2
48Obsoletes: Distutils
49Obsoletes: python-base
50Provides: Distutils
51
52BuildRequires: db4-devel >= 4.8
53BuildRequires: readline-devel, libtermcap-devel, openssl-devel, gmp-devel
54BuildRequires: ncurses-devel, gdbm-devel, zlib-devel, expat-devel, tetex-latex
55BuildRequires: tk tix gcc-c++ glibc-devel
56BuildRequires: xorg-x11-devel mesa-libGL-devel
57BuildRequires: gzip tar /usr/bin/find pkgconfig bzip2-devel
58BuildRequires: nkf
59BuildRequires: sqlite3-devel
60BuildRoot: %{_tmppath}/%{name}-%{version}-root
61
62
63%description
64Python is an interpreted, interactive, object-oriented programming
65language.  It incorporates modules, exceptions, dynamic typing, very high
66level dynamic data types, and classes. Python combines remarkable power
67with very clear syntax. It has interfaces to many system calls and
68libraries, as well as to various window systems, and is extensible in C or
69C++. It is also usable as an extension language for applications that need
70a programmable interface.  Finally, Python is portable: it runs on many
71brands of UNIX, on PCs under Windows, MS-DOS, and OS/2, and on the
72Mac.
73
74%package devel
75Summary: The libraries and header files needed for Python development.
76Summary(ja): Python での開発に必要なライブラリやヘッダファイル
77Group: Development/Libraries
78Obsoletes: python2-devel
79
80%description devel
81The Python programming language's interpreter can be extended with
82dynamically loaded extensions and can be embedded in other programs.
83This package contains the header files and libraries needed to do
84these types of tasks.
85
86Install python-devel if you want to develop Python extensions.  The
87python package will also need to be installed.  You'll probably also
88want to install the python-docs package, which contains Python
89documentation.
90
91%package tools
92Summary: A collection of development tools included with Python.
93Summary(ja): Python に含まれる開発ツール一式
94Group: Development/Tools
95Requires: %{name} = %{version}
96Requires: tkinter = %{version}
97Obsoletes: python2-tools
98
99%description tools
100The Python package includes several development tools that are used
101to build python programs.  This package contains a selection of those
102tools, including the IDLE Python IDE.
103
104Install python-tools if you want to use these tools to develop
105Python programs.  You will also need to install the python and
106tkinter packages.
107
108%package docs
109Summary: Documentation for the Python programming language.
110Summary(ja): Python プログラミング言語のドキュメント
111Group: Applications/Documentation
112Obsoletes: python2-docs
113
114%description docs
115Documentation relating to the Python programming language in HTML and info
116formats.
117
118%package -n tkinter
119Summary: A graphical user interface for the Python scripting language.
120Summary(ja): Python スクリプト言語のグラフィカルインターフェイス
121Group: Development/Languages
122Obsoletes: tkinter2
123BuildRequires: tcl, tk
124Requires: %{name} = %{version}
125Requires: tix
126
127%description -n tkinter
128The Tkinter (Tk interface) program is an graphical user interface for
129the Python scripting language.
130
131You should install the tkinter package if you'd like to use a graphical
132user interface for Python programming.
133
134%prep
135%setup -q -n Python-%{version}
136%patch0 -p1 -b .~Setup
137%if %{_lib} == lib64
138%patch1 -p2 -b .~lib64
139%endif
140%patch3 -p1 -b .~no_gui
141%patch5 -p1 -b .~distutilrpm
142
143## for bsddb-4.8
144# %patch10 -p1 -b .db48
145%patch11 -p0 -b .~db48-v2
146
147# shm module
148cp %{SOURCE6} Modules
149cat >> Modules/Setup.dist << EOF
150
151# Shared memory module
152shm shmmodule.c
153EOF
154
155# Fix library flags
156pushd Modules
157mv Setup.dist Setup.dist.tmp
158cat Setup.dist.tmp \
159        | sed "s^-ldb-^-ldb-%{bsddb_ver}^" \
160        | sed "s^-ltcl^-ltcl%{tcl_major}^" \
161        | sed "s^-ltk^-ltk%{tk_major}^" \
162        | sed "s^-ltix^-ltix%{tix_major}^" \
163        > Setup.dist
164rm -f Setup.dist.tmp
165popd
166
167
168%build
169topdir=`pwd`
170export CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
171export CXXFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
172export OPT="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
173export LINKCC="gcc"
174if pkg-config openssl ; then
175        export CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
176        export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
177fi
178%configure --enable-ipv6 --enable-unicode=%{unicode} --enable-shared
179make OPT="$CFLAGS" %{?_smp_mflags}
180
181export LD_LIBRARY_PATH=$topdir
182export PATH="$topdir:$PATH"
183cp $topdir/python $topdir/python%{pybasever}
184$topdir/python Tools/scripts/pathfix.py -i "/usr/bin/env python%{pybasever}" .
185make OPT="$CFLAGS" %{?_smp_mflags}
186
187
188%if %{run_test}
189## Test
190#cp %{SOURCE7} ./
191#cp %{SOURCE8} ./
192#cp %{SOURCE9} ./
193#cp %{SOURCE10} ./
194#cp %{SOURCE11} ./
195#cp %{SOURCE12} ./
196#cp %{SOURCE13} ./
197#cp %{SOURCE14} ./
198#cp %{SOURCE15} ./
199#cp %{SOURCE16} ./
200#cp %{SOURCE17} ./
201#cp %{SOURCE18} ./
202#cp %{SOURCE19} ./
203#cp %{SOURCE20} ./
204# not nesessary?
205
206## This runs the test set twice (once with no compiled files, once with
207## the compiled files left by the previous test run).
208find ./Lib -name '*.py[co]' -print | xargs rm -f
209LD_LIBRARY_PATH=$topdir:$topdir/Modules:$topdir/build/lib.linux-%{_host_cpu}-%{pybasever}
210PYTHONPATH=$topdir/Lib:$topdir/Lib/test:$topdir/Lib/lib-tk:$topdir/Lib/site-packages
211PYTHONPATH=$PYTHONPATH:$LD_LIBRARY_PATH
212PYTHONHOME=$topdir
213export PYTHONHOME PYTHONPATH LD_LIBRARY_PATH
214./python -tt -E ./Lib/test/regrtest.py -l -w
215./python -tt -E ./Lib/test/regrtest.py -l -w
216## Mon Mar 22 2010: last tested
217## 328 tests OK.
218## 1 test failed: test_pydoc
219## 37 tests skipped:
220%endif
221
222
223%install
224rm -fr $RPM_BUILD_ROOT
225mkdir -p $RPM_BUILD_ROOT/usr $RPM_BUILD_ROOT%{_mandir}
226
227# Clean up patched .py files that are saved as .lib64
228for f in distutils/command/install distutils/sysconfig; do
229    rm -f Lib/$f.py.lib64
230done
231
232# Temporary workaround to avoid confusing find-requires: don't ship the tests
233# as executable files
234chmod 0644 Lib/test/test_*.py
235
236make DESTDIR=$RPM_BUILD_ROOT install
237
238# Fix the interpreter path in binaries installed by distutils
239# (which changes them by itself)
240# Make sure we preserve the file permissions
241for fixed in $RPM_BUILD_ROOT/usr/bin/pydoc; do
242    sed 's,#!.*/python$,#!/usr/bin/env python%{pybasever},' $fixed > $fixed- \
243        && cat $fixed- > $fixed && rm -f $fixed-
244done
245
246
247## tools
248mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages
249
250echo "#!/bin/bash
251exec %{python_lib}/site-packages/pynche/pynche" \
252        > $RPM_BUILD_ROOT/usr/bin/pynche
253chmod 755 $RPM_BUILD_ROOT/usr/bin/pynche
254
255echo "#!/bin/bash
256exec %{python_lib}/site-packages/modulator/modulator.py" \
257        > $RPM_BUILD_ROOT/usr/bin/modulator
258chmod 755 $RPM_BUILD_ROOT/usr/bin/modulator
259
260# idle
261mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
262install -m 755 ./Lib/idlelib/idle.py $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
263chmod 755 $RPM_BUILD_ROOT/usr/bin/idle
264
265#modulator
266cp -r Tools/modulator ${RPM_BUILD_ROOT}%{python_lib}/site-packages/
267
268#pynche
269rm -f Tools/pynche/*.pyw
270cp -r Tools/pynche $RPM_BUILD_ROOT%{python_lib}/site-packages/
271
272(mv Tools/modulator/README Tools/modulator/README.modulator)
273(mv Tools/pynche/README Tools/pynche/README.pynche)
274
275#gettext
276install -m755  Tools/i18n/pygettext.py $RPM_BUILD_ROOT/usr/bin/
277install -m755  Tools/i18n/msgfmt.py $RPM_BUILD_ROOT/usr/bin/
278
279# Get rid of crap
280find $RPM_BUILD_ROOT/ -name "*~"|xargs rm -f
281find $RPM_BUILD_ROOT/ -name ".cvsignore"|xargs rm -f
282find . -name "*~"|xargs rm -f
283find . -name ".cvsignore"|xargs rm -f
284#zero length
285rm -f $RPM_BUILD_ROOT%{python_lib}/site-packages/modulator/Templates/copyright
286
287# Clean up the testsuite - we don't need compiled files for it
288find $RPM_BUILD_ROOT%{python_lib}/test \
289    -name "*.pyc" -o -name "*.pyo" | xargs rm -f
290rm -f $RPM_BUILD_ROOT%{python_lib}/LICENSE.txt
291
292find $RPM_BUILD_ROOT%{python_lib}/lib-dynload -type f | grep -v _tkinter.so | sed "s|$RPM_BUILD_ROOT||" > dynfiles
293
294## Fix the file permissions
295chmod 755 $RPM_BUILD_ROOT%{python_lib}/lib-dynload/*.so
296chmod 755 $RPM_BUILD_ROOT%{_libdir}/libpython*.so.*
297find $RPM_BUILD_ROOT%{python_lib} -type f -name '*.py' | xargs chmod -x
298
299## docs
300if [ -d Doc/html ] ; then
301        rm Doc/html
302fi
303tar xvzf %SOURCE1
304mv python-%{version}-docs-html Doc/html
305
306
307%clean
308rm -fr $RPM_BUILD_ROOT
309
310
311%files -f dynfiles
312%defattr(-, root, root)
313%doc LICENSE README
314%{_bindir}/%{name}*
315%{_mandir}/*/*
316%{_libdir}/libpython%{pybasever}.so*
317%dir %{python_lib}
318%dir %{python_lib}/lib-dynload
319%dir %{python_lib}/site-packages
320%{python_lib}/*.py*
321%{python_lib}/*.doc
322%{python_lib}/bsddb
323%{python_lib}/compiler
324%{python_lib}/ctypes
325%{python_lib}/curses
326%{python_lib}/distutils
327%{python_lib}/email
328%{python_lib}/encodings
329%{python_lib}/hotshot
330%{python_lib}/idlelib
331%{python_lib}/json
332%{python_lib}/lib2to3
333%{python_lib}/logging
334%{python_lib}/multiprocessing
335%{python_lib}/plat-linux2
336%{python_lib}/sqlite3
337%{python_lib}/wsgiref
338%{python_lib}/wsgiref.egg-info
339%{python_lib}/xml
340
341%files devel
342%defattr(-,root,root)
343%{_includedir}/*
344%{python_lib}/config
345%{python_lib}/test
346
347%files tools
348%defattr(-,root,root,755)
349%doc Tools/modulator/README.modulator
350%doc Tools/pynche/README.pynche
351%{python_lib}/site-packages
352%{_bindir}/2to3
353%{_bindir}/idle
354%{_bindir}/modulator
355%{_bindir}/msgfmt.py
356%{_bindir}/pydoc
357%{_bindir}/pygettext.py
358%{_bindir}/pynche
359%{_bindir}/smtpd.py
360
361%files docs
362%defattr(-,root,root,755)
363%doc Misc/HISTORY Misc/NEWS  Misc/README Misc/cheatsheet Misc/developers.txt
364%doc Doc/html
365
366%files -n tkinter
367%defattr(-,root,root,755)
368%{python_lib}/lib-tk
369%{python_lib}/lib-dynload/_tkinter.so
370
371
372%changelog
373* Mon Mar 22 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-3
374- fixed missing of python-docs files
375- dropt '--with doc' option
376- dropt BR: latex2html
377- replaced descriptions (from Misc/RPM/python-2.6.spec in tar-ball)
378
379* Sun Mar 21 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-2
380- replaced Patch0: python-2.6.?-Setup.dist.patch
381- replaced Patch1: python-2.6.?-lib64.patch
382- added python-2.6.5-docs-html.tar.bz2
383- dropt Python-2.6.4-Doc.78718.tgz
384
385* Sat Mar 20 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-1
386- updated python to 2.6.5
387- updated Patch0: Python-2.6.4-Setup.dist.patch
388- added macro bsddb_ver
389- added Patch11: python-support_bdb-4.8-v2.patch (instead of Patch10: python-2.6-db48.patch)
390
391* Sat Mar 06 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-5
392- added Python-2.6.4-Doc.78718.tgz (documents from http://svn.python.org/projects)
393- changed default to '--with doc' again
394
395* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.4-4
396- rebuilt with gcc-4.4.3-3 on ppc
397- s/BuildPreReq/BuildRequires/
398
399* Thu Feb 04 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
400- replaced Python-%%{version}-Setup.dist.patch
401- added BR: sqlite3-devel
402
403* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-2
404- add Patch10 to build with db-4.8
405
406* Mon Feb 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-1
407- updated python to 2.6.4
408- changed default to '--without doc'
409- added Setup.dist.patch instead of Setup.dist{32,64}.patch
410- updated python-*-lib64.patch to 2.6.3
411
412* Mon Feb 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.5.5-1
413- updated python to 2.5.5
414
415* Wed May 06 2009 Shu KONNO <owa@bg.wakwak.com> 2.5.4-4vl5
416- added Python-2.5.4-{Setup,Setup64}.patch
417  - added _bsddb module
418  - dropt patch{0,9,10}
419
420* Sun May  3 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.4-3vl5
421- updated Patch0 for building with db-4.6.21
422
423* Thu Feb 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.4-2vl5
424- add patch10
425  - add -lcrypt for cryptmodule
426
427* Wed Dec 24 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.4-1vl5
428- new upstream release
429- changed typo of summary(ja)
430
431* Sat Dec 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.3-1vl5
432- new upstream release
433- dropt python-2.4.4_CVE-2007-4965.patch
434- dropt python-2.4.4_CVE-2008-1721.patch
435- dropt python-2.4.4-CVE-2008-1679.patch
436
437* Fri Jul 18 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.2-1vl5
438- updated python to 2.5.2
439- added python-2.5.2-config.patch instead of python-2.5c1-config.patch
440- added python-2.5.2-config64.patch instead of python-2.4.3-config.lib64.patch
441- added python-2.5.2-lib64.patch instead of python-2.4.2-lib64.patch
442- added modules ctypes, sqlite3, and wsgiref
443- dropt modules lib-old
444- dropt python-2.4.4_CVE-2008-1887.patch
445- dropt python-2.4.4_CVE-2007-2052.patch
446- fixed the file permissions
447
448* Sun Jun 08 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-1vl5
449- applied new versioning policy and spec in utf-8
450- added BuildPrereq: xorg-x11-devel
451- imported updates from Vine4.2
452        * Fri Apr 25 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.4vl4
453        - add patch120 for fix CVE-2008-1679 (added fix of CVE-2007-4965)
454        - add patch130 for fix CVE-2008-1887 (PyString_FromStringAndSize)
455        - add patch140 for fix CVE-2007-2052 (_localemodule.c off-by-one err)
456        * Mon Apr 21 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.3vl4
457        - add patch110 CVE-2008-1721 (zlib module)
458        - add remove unneeded files in Lib/test/
459        #- new versioning policy
460
461* Wed Mar 12 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-0vl1
462- updated python to 2.4.5
463
464* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.4-0vl7
465- rebuild with expat-2.0.1
466
467* Mon Feb 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl6
468- fix typo on Patch0 (s/db-4.2/db-4.3/)
469
470* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl5
471- rebuild with tcl/tk-8.4.18
472
473* Sat Dec 01 2007 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl4
474- imported updates from Vine4.2 Plus
475        * Thu Nov 01 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.2
476        - add BuildPrereq: nkf
477        * Wed Oct 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.1
478        - add patch100 for fix CVE-2007-4965 (imageop Module integer OF)
479
480* Sat Jun 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.4-0vl3
481- rebuilt with openssl-0.9.8e and tix-8.4.2
482- fixed spec file encoding
483
484* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl2
485- rebuilt with new toolchain and db4-4.3.x
486- modified Patch0 (s/db-4.2/db-4.3/)
487
488* Thu Oct 19 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl1
489- updated python to 2.4.4 (included security fix PSF-2006-001)
490- added japanese summary
491- updated patch8 (python-2.4.2-lib64.patch)
492- added patch9 (python-2.4.4c1-setup.lib64.patch)
493
494* Wed Sep 13 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.4.3-0vl4
495- change docs Group to Applications/Documentation. <BTS:VineLinux:163>
496
497* Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.4.3-0vl3
498- rebuild with readline-5.1 (x86_64)
499
500* Fri Apr 14 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl2
501- fixed python-2.4.3-config.patch cause undefined symbol: crypt
502
503* Thu Mar 30 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl1
504- updated python to 2.4.3
505- added python-2.4.3-config.patch instead of python-2.4.1c1-config.patch
506
507* Wed Feb 15 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl5
508- set permition of lib-dynload/*.so to 755
509- added without_doc option
510- rebuilt with x86_64
511
512* Thu Nov 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl4
513- add run_test option
514
515* Fri Nov  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3.2
516- add BuildPrereq: bzip2-devel
517- arrange testing script
518
519* Wed Nov 02 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl3.1
520- back to %%configure macro
521- change testing script
522
523* Mon Oct 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3
524- update Patch8 (VineSeed:10306)
525- use ./configure instead of %%configure script
526- add forgotten popd
527
528* Fri Oct 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl2
529- add --enable-shared to confiugre option
530- add %%{_libdir}/libpython2.4.so* to python package
531- add LD_LIBRARY_PATH=$topdir to use pathfix.py
532- change build method of Doc
533- add files for make test
534- change install method
535
536* Wed Sep 28 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl1
537- update python to 2.4.2 (final)
538
539* Wed Mar 30 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl1
540- update python to 2.4.1 (final)
541
542* Sat Mar 19 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c2
543- update python to 2.4.1c2
544- moved all site-packages files to python-tools package
545
546* Sat Mar 12 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c1
547- update python to 2.4.1c1
548- droped aspython2 macros
549- droped japanese-codecs module
550- droped Source2 idle, now it's provided from original source
551- droped Source3 modulator, now it's generated in a spec file
552- droped Source4 pynche, now it's generated in a spec file
553- droped Python-2.3.3-buildroot-bytecode.patch
554- changed python-2.3.3-config2.patch to python-2.4.1c1-config.patch
555
556* Wed Feb 09 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.5-0vl1
557- update python to 2.3.5
558
559* Fri Feb 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl6
560- add PSF-2005-001.patch
561
562* Wed Nov 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl4
563- rebuilt
564
565* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl3
566- modified Patch0 and Patch8 (-ldb-4.0 -> -ldb-4.2)
567
568* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl2
569- rebuilt with db4-4.2.25
570
571* Thu May 27 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl1
572- updated python to 2.3.4
573- fixed patch10, patch11
574
575* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl1
576- rebuild
577
578* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.3
579- updated python-2.3.3-config2.patch
580
581* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.2
582- added librarys 'logging, bsddb, idlelib' to /usr/lib/python2.3
583
584* Wed Apr 07 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.1
585- updated python to 2.3.3
586- changed version code 2.2.3 to 2.3.3 in source{2,3,4}
587- updated config2.patch for 2.3.3
588- updated nowhatsnew.patch for 2.3.3
589- updated distutilrpm.patch in which tabstops have made indent error
590- updated buildroot-bytecode.patch for 2.3.3
591- deleted buildroot.patch which fixed in 2.3.3
592- changed Tools/idle with Lib/idlelib
593
594* Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-3vl3
595- rebuild with openssl-0.9.7d
596
597* Wed Mar 03 2004 Shu KONNO <owa@bg.wakwak.com> 2.2.3-3vl2
598- updated JapaneseCodecs to 1.4.10
599
600* Wed Jul 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.3-3vl1
601- synced with RawHide 2.2.3-3 (substantially source ver up)
602
603* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.2-26vl1
604- rebuild with tcltk-8.4.2
605- synced with RawHide 2.2.2-26
606  * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
607  - rebuilt
608
609  * Mon Feb 24 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-25
610  - Fixed bug #84886: pydoc dies when run w/o arguments
611  - Fixed bug #84205: add python shm module back (used to be shipped with 1.5.2)
612  - Fixed bug #84966: path in byte-compiled code still wrong
613
614  * Thu Feb 20 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-23
615  - ftp uri's should be able to specify being rooted at the root instead of
616    where you login via ftp (#84692)
617
618  * Mon Feb 10 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-22
619  - Using newer Japanese codecs (1.4.9). Thanks to
620    Peter Bowen <pzb@datastacks.com> for pointing this out.
621
622  * Thu Feb  6 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-21
623  - Rebuild
624
625  * Wed Feb  5 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-20
626  - Release number bumped really high: turning on UCS4 (ABI compatibility
627    breakage)
628
629  * Fri Jan 31 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-13
630  - Attempt to look both in /usr/lib64 and /usr/lib/python2.2/site-packages/:
631    some work on python-2.2.2-lib64.patch
632
633  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-12
634  - Rebuild to incorporate the removal of .lib64 and - files.
635
636  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-11.7.3
637  - Fixed bug #82544: Errata removes most tools
638  - Fixed bug #82435: Python 2.2.2 errata breaks redhat-config-users
639  - Removed .lib64 and - files that get installed after we fix the multilib
640    .py files.
641
642  * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
643  - rebuilt
644
645  * Wed Jan 15 2003 Jens Petersen <petersen@redhat.com> 2.2.2-10
646  - rebuild to update tkinter's tcltk deps
647  - convert changelog to utf-8
648
649
650* Wed Jan 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.2-9vl0
651- rebuilt for Vine Linux against db4
652- obsolete python-base (which comes with python-2.2.1 of TestPkg)
653
654* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 2.2.2-9
655- rebuild
656
657* Fri Jan  3 2003 Nalin Dahyabhai <nalin@redhat.com>
658- pick up OpenSSL cflags and ldflags from pkgconfig if available
659
660* Thu Jan  2 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-8
661- urllib2 didn't support non-anonymous ftp.  add support based on how
662  urllib did it (#80676, #78168)
663
664* Mon Dec 16 2002 Mihai Ibanescu <misa@redhat.com> 2.2.2-7
665- Fix bug #79647 (Rebuild of SRPM fails if python isn't installed)
666- Added a bunch of missing BuildRequires found while fixing the
667  above-mentioned bug
668
669* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 2.2.2-6
670- rebuild to fix broken tcltk deps for tkinter
671
672* Fri Nov 22 2002 Mihai Ibanescu <misa@redhat.com>
6732.2.2-3.7.3
674- Recompiled for 7.3 (to fix the -lcrypt bug)
675- Fix for the spurious error message at the end of the build (build-requires
676  gets confused by executable files starting with """"): make the tests
677  non-executable.
678
679* Wed Nov 20 2002 Mihai Ibanescu <misa@redhat.com>
6802.2.2-5
681- Fixed configuration patch to add -lcrypt when compiling cryptmodule.c
682
6832.2.2-4
684- Spec file change from Matt Wilson <msw@redhat.com> to disable linking
685  with the C++ compiler.
686
687* Mon Nov 11 2002 Mihai Ibanescu <misa@redhat.com>
6882.2.2-3.*
689- Merged patch from Karsten Hopp <karsten@redhat.de> from 2.2.1-17hammer to
690  use %%{_libdir}
691- Added XFree86-libs as BuildRequires (because of tkinter)
692- Fixed duplicate listing of plat-linux2
693- Fixed exclusion of lib-dynload/japanese
694- Added lib64 patch for the japanese codecs
695- Use setup magic instead of using tar directly on JapaneseCodecs
696
697* Tue Nov  5 2002 Mihai Ibanescu <misa@redhat.com>
6982.2.2-2
699- Fix #76912 (python-tools contains idle, which uses tkinter, but there is no
700  requirement of tkinter from python-tools).
701- Fix #74013 (rpm is missing the /usr/lib/python2.2/test directory)
702
703* Mon Nov  4 2002 Mihai Ibanescu <misa@redhat.com>
704- builds as python2 require a different libdb
705- changed the buildroot name of python to match python2 builds
706
707* Fri Nov  1 2002 Mihai Ibanescu <misa@redhat.com>
708- updated python to 2.2.2 and adjusted the patches accordingly
709
710* Mon Oct 21 2002 Mihai Ibanescu <misa@redhat.com>
711- Fix #53930 (Python-2.2.1-buildroot-bytecode.patch)
712- Added BuildPrereq dependency on gcc-c++
713
714* Fri Aug 30 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-17
715- security fix for _execvpe
716
717* Tue Aug 13 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-16
718- Fix  #71011,#71134, #58157
719
720* Wed Aug  7 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-15
721- Resurrect tkinter
722- Fix for distutils (#67671)
723- Fix #69962
724
725* Thu Jul 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-14
726- Obsolete tkinter/tkinter2 (#69838)
727
728* Tue Jul 23 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-13
729- Doc fixes (#53951) - not on alpha at the momemt
730
731* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-12
732- fix pydoc (#68082)
733
734* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-11
735- Add db4-devel as a BuildPrereq
736
737* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.2.1-10
738- automated rebuild
739
740* Mon Jun 17 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-9
741- Add Japanese codecs (#66352)
742
743* Tue Jun 11 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-8
744- No more tkinter...
745
746* Wed May 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-7
747- Rebuild
748
749* Tue May 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-6
750- Add the email subcomponent (#65301)
751
752* Fri May 10 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-5
753- Rebuild
754
755* Thu May 02 2002 Than Ngo <than@redhat.com> 2.2.1-4
756- rebuild i new enviroment
757
758* Tue Apr 23 2002 Trond Eivind Glomsroed <teg@redhat.com>
759- Use ucs2, not ucs4, to avoid breaking tkinter (#63965)
760
761* Mon Apr 22 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-2
762- Make it use db4
763
764* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-1
765- 2.2.1 - a bugfix-only release
766
767* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-16
768- the same, but in builddirs - this will remove them from the
769  docs package, which doesn't look in the buildroot for files.
770
771* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-15
772- Get rid of temporary files and .cvsignores included
773  in the tarball and make install
774
775* Fri Apr  5 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-14
776- Don't own lib-tk in main package, only in tkinter (#62753)
777
778* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-13
779- rebuild
780
781* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-12
782- rebuild
783
784* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-11
785- Add a not to the Distutils obsoletes test (doh!)
786
787* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-10
788- Rebuild
789
790* Mon Feb 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-9
791- Only obsolete Distutils when built as python
792
793* Thu Feb 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-8
794- Make files in /usr/bin install side by side with python 1.5 when
795- Drop explicit requirement of db4
796  built as python2
797
798* Thu Jan 31 2002 Elliot Lee <sopwith@redhat.com> 2.2-7
799- Use version and pybasever macros to make updating easy
800- Use _smp_mflags macro
801
802* Tue Jan 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-6
803- Add db4-devel to BuildPrereq
804
805* Fri Jan 25 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-5
806- disable ndbm support, which is db2 in disguise (really interesting things
807  can happen when you mix db2 and db4 in a single application)
808
809* Thu Jan 24 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-4
810- Obsolete subpackages if necesarry
811- provide versioned python2
812- build with db4
813
814* Wed Jan 16 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-3
815- Alpha toolchain broken. Disable build on alpha.
816- New openssl
817
818* Wed Dec 26 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-1
819- 2.2 final
820
821* Fri Dec 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.11c1
822- 2.2 RC 1
823- Don't include the _tkinter module in the main package - it's
824  already in the tkiter packace
825- Turn off the mpzmodule, something broke in the buildroot
826
827* Wed Nov 28 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.10b2
828- Use -fPIC for OPT as well, in lack of a proper libpython.so
829
830* Mon Nov 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.9b2
831- changed DESTDIR to point to / so that distutils will install dynload
832  modules properly in the installroot
833
834* Fri Nov 16 2001 Matt Wilson <msw@redhat.com> 2.2-0.8b2
835- 2.2b2
836
837* Fri Oct 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.7b1
838- python2ify
839
840* Fri Oct 19 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.5b1
841- 2.2b1
842
843* Sun Sep 30 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.4a4
844- 2.2a4
845- Enable UCS4 support
846- Enable IPv6
847- Provide distutils
848- Include msgfmt.py and pygettext.py
849
850* Fri Sep 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.3a3
851- Obsolete Distutils, which is now part of the main package
852- Obsolete python2
853
854* Thu Sep 13 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.2a3
855- Add docs, tools and tkinter subpackages, to match the 1.5 layout
856
857* Wed Sep 12 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.1a3
858- 2.2a3
859- don't build tix and blt extensions
860
861* Mon Aug 13 2001 Trond Eivind Glomsroed <teg@redhat.com>
862- Add tk and tix to build dependencies
863
864* Sat Jul 21 2001 Trond Eivind Glomsroed <teg@redhat.com>
865- 2.1.1 bugfix release - with a GPL compatible license
866
867* Fri Jul 20 2001 Trond Eivind Glomsroed <teg@redhat.com>
868- Add new build dependencies (#49753)
869
870* Tue Jun 26 2001 Nalin Dahyabhai <nalin@redhat.com>
871- build with -fPIC
872
873* Fri Jun  1 2001 Trond Eivind Glomsroed <teg@redhat.com>
874- 2.1
875- reorganization of file includes
876
877* Wed Dec 20 2000 Trond Eivind Glomsroed <teg@redhat.com>
878- fix the "requires" clause, it lacked a space causing problems
879- use %%{_tmppath}
880- don't define name, version etc
881- add the available patches from the Python home page
882
883* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
884- added devel subpackage
885
886* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
887- modify all files to use "python2.0" as the intrepter
888- don't build the Expat bindings
889- build against db1
890
891* Mon Oct 16 2000 Jeremy Hylton <jeremy@beopen.com>
892- updated for 2.0 final
893
894* Mon Oct  9 2000 Jeremy Hylton <jeremy@beopen.com>
895- updated for 2.0c1
896- build audioop, imageop, and rgbimg extension modules
897- include xml.parsers subpackage
898- add test.xml.out to files list
899
900* Thu Oct  5 2000 Jeremy Hylton <jeremy@beopen.com>
901- added bin/python2.0 to files list (suggested by Martin v. Loewis)
902
903* Tue Sep 26 2000 Jeremy Hylton <jeremy@beopen.com>
904- updated for release 1 of 2.0b2
905- use .bz2 version of Python source
906
907* Tue Sep 12 2000 Jeremy Hylton <jeremy@beopen.com>
908- Version 2 of 2.0b1
909- Make the package relocatable.  Thanks to Suchandra Thapa.
910- Exclude Tkinter from main RPM.  If it is in a separate RPM, it is
911  easier to track Tk releases.
Note: See TracBrowser for help on using the repository browser.