source: projects/specs/trunk/p/python/python-vl.spec @ 2746

Revision 2746, 30.7 KB checked in by owa, 13 years ago (diff)

tix-8.4.3-1

Line 
1# If you want to run test, add "--define '_run_test 1'" to rpm option
2%define run_test %{?_run_test:1}%{!?_run_test:0}
3%define unicode  ucs4
4%define bsddb_ver 4.8
5%define tcl_major 8.4
6%define tk_major 8.4
7%define tix_major 8.4
8%define pybasever 2.6
9%define python_lib %{_libdir}/python%{pybasever}
10
11Summary: An interpreted, interactive, object-oriented programming language.
12Summary(ja): オブジェクト指向言語 Python インタプリタ
13Name: python
14Version: %{pybasever}.6
15Release: 3%{?_dist_release}
16License: Modified CNRI Open Source License
17Group: Development/Languages
18URL: http://www.python.org/%{pybasever}/
19Source0: http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.bz2
20Source1: http://docs.python.org/archives/python-%{version}-docs-html.tar.bz2
21Source6: shmmodule.c
22
23# For TEST
24Source7: http://people.freebsd.org/~perky/i18n/EUC-CN.TXT
25Source8: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP936.TXT
26Source9: http://people.freebsd.org/~perky/i18n/BIG5HKSCS.TXT
27Source10: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP932.TXT
28Source11: http://people.freebsd.org/~perky/i18n/EUC-JP.TXT
29Source12: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/JIS/SHIFTJIS.TXT
30Source13: http://people.freebsd.org/~perky/i18n/EUC-JISX0213.TXT
31Source14: http://people.freebsd.org/~perky/i18n/SHIFT_JISX0213.TXT
32Source15: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP949.TXT
33Source16: http://people.freebsd.org/~perky/i18n/EUC-KR.TXT
34Source17: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/KSC/JOHAB.TXT
35Source18: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/OTHER/BIG5.TXT
36Source19: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP950.TXT
37Source20: http://www.unicode.org/Public/3.2-Update/NormalizationTest-3.2.0.txt
38
39Patch0: python-2.6.5-Setup.dist.patch
40Patch1: python-2.6.6-lib64.patch
41Patch3: Python-2.2.1-pydocnogui.patch
42Patch5: Python-2.3.3-distutilrpm.patch
43
44Patch10: python-2.6-db48.patch
45Patch11: http://bugs.python.org/file16549/python-support_bdb-4.8-v2.patch
46
47Obsoletes: python2
48Obsoletes: Distutils
49Obsoletes: python-base
50Provides: Distutils
51
52BuildRequires: db4-devel >= 4.8
53BuildRequires: gzip tar gcc-c++ pkgconfig sed findutils
54BuildRequires: bzip2-devel
55BuildRequires: gdbm-devel
56BuildRequires: glibc-devel
57BuildRequires: ncurses-devel
58BuildRequires: openssl-devel
59BuildRequires: readline-devel
60BuildRequires: sqlite3-devel
61BuildRequires: zlib-devel
62BuildRequires: expat-devel
63BuildRequires: libtermcap-devel, gmp-devel
64#BuildRequires: tetex-latex
65Requires: bzip2
66Requires: gdbm
67Requires: ncurses
68Requires: openssl
69Requires: readline
70Requires: sqlite3
71Requires: zlib
72BuildRoot: %{_tmppath}/%{name}-%{version}-root
73
74
75%description
76Python is an interpreted, interactive, object-oriented programming
77language.  It incorporates modules, exceptions, dynamic typing, very high
78level dynamic data types, and classes. Python combines remarkable power
79with very clear syntax. It has interfaces to many system calls and
80libraries, as well as to various window systems, and is extensible in C or
81C++. It is also usable as an extension language for applications that need
82a programmable interface.  Finally, Python is portable: it runs on many
83brands of UNIX, on PCs under Windows, MS-DOS, and OS/2, and on the
84Mac.
85
86%package devel
87Summary: The libraries and header files needed for Python development.
88Summary(ja): Python での開発に必要なライブラリやヘッダファイル
89Group: Development/Libraries
90Obsoletes: python2-devel
91
92%description devel
93The Python programming language's interpreter can be extended with
94dynamically loaded extensions and can be embedded in other programs.
95This package contains the header files and libraries needed to do
96these types of tasks.
97
98Install python-devel if you want to develop Python extensions.  The
99python package will also need to be installed.  You'll probably also
100want to install the python-docs package, which contains Python
101documentation.
102
103%package tools
104Summary: A collection of development tools included with Python.
105Summary(ja): Python に含まれる開発ツール一式
106Group: Development/Tools
107Requires: %{name} = %{version}
108Requires: tkinter = %{version}
109Obsoletes: python2-tools
110
111%description tools
112The Python package includes several development tools that are used
113to build python programs.  This package contains a selection of those
114tools, including the IDLE Python IDE.
115
116Install python-tools if you want to use these tools to develop
117Python programs.  You will also need to install the python and
118tkinter packages.
119
120%package docs
121Summary: Documentation for the Python programming language.
122Summary(ja): Python プログラミング言語のドキュメント
123Group: Applications/Documentation
124Obsoletes: python2-docs
125
126%description docs
127Documentation relating to the Python programming language in HTML and info
128formats.
129
130%package -n tkinter
131Summary: A graphical user interface for the Python scripting language.
132Summary(ja): Python スクリプト言語のグラフィカルインターフェイス
133Group: Development/Languages
134Obsoletes: tkinter2
135Requires: %{name} = %{version}
136Requires: tcl, tk, tix
137BuildRequires: nkf
138BuildRequires: tcl, tk, tix
139BuildRequires: xorg-x11-devel mesa-libGL-devel
140
141
142%description -n tkinter
143The Tkinter (Tk interface) program is an graphical user interface for
144the Python scripting language.
145
146You should install the tkinter package if you'd like to use a graphical
147user interface for Python programming.
148
149%prep
150%setup -q -n Python-%{version}
151%patch0 -p1 -b .~Setup
152%if %{_lib} == lib64
153%patch1 -p2 -b .~lib64
154%endif
155%patch3 -p1 -b .~no_gui
156%patch5 -p1 -b .~distutilrpm
157
158## for bsddb-4.8
159# %patch10 -p1 -b .db48
160%patch11 -p0 -b .~db48-v2
161
162# shm module
163cp %{SOURCE6} Modules
164cat >> Modules/Setup.dist << EOF
165
166# Shared memory module
167shm shmmodule.c
168EOF
169
170# Fix library flags
171pushd Modules
172mv Setup.dist Setup.dist.tmp
173cat Setup.dist.tmp \
174        | sed "s^-ldb-^-ldb-%{bsddb_ver}^" \
175        | sed "s^-ltcl^-ltcl%{tcl_major}^" \
176        | sed "s^-ltk^-ltk%{tk_major}^" \
177        | sed "s^-ltix^-ltix%{tix_major}^" \
178        > Setup.dist
179rm -f Setup.dist.tmp
180popd
181
182
183%build
184topdir=`pwd`
185export CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
186export CXXFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
187export OPT="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
188export LINKCC="gcc"
189if pkg-config openssl ; then
190        export CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
191        export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
192fi
193%configure --enable-ipv6 --enable-unicode=%{unicode} --enable-shared
194make OPT="$CFLAGS" %{?_smp_mflags}
195
196export LD_LIBRARY_PATH=$topdir
197export PATH="$topdir:$PATH"
198cp $topdir/python $topdir/python%{pybasever}
199$topdir/python Tools/scripts/pathfix.py -i "/usr/bin/env python%{pybasever}" .
200make OPT="$CFLAGS" %{?_smp_mflags}
201
202
203%if %{run_test}
204## Test
205#cp %{SOURCE7} ./
206#cp %{SOURCE8} ./
207#cp %{SOURCE9} ./
208#cp %{SOURCE10} ./
209#cp %{SOURCE11} ./
210#cp %{SOURCE12} ./
211#cp %{SOURCE13} ./
212#cp %{SOURCE14} ./
213#cp %{SOURCE15} ./
214#cp %{SOURCE16} ./
215#cp %{SOURCE17} ./
216#cp %{SOURCE18} ./
217#cp %{SOURCE19} ./
218#cp %{SOURCE20} ./
219# not nesessary?
220
221## This runs the test set twice (once with no compiled files, once with
222## the compiled files left by the previous test run).
223find ./Lib -name '*.py[co]' -print | xargs rm -f
224LD_LIBRARY_PATH=$topdir:$topdir/Modules:$topdir/build/lib.linux-%{_host_cpu}-%{pybasever}
225PYTHONPATH=$topdir/Lib:$topdir/Lib/test:$topdir/Lib/lib-tk:$topdir/Lib/site-packages
226PYTHONPATH=$PYTHONPATH:$LD_LIBRARY_PATH
227PYTHONHOME=$topdir
228export PYTHONHOME PYTHONPATH LD_LIBRARY_PATH
229./python -tt -E ./Lib/test/regrtest.py -l -w
230./python -tt -E ./Lib/test/regrtest.py -l -w
231## Mon Mar 22 2010: last tested
232## 328 tests OK.
233## 1 test failed: test_pydoc
234## 37 tests skipped:
235%endif
236
237
238%install
239rm -fr $RPM_BUILD_ROOT
240mkdir -p $RPM_BUILD_ROOT/usr $RPM_BUILD_ROOT%{_mandir}
241
242# Clean up patched .py files that are saved as .lib64
243for f in distutils/command/install distutils/sysconfig; do
244    rm -f Lib/$f.py.lib64
245done
246
247# Temporary workaround to avoid confusing find-requires: don't ship the tests
248# as executable files
249chmod 0644 Lib/test/test_*.py
250
251make DESTDIR=$RPM_BUILD_ROOT install
252
253# Fix the interpreter path in binaries installed by distutils
254# (which changes them by itself)
255# Make sure we preserve the file permissions
256for fixed in $RPM_BUILD_ROOT/usr/bin/pydoc; do
257    sed 's,#!.*/python$,#!/usr/bin/env python%{pybasever},' $fixed > $fixed- \
258        && cat $fixed- > $fixed && rm -f $fixed-
259done
260
261
262## tools
263mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages
264
265echo "#!/bin/bash
266exec %{python_lib}/site-packages/pynche/pynche" \
267        > $RPM_BUILD_ROOT/usr/bin/pynche
268chmod 755 $RPM_BUILD_ROOT/usr/bin/pynche
269
270echo "#!/bin/bash
271exec %{python_lib}/site-packages/modulator/modulator.py" \
272        > $RPM_BUILD_ROOT/usr/bin/modulator
273chmod 755 $RPM_BUILD_ROOT/usr/bin/modulator
274
275# idle
276mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
277install -m 755 ./Lib/idlelib/idle.py $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
278chmod 755 $RPM_BUILD_ROOT/usr/bin/idle
279
280#modulator
281cp -r Tools/modulator ${RPM_BUILD_ROOT}%{python_lib}/site-packages/
282
283#pynche
284rm -f Tools/pynche/*.pyw
285cp -r Tools/pynche $RPM_BUILD_ROOT%{python_lib}/site-packages/
286
287(mv Tools/modulator/README Tools/modulator/README.modulator)
288(mv Tools/pynche/README Tools/pynche/README.pynche)
289
290#gettext
291install -m755  Tools/i18n/pygettext.py $RPM_BUILD_ROOT/usr/bin/
292install -m755  Tools/i18n/msgfmt.py $RPM_BUILD_ROOT/usr/bin/
293
294# Get rid of crap
295find $RPM_BUILD_ROOT/ -name "*~"|xargs rm -f
296find $RPM_BUILD_ROOT/ -name ".cvsignore"|xargs rm -f
297find . -name "*~"|xargs rm -f
298find . -name ".cvsignore"|xargs rm -f
299#zero length
300rm -f $RPM_BUILD_ROOT%{python_lib}/site-packages/modulator/Templates/copyright
301
302# Clean up the testsuite - we don't need compiled files for it
303find $RPM_BUILD_ROOT%{python_lib}/test \
304    -name "*.pyc" -o -name "*.pyo" | xargs rm -f
305rm -f $RPM_BUILD_ROOT%{python_lib}/LICENSE.txt
306
307find $RPM_BUILD_ROOT%{python_lib}/lib-dynload -type f | grep -v _tkinter.so | sed "s|$RPM_BUILD_ROOT||" > dynfiles
308
309## Fix the file permissions
310chmod 755 $RPM_BUILD_ROOT%{python_lib}/lib-dynload/*.so
311chmod 755 $RPM_BUILD_ROOT%{_libdir}/libpython*.so.*
312find $RPM_BUILD_ROOT%{python_lib} -type f -name '*.py' | xargs chmod -x
313
314## docs
315if [ -d Doc/html ] ; then
316        rm Doc/html
317fi
318tar xvzf %SOURCE1
319mv python-%{version}-docs-html Doc/html
320
321
322%clean
323rm -fr $RPM_BUILD_ROOT
324
325
326%files -f dynfiles
327%defattr(-, root, root)
328%doc LICENSE README
329%{_bindir}/%{name}*
330%{_mandir}/*/*
331%{_libdir}/libpython%{pybasever}.so*
332%dir %{python_lib}
333%dir %{python_lib}/lib-dynload
334%dir %{python_lib}/site-packages
335%{python_lib}/*.py*
336%{python_lib}/*.doc
337%{python_lib}/bsddb
338%{python_lib}/compiler
339%{python_lib}/ctypes
340%{python_lib}/curses
341%{python_lib}/distutils
342%{python_lib}/email
343%{python_lib}/encodings
344%{python_lib}/hotshot
345%{python_lib}/idlelib
346%{python_lib}/json
347%{python_lib}/lib2to3
348%{python_lib}/logging
349%{python_lib}/multiprocessing
350%{python_lib}/plat-linux2
351%{python_lib}/sqlite3
352%{python_lib}/wsgiref
353%{python_lib}/wsgiref.egg-info
354%{python_lib}/xml
355
356%files devel
357%defattr(-,root,root)
358%{_includedir}/*
359%{python_lib}/config
360%{python_lib}/test
361
362%files tools
363%defattr(-,root,root,755)
364%doc Tools/modulator/README.modulator
365%doc Tools/pynche/README.pynche
366%{python_lib}/site-packages
367%{_bindir}/2to3
368%{_bindir}/idle
369%{_bindir}/modulator
370%{_bindir}/msgfmt.py
371%{_bindir}/pydoc
372%{_bindir}/pygettext.py
373%{_bindir}/pynche
374%{_bindir}/smtpd.py
375
376%files docs
377%defattr(-,root,root,755)
378%doc Misc/HISTORY Misc/NEWS  Misc/README Misc/cheatsheet Misc/developers.txt
379%doc Doc/html
380
381%files -n tkinter
382%defattr(-,root,root,755)
383%{python_lib}/lib-tk
384%{python_lib}/lib-dynload/_tkinter.so
385
386
387%changelog
388* Tue Feb 22 2011 Shu KONNO <owa@bg.wakwak.com> 2.6.6-3
389- rebuild with tix-8.4.3, file-5.05-2
390
391* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.6-2
392- rebuild with openssl-1.0.0c
393
394* Wed Aug 25 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.6-1
395- updated python to 2.6.6
396- updated python-docs to 2.6.6
397- updated python-2.6.?-lib64.patch
398
399* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-4
400- rebuilt with tcl/tk-8.4.19-2
401
402* Mon Mar 22 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-3
403- fixed missing of python-docs files
404- dropt '--with doc' option
405- dropt BR: latex2html
406- replaced descriptions (from Misc/RPM/python-2.6.spec in tar-ball)
407
408* Sun Mar 21 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-2
409- replaced Patch0: python-2.6.?-Setup.dist.patch
410- replaced Patch1: python-2.6.?-lib64.patch
411- added python-2.6.5-docs-html.tar.bz2
412- dropt Python-2.6.4-Doc.78718.tgz
413
414* Sat Mar 20 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-1
415- updated python to 2.6.5
416- updated Patch0: Python-2.6.4-Setup.dist.patch
417- added macro bsddb_ver
418- added Patch11: python-support_bdb-4.8-v2.patch (instead of Patch10: python-2.6-db48.patch)
419
420* Sat Mar 06 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-5
421- added Python-2.6.4-Doc.78718.tgz (documents from http://svn.python.org/projects)
422- changed default to '--with doc' again
423
424* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.4-4
425- rebuilt with gcc-4.4.3-3 on ppc
426- s/BuildPreReq/BuildRequires/
427
428* Thu Feb 04 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
429- replaced Python-%%{version}-Setup.dist.patch
430- added BR: sqlite3-devel
431
432* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-2
433- add Patch10 to build with db-4.8
434
435* Mon Feb 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-1
436- updated python to 2.6.4
437- changed default to '--without doc'
438- added Setup.dist.patch instead of Setup.dist{32,64}.patch
439- updated python-*-lib64.patch to 2.6.3
440
441* Mon Feb 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.5.5-1
442- updated python to 2.5.5
443
444* Wed May 06 2009 Shu KONNO <owa@bg.wakwak.com> 2.5.4-4vl5
445- added Python-2.5.4-{Setup,Setup64}.patch
446  - added _bsddb module
447  - dropt patch{0,9,10}
448
449* Sun May  3 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.4-3vl5
450- updated Patch0 for building with db-4.6.21
451
452* Thu Feb 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.4-2vl5
453- add patch10
454  - add -lcrypt for cryptmodule
455
456* Wed Dec 24 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.4-1vl5
457- new upstream release
458- changed typo of summary(ja)
459
460* Sat Dec 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.3-1vl5
461- new upstream release
462- dropt python-2.4.4_CVE-2007-4965.patch
463- dropt python-2.4.4_CVE-2008-1721.patch
464- dropt python-2.4.4-CVE-2008-1679.patch
465
466* Fri Jul 18 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.2-1vl5
467- updated python to 2.5.2
468- added python-2.5.2-config.patch instead of python-2.5c1-config.patch
469- added python-2.5.2-config64.patch instead of python-2.4.3-config.lib64.patch
470- added python-2.5.2-lib64.patch instead of python-2.4.2-lib64.patch
471- added modules ctypes, sqlite3, and wsgiref
472- dropt modules lib-old
473- dropt python-2.4.4_CVE-2008-1887.patch
474- dropt python-2.4.4_CVE-2007-2052.patch
475- fixed the file permissions
476
477* Sun Jun 08 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-1vl5
478- applied new versioning policy and spec in utf-8
479- added BuildPrereq: xorg-x11-devel
480- imported updates from Vine4.2
481        * Fri Apr 25 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.4vl4
482        - add patch120 for fix CVE-2008-1679 (added fix of CVE-2007-4965)
483        - add patch130 for fix CVE-2008-1887 (PyString_FromStringAndSize)
484        - add patch140 for fix CVE-2007-2052 (_localemodule.c off-by-one err)
485        * Mon Apr 21 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.3vl4
486        - add patch110 CVE-2008-1721 (zlib module)
487        - add remove unneeded files in Lib/test/
488        #- new versioning policy
489
490* Wed Mar 12 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-0vl1
491- updated python to 2.4.5
492
493* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.4-0vl7
494- rebuild with expat-2.0.1
495
496* Mon Feb 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl6
497- fix typo on Patch0 (s/db-4.2/db-4.3/)
498
499* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl5
500- rebuild with tcl/tk-8.4.18
501
502* Sat Dec 01 2007 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl4
503- imported updates from Vine4.2 Plus
504        * Thu Nov 01 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.2
505        - add BuildPrereq: nkf
506        * Wed Oct 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.1
507        - add patch100 for fix CVE-2007-4965 (imageop Module integer OF)
508
509* Sat Jun 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.4-0vl3
510- rebuilt with openssl-0.9.8e and tix-8.4.2
511- fixed spec file encoding
512
513* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl2
514- rebuilt with new toolchain and db4-4.3.x
515- modified Patch0 (s/db-4.2/db-4.3/)
516
517* Thu Oct 19 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl1
518- updated python to 2.4.4 (included security fix PSF-2006-001)
519- added japanese summary
520- updated patch8 (python-2.4.2-lib64.patch)
521- added patch9 (python-2.4.4c1-setup.lib64.patch)
522
523* Wed Sep 13 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.4.3-0vl4
524- change docs Group to Applications/Documentation. <BTS:VineLinux:163>
525
526* Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.4.3-0vl3
527- rebuild with readline-5.1 (x86_64)
528
529* Fri Apr 14 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl2
530- fixed python-2.4.3-config.patch cause undefined symbol: crypt
531
532* Thu Mar 30 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl1
533- updated python to 2.4.3
534- added python-2.4.3-config.patch instead of python-2.4.1c1-config.patch
535
536* Wed Feb 15 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl5
537- set permition of lib-dynload/*.so to 755
538- added without_doc option
539- rebuilt with x86_64
540
541* Thu Nov 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl4
542- add run_test option
543
544* Fri Nov  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3.2
545- add BuildPrereq: bzip2-devel
546- arrange testing script
547
548* Wed Nov 02 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl3.1
549- back to %%configure macro
550- change testing script
551
552* Mon Oct 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3
553- update Patch8 (VineSeed:10306)
554- use ./configure instead of %%configure script
555- add forgotten popd
556
557* Fri Oct 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl2
558- add --enable-shared to confiugre option
559- add %%{_libdir}/libpython2.4.so* to python package
560- add LD_LIBRARY_PATH=$topdir to use pathfix.py
561- change build method of Doc
562- add files for make test
563- change install method
564
565* Wed Sep 28 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl1
566- update python to 2.4.2 (final)
567
568* Wed Mar 30 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl1
569- update python to 2.4.1 (final)
570
571* Sat Mar 19 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c2
572- update python to 2.4.1c2
573- moved all site-packages files to python-tools package
574
575* Sat Mar 12 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c1
576- update python to 2.4.1c1
577- droped aspython2 macros
578- droped japanese-codecs module
579- droped Source2 idle, now it's provided from original source
580- droped Source3 modulator, now it's generated in a spec file
581- droped Source4 pynche, now it's generated in a spec file
582- droped Python-2.3.3-buildroot-bytecode.patch
583- changed python-2.3.3-config2.patch to python-2.4.1c1-config.patch
584
585* Wed Feb 09 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.5-0vl1
586- update python to 2.3.5
587
588* Fri Feb 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl6
589- add PSF-2005-001.patch
590
591* Wed Nov 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl4
592- rebuilt
593
594* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl3
595- modified Patch0 and Patch8 (-ldb-4.0 -> -ldb-4.2)
596
597* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl2
598- rebuilt with db4-4.2.25
599
600* Thu May 27 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl1
601- updated python to 2.3.4
602- fixed patch10, patch11
603
604* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl1
605- rebuild
606
607* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.3
608- updated python-2.3.3-config2.patch
609
610* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.2
611- added librarys 'logging, bsddb, idlelib' to /usr/lib/python2.3
612
613* Wed Apr 07 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.1
614- updated python to 2.3.3
615- changed version code 2.2.3 to 2.3.3 in source{2,3,4}
616- updated config2.patch for 2.3.3
617- updated nowhatsnew.patch for 2.3.3
618- updated distutilrpm.patch in which tabstops have made indent error
619- updated buildroot-bytecode.patch for 2.3.3
620- deleted buildroot.patch which fixed in 2.3.3
621- changed Tools/idle with Lib/idlelib
622
623* Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-3vl3
624- rebuild with openssl-0.9.7d
625
626* Wed Mar 03 2004 Shu KONNO <owa@bg.wakwak.com> 2.2.3-3vl2
627- updated JapaneseCodecs to 1.4.10
628
629* Wed Jul 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.3-3vl1
630- synced with RawHide 2.2.3-3 (substantially source ver up)
631
632* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.2-26vl1
633- rebuild with tcltk-8.4.2
634- synced with RawHide 2.2.2-26
635  * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
636  - rebuilt
637
638  * Mon Feb 24 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-25
639  - Fixed bug #84886: pydoc dies when run w/o arguments
640  - Fixed bug #84205: add python shm module back (used to be shipped with 1.5.2)
641  - Fixed bug #84966: path in byte-compiled code still wrong
642
643  * Thu Feb 20 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-23
644  - ftp uri's should be able to specify being rooted at the root instead of
645    where you login via ftp (#84692)
646
647  * Mon Feb 10 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-22
648  - Using newer Japanese codecs (1.4.9). Thanks to
649    Peter Bowen <pzb@datastacks.com> for pointing this out.
650
651  * Thu Feb  6 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-21
652  - Rebuild
653
654  * Wed Feb  5 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-20
655  - Release number bumped really high: turning on UCS4 (ABI compatibility
656    breakage)
657
658  * Fri Jan 31 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-13
659  - Attempt to look both in /usr/lib64 and /usr/lib/python2.2/site-packages/:
660    some work on python-2.2.2-lib64.patch
661
662  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-12
663  - Rebuild to incorporate the removal of .lib64 and - files.
664
665  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-11.7.3
666  - Fixed bug #82544: Errata removes most tools
667  - Fixed bug #82435: Python 2.2.2 errata breaks redhat-config-users
668  - Removed .lib64 and - files that get installed after we fix the multilib
669    .py files.
670
671  * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
672  - rebuilt
673
674  * Wed Jan 15 2003 Jens Petersen <petersen@redhat.com> 2.2.2-10
675  - rebuild to update tkinter's tcltk deps
676  - convert changelog to utf-8
677
678
679* Wed Jan 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.2-9vl0
680- rebuilt for Vine Linux against db4
681- obsolete python-base (which comes with python-2.2.1 of TestPkg)
682
683* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 2.2.2-9
684- rebuild
685
686* Fri Jan  3 2003 Nalin Dahyabhai <nalin@redhat.com>
687- pick up OpenSSL cflags and ldflags from pkgconfig if available
688
689* Thu Jan  2 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-8
690- urllib2 didn't support non-anonymous ftp.  add support based on how
691  urllib did it (#80676, #78168)
692
693* Mon Dec 16 2002 Mihai Ibanescu <misa@redhat.com> 2.2.2-7
694- Fix bug #79647 (Rebuild of SRPM fails if python isn't installed)
695- Added a bunch of missing BuildRequires found while fixing the
696  above-mentioned bug
697
698* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 2.2.2-6
699- rebuild to fix broken tcltk deps for tkinter
700
701* Fri Nov 22 2002 Mihai Ibanescu <misa@redhat.com>
7022.2.2-3.7.3
703- Recompiled for 7.3 (to fix the -lcrypt bug)
704- Fix for the spurious error message at the end of the build (build-requires
705  gets confused by executable files starting with """"): make the tests
706  non-executable.
707
708* Wed Nov 20 2002 Mihai Ibanescu <misa@redhat.com>
7092.2.2-5
710- Fixed configuration patch to add -lcrypt when compiling cryptmodule.c
711
7122.2.2-4
713- Spec file change from Matt Wilson <msw@redhat.com> to disable linking
714  with the C++ compiler.
715
716* Mon Nov 11 2002 Mihai Ibanescu <misa@redhat.com>
7172.2.2-3.*
718- Merged patch from Karsten Hopp <karsten@redhat.de> from 2.2.1-17hammer to
719  use %%{_libdir}
720- Added XFree86-libs as BuildRequires (because of tkinter)
721- Fixed duplicate listing of plat-linux2
722- Fixed exclusion of lib-dynload/japanese
723- Added lib64 patch for the japanese codecs
724- Use setup magic instead of using tar directly on JapaneseCodecs
725
726* Tue Nov  5 2002 Mihai Ibanescu <misa@redhat.com>
7272.2.2-2
728- Fix #76912 (python-tools contains idle, which uses tkinter, but there is no
729  requirement of tkinter from python-tools).
730- Fix #74013 (rpm is missing the /usr/lib/python2.2/test directory)
731
732* Mon Nov  4 2002 Mihai Ibanescu <misa@redhat.com>
733- builds as python2 require a different libdb
734- changed the buildroot name of python to match python2 builds
735
736* Fri Nov  1 2002 Mihai Ibanescu <misa@redhat.com>
737- updated python to 2.2.2 and adjusted the patches accordingly
738
739* Mon Oct 21 2002 Mihai Ibanescu <misa@redhat.com>
740- Fix #53930 (Python-2.2.1-buildroot-bytecode.patch)
741- Added BuildPrereq dependency on gcc-c++
742
743* Fri Aug 30 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-17
744- security fix for _execvpe
745
746* Tue Aug 13 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-16
747- Fix  #71011,#71134, #58157
748
749* Wed Aug  7 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-15
750- Resurrect tkinter
751- Fix for distutils (#67671)
752- Fix #69962
753
754* Thu Jul 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-14
755- Obsolete tkinter/tkinter2 (#69838)
756
757* Tue Jul 23 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-13
758- Doc fixes (#53951) - not on alpha at the momemt
759
760* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-12
761- fix pydoc (#68082)
762
763* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-11
764- Add db4-devel as a BuildPrereq
765
766* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.2.1-10
767- automated rebuild
768
769* Mon Jun 17 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-9
770- Add Japanese codecs (#66352)
771
772* Tue Jun 11 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-8
773- No more tkinter...
774
775* Wed May 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-7
776- Rebuild
777
778* Tue May 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-6
779- Add the email subcomponent (#65301)
780
781* Fri May 10 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-5
782- Rebuild
783
784* Thu May 02 2002 Than Ngo <than@redhat.com> 2.2.1-4
785- rebuild i new enviroment
786
787* Tue Apr 23 2002 Trond Eivind Glomsroed <teg@redhat.com>
788- Use ucs2, not ucs4, to avoid breaking tkinter (#63965)
789
790* Mon Apr 22 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-2
791- Make it use db4
792
793* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-1
794- 2.2.1 - a bugfix-only release
795
796* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-16
797- the same, but in builddirs - this will remove them from the
798  docs package, which doesn't look in the buildroot for files.
799
800* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-15
801- Get rid of temporary files and .cvsignores included
802  in the tarball and make install
803
804* Fri Apr  5 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-14
805- Don't own lib-tk in main package, only in tkinter (#62753)
806
807* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-13
808- rebuild
809
810* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-12
811- rebuild
812
813* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-11
814- Add a not to the Distutils obsoletes test (doh!)
815
816* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-10
817- Rebuild
818
819* Mon Feb 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-9
820- Only obsolete Distutils when built as python
821
822* Thu Feb 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-8
823- Make files in /usr/bin install side by side with python 1.5 when
824- Drop explicit requirement of db4
825  built as python2
826
827* Thu Jan 31 2002 Elliot Lee <sopwith@redhat.com> 2.2-7
828- Use version and pybasever macros to make updating easy
829- Use _smp_mflags macro
830
831* Tue Jan 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-6
832- Add db4-devel to BuildPrereq
833
834* Fri Jan 25 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-5
835- disable ndbm support, which is db2 in disguise (really interesting things
836  can happen when you mix db2 and db4 in a single application)
837
838* Thu Jan 24 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-4
839- Obsolete subpackages if necesarry
840- provide versioned python2
841- build with db4
842
843* Wed Jan 16 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-3
844- Alpha toolchain broken. Disable build on alpha.
845- New openssl
846
847* Wed Dec 26 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-1
848- 2.2 final
849
850* Fri Dec 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.11c1
851- 2.2 RC 1
852- Don't include the _tkinter module in the main package - it's
853  already in the tkiter packace
854- Turn off the mpzmodule, something broke in the buildroot
855
856* Wed Nov 28 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.10b2
857- Use -fPIC for OPT as well, in lack of a proper libpython.so
858
859* Mon Nov 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.9b2
860- changed DESTDIR to point to / so that distutils will install dynload
861  modules properly in the installroot
862
863* Fri Nov 16 2001 Matt Wilson <msw@redhat.com> 2.2-0.8b2
864- 2.2b2
865
866* Fri Oct 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.7b1
867- python2ify
868
869* Fri Oct 19 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.5b1
870- 2.2b1
871
872* Sun Sep 30 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.4a4
873- 2.2a4
874- Enable UCS4 support
875- Enable IPv6
876- Provide distutils
877- Include msgfmt.py and pygettext.py
878
879* Fri Sep 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.3a3
880- Obsolete Distutils, which is now part of the main package
881- Obsolete python2
882
883* Thu Sep 13 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.2a3
884- Add docs, tools and tkinter subpackages, to match the 1.5 layout
885
886* Wed Sep 12 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.1a3
887- 2.2a3
888- don't build tix and blt extensions
889
890* Mon Aug 13 2001 Trond Eivind Glomsroed <teg@redhat.com>
891- Add tk and tix to build dependencies
892
893* Sat Jul 21 2001 Trond Eivind Glomsroed <teg@redhat.com>
894- 2.1.1 bugfix release - with a GPL compatible license
895
896* Fri Jul 20 2001 Trond Eivind Glomsroed <teg@redhat.com>
897- Add new build dependencies (#49753)
898
899* Tue Jun 26 2001 Nalin Dahyabhai <nalin@redhat.com>
900- build with -fPIC
901
902* Fri Jun  1 2001 Trond Eivind Glomsroed <teg@redhat.com>
903- 2.1
904- reorganization of file includes
905
906* Wed Dec 20 2000 Trond Eivind Glomsroed <teg@redhat.com>
907- fix the "requires" clause, it lacked a space causing problems
908- use %%{_tmppath}
909- don't define name, version etc
910- add the available patches from the Python home page
911
912* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
913- added devel subpackage
914
915* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
916- modify all files to use "python2.0" as the intrepter
917- don't build the Expat bindings
918- build against db1
919
920* Mon Oct 16 2000 Jeremy Hylton <jeremy@beopen.com>
921- updated for 2.0 final
922
923* Mon Oct  9 2000 Jeremy Hylton <jeremy@beopen.com>
924- updated for 2.0c1
925- build audioop, imageop, and rgbimg extension modules
926- include xml.parsers subpackage
927- add test.xml.out to files list
928
929* Thu Oct  5 2000 Jeremy Hylton <jeremy@beopen.com>
930- added bin/python2.0 to files list (suggested by Martin v. Loewis)
931
932* Tue Sep 26 2000 Jeremy Hylton <jeremy@beopen.com>
933- updated for release 1 of 2.0b2
934- use .bz2 version of Python source
935
936* Tue Sep 12 2000 Jeremy Hylton <jeremy@beopen.com>
937- Version 2 of 2.0b1
938- Make the package relocatable.  Thanks to Suchandra Thapa.
939- Exclude Tkinter from main RPM.  If it is in a separate RPM, it is
940  easier to track Tk releases.
Note: See TracBrowser for help on using the repository browser.