source: projects/specs/trunk/p/python/python-vl.spec @ 1262

Revision 1262, 30.4 KB checked in by owa, 14 years ago (diff)

updated tcl/tk

Line 
1# If you want to run test, add "--define '_run_test 1'" to rpm option
2%define run_test %{?_run_test:1}%{!?_run_test:0}
3%define unicode  ucs4
4%define bsddb_ver 4.8
5%define tcl_major 8.4
6%define tk_major 8.4
7%define tix_major 8.4
8%define pybasever 2.6
9%define python_lib %{_libdir}/python%{pybasever}
10
11Summary: An interpreted, interactive, object-oriented programming language.
12Summary(ja): オブジェクト指向言語 Python インタプリタ
13Name: python
14Version: %{pybasever}.5
15Release: 4%{?_dist_release}
16License: Modified CNRI Open Source License
17Group: Development/Languages
18URL: http://www.python.org/%{pybasever}/
19Source0: http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.bz2
20Source1: http://docs.python.org/archives/python-%{version}-docs-html.tar.bz2
21Source6: shmmodule.c
22
23# For TEST
24Source7: http://people.freebsd.org/~perky/i18n/EUC-CN.TXT
25Source8: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP936.TXT
26Source9: http://people.freebsd.org/~perky/i18n/BIG5HKSCS.TXT
27Source10: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP932.TXT
28Source11: http://people.freebsd.org/~perky/i18n/EUC-JP.TXT
29Source12: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/JIS/SHIFTJIS.TXT
30Source13: http://people.freebsd.org/~perky/i18n/EUC-JISX0213.TXT
31Source14: http://people.freebsd.org/~perky/i18n/SHIFT_JISX0213.TXT
32Source15: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP949.TXT
33Source16: http://people.freebsd.org/~perky/i18n/EUC-KR.TXT
34Source17: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/KSC/JOHAB.TXT
35Source18: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/OTHER/BIG5.TXT
36Source19: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP950.TXT
37Source20: http://www.unicode.org/Public/3.2-Update/NormalizationTest-3.2.0.txt
38
39Patch0: python-2.6.5-Setup.dist.patch
40Patch1: python-2.6.5-lib64.patch
41Patch3: Python-2.2.1-pydocnogui.patch
42Patch5: Python-2.3.3-distutilrpm.patch
43
44Patch10: python-2.6-db48.patch
45Patch11: http://bugs.python.org/file16549/python-support_bdb-4.8-v2.patch
46
47Obsoletes: python2
48Obsoletes: Distutils
49Obsoletes: python-base
50Provides: Distutils
51
52BuildRequires: db4-devel >= 4.8
53BuildRequires: gzip tar gcc-c++ pkgconfig sed findutils
54BuildRequires: bzip2-devel
55BuildRequires: gdbm-devel
56BuildRequires: glibc-devel
57BuildRequires: ncurses-devel
58BuildRequires: openssl-devel
59BuildRequires: readline-devel
60BuildRequires: sqlite3-devel
61BuildRequires: zlib-devel
62BuildRequires: expat-devel
63BuildRequires: libtermcap-devel, gmp-devel
64#BuildRequires: tetex-latex
65Requires: bzip2
66Requires: gdbm
67Requires: ncurses
68Requires: openssl
69Requires: readline
70Requires: sqlite3
71Requires: zlib
72BuildRoot: %{_tmppath}/%{name}-%{version}-root
73
74
75%description
76Python is an interpreted, interactive, object-oriented programming
77language.  It incorporates modules, exceptions, dynamic typing, very high
78level dynamic data types, and classes. Python combines remarkable power
79with very clear syntax. It has interfaces to many system calls and
80libraries, as well as to various window systems, and is extensible in C or
81C++. It is also usable as an extension language for applications that need
82a programmable interface.  Finally, Python is portable: it runs on many
83brands of UNIX, on PCs under Windows, MS-DOS, and OS/2, and on the
84Mac.
85
86%package devel
87Summary: The libraries and header files needed for Python development.
88Summary(ja): Python での開発に必要なライブラリやヘッダファイル
89Group: Development/Libraries
90Obsoletes: python2-devel
91
92%description devel
93The Python programming language's interpreter can be extended with
94dynamically loaded extensions and can be embedded in other programs.
95This package contains the header files and libraries needed to do
96these types of tasks.
97
98Install python-devel if you want to develop Python extensions.  The
99python package will also need to be installed.  You'll probably also
100want to install the python-docs package, which contains Python
101documentation.
102
103%package tools
104Summary: A collection of development tools included with Python.
105Summary(ja): Python に含まれる開発ツール一式
106Group: Development/Tools
107Requires: %{name} = %{version}
108Requires: tkinter = %{version}
109Obsoletes: python2-tools
110
111%description tools
112The Python package includes several development tools that are used
113to build python programs.  This package contains a selection of those
114tools, including the IDLE Python IDE.
115
116Install python-tools if you want to use these tools to develop
117Python programs.  You will also need to install the python and
118tkinter packages.
119
120%package docs
121Summary: Documentation for the Python programming language.
122Summary(ja): Python プログラミング言語のドキュメント
123Group: Applications/Documentation
124Obsoletes: python2-docs
125
126%description docs
127Documentation relating to the Python programming language in HTML and info
128formats.
129
130%package -n tkinter
131Summary: A graphical user interface for the Python scripting language.
132Summary(ja): Python スクリプト言語のグラフィカルインターフェイス
133Group: Development/Languages
134Obsoletes: tkinter2
135BuildRequires: tcl, tk
136Requires: %{name} = %{version}
137Requires: tcl, tk, tix
138BuildRequires: nkf
139BuildRequires: tcl, tk, tix
140BuildRequires: xorg-x11-devel mesa-libGL-devel
141
142
143%description -n tkinter
144The Tkinter (Tk interface) program is an graphical user interface for
145the Python scripting language.
146
147You should install the tkinter package if you'd like to use a graphical
148user interface for Python programming.
149
150%prep
151%setup -q -n Python-%{version}
152%patch0 -p1 -b .~Setup
153%if %{_lib} == lib64
154%patch1 -p2 -b .~lib64
155%endif
156%patch3 -p1 -b .~no_gui
157%patch5 -p1 -b .~distutilrpm
158
159## for bsddb-4.8
160# %patch10 -p1 -b .db48
161%patch11 -p0 -b .~db48-v2
162
163# shm module
164cp %{SOURCE6} Modules
165cat >> Modules/Setup.dist << EOF
166
167# Shared memory module
168shm shmmodule.c
169EOF
170
171# Fix library flags
172pushd Modules
173mv Setup.dist Setup.dist.tmp
174cat Setup.dist.tmp \
175        | sed "s^-ldb-^-ldb-%{bsddb_ver}^" \
176        | sed "s^-ltcl^-ltcl%{tcl_major}^" \
177        | sed "s^-ltk^-ltk%{tk_major}^" \
178        | sed "s^-ltix^-ltix%{tix_major}^" \
179        > Setup.dist
180rm -f Setup.dist.tmp
181popd
182
183
184%build
185topdir=`pwd`
186export CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
187export CXXFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
188export OPT="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
189export LINKCC="gcc"
190if pkg-config openssl ; then
191        export CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
192        export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
193fi
194%configure --enable-ipv6 --enable-unicode=%{unicode} --enable-shared
195make OPT="$CFLAGS" %{?_smp_mflags}
196
197export LD_LIBRARY_PATH=$topdir
198export PATH="$topdir:$PATH"
199cp $topdir/python $topdir/python%{pybasever}
200$topdir/python Tools/scripts/pathfix.py -i "/usr/bin/env python%{pybasever}" .
201make OPT="$CFLAGS" %{?_smp_mflags}
202
203
204%if %{run_test}
205## Test
206#cp %{SOURCE7} ./
207#cp %{SOURCE8} ./
208#cp %{SOURCE9} ./
209#cp %{SOURCE10} ./
210#cp %{SOURCE11} ./
211#cp %{SOURCE12} ./
212#cp %{SOURCE13} ./
213#cp %{SOURCE14} ./
214#cp %{SOURCE15} ./
215#cp %{SOURCE16} ./
216#cp %{SOURCE17} ./
217#cp %{SOURCE18} ./
218#cp %{SOURCE19} ./
219#cp %{SOURCE20} ./
220# not nesessary?
221
222## This runs the test set twice (once with no compiled files, once with
223## the compiled files left by the previous test run).
224find ./Lib -name '*.py[co]' -print | xargs rm -f
225LD_LIBRARY_PATH=$topdir:$topdir/Modules:$topdir/build/lib.linux-%{_host_cpu}-%{pybasever}
226PYTHONPATH=$topdir/Lib:$topdir/Lib/test:$topdir/Lib/lib-tk:$topdir/Lib/site-packages
227PYTHONPATH=$PYTHONPATH:$LD_LIBRARY_PATH
228PYTHONHOME=$topdir
229export PYTHONHOME PYTHONPATH LD_LIBRARY_PATH
230./python -tt -E ./Lib/test/regrtest.py -l -w
231./python -tt -E ./Lib/test/regrtest.py -l -w
232## Mon Mar 22 2010: last tested
233## 328 tests OK.
234## 1 test failed: test_pydoc
235## 37 tests skipped:
236%endif
237
238
239%install
240rm -fr $RPM_BUILD_ROOT
241mkdir -p $RPM_BUILD_ROOT/usr $RPM_BUILD_ROOT%{_mandir}
242
243# Clean up patched .py files that are saved as .lib64
244for f in distutils/command/install distutils/sysconfig; do
245    rm -f Lib/$f.py.lib64
246done
247
248# Temporary workaround to avoid confusing find-requires: don't ship the tests
249# as executable files
250chmod 0644 Lib/test/test_*.py
251
252make DESTDIR=$RPM_BUILD_ROOT install
253
254# Fix the interpreter path in binaries installed by distutils
255# (which changes them by itself)
256# Make sure we preserve the file permissions
257for fixed in $RPM_BUILD_ROOT/usr/bin/pydoc; do
258    sed 's,#!.*/python$,#!/usr/bin/env python%{pybasever},' $fixed > $fixed- \
259        && cat $fixed- > $fixed && rm -f $fixed-
260done
261
262
263## tools
264mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages
265
266echo "#!/bin/bash
267exec %{python_lib}/site-packages/pynche/pynche" \
268        > $RPM_BUILD_ROOT/usr/bin/pynche
269chmod 755 $RPM_BUILD_ROOT/usr/bin/pynche
270
271echo "#!/bin/bash
272exec %{python_lib}/site-packages/modulator/modulator.py" \
273        > $RPM_BUILD_ROOT/usr/bin/modulator
274chmod 755 $RPM_BUILD_ROOT/usr/bin/modulator
275
276# idle
277mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
278install -m 755 ./Lib/idlelib/idle.py $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
279chmod 755 $RPM_BUILD_ROOT/usr/bin/idle
280
281#modulator
282cp -r Tools/modulator ${RPM_BUILD_ROOT}%{python_lib}/site-packages/
283
284#pynche
285rm -f Tools/pynche/*.pyw
286cp -r Tools/pynche $RPM_BUILD_ROOT%{python_lib}/site-packages/
287
288(mv Tools/modulator/README Tools/modulator/README.modulator)
289(mv Tools/pynche/README Tools/pynche/README.pynche)
290
291#gettext
292install -m755  Tools/i18n/pygettext.py $RPM_BUILD_ROOT/usr/bin/
293install -m755  Tools/i18n/msgfmt.py $RPM_BUILD_ROOT/usr/bin/
294
295# Get rid of crap
296find $RPM_BUILD_ROOT/ -name "*~"|xargs rm -f
297find $RPM_BUILD_ROOT/ -name ".cvsignore"|xargs rm -f
298find . -name "*~"|xargs rm -f
299find . -name ".cvsignore"|xargs rm -f
300#zero length
301rm -f $RPM_BUILD_ROOT%{python_lib}/site-packages/modulator/Templates/copyright
302
303# Clean up the testsuite - we don't need compiled files for it
304find $RPM_BUILD_ROOT%{python_lib}/test \
305    -name "*.pyc" -o -name "*.pyo" | xargs rm -f
306rm -f $RPM_BUILD_ROOT%{python_lib}/LICENSE.txt
307
308find $RPM_BUILD_ROOT%{python_lib}/lib-dynload -type f | grep -v _tkinter.so | sed "s|$RPM_BUILD_ROOT||" > dynfiles
309
310## Fix the file permissions
311chmod 755 $RPM_BUILD_ROOT%{python_lib}/lib-dynload/*.so
312chmod 755 $RPM_BUILD_ROOT%{_libdir}/libpython*.so.*
313find $RPM_BUILD_ROOT%{python_lib} -type f -name '*.py' | xargs chmod -x
314
315## docs
316if [ -d Doc/html ] ; then
317        rm Doc/html
318fi
319tar xvzf %SOURCE1
320mv python-%{version}-docs-html Doc/html
321
322
323%clean
324rm -fr $RPM_BUILD_ROOT
325
326
327%files -f dynfiles
328%defattr(-, root, root)
329%doc LICENSE README
330%{_bindir}/%{name}*
331%{_mandir}/*/*
332%{_libdir}/libpython%{pybasever}.so*
333%dir %{python_lib}
334%dir %{python_lib}/lib-dynload
335%dir %{python_lib}/site-packages
336%{python_lib}/*.py*
337%{python_lib}/*.doc
338%{python_lib}/bsddb
339%{python_lib}/compiler
340%{python_lib}/ctypes
341%{python_lib}/curses
342%{python_lib}/distutils
343%{python_lib}/email
344%{python_lib}/encodings
345%{python_lib}/hotshot
346%{python_lib}/idlelib
347%{python_lib}/json
348%{python_lib}/lib2to3
349%{python_lib}/logging
350%{python_lib}/multiprocessing
351%{python_lib}/plat-linux2
352%{python_lib}/sqlite3
353%{python_lib}/wsgiref
354%{python_lib}/wsgiref.egg-info
355%{python_lib}/xml
356
357%files devel
358%defattr(-,root,root)
359%{_includedir}/*
360%{python_lib}/config
361%{python_lib}/test
362
363%files tools
364%defattr(-,root,root,755)
365%doc Tools/modulator/README.modulator
366%doc Tools/pynche/README.pynche
367%{python_lib}/site-packages
368%{_bindir}/2to3
369%{_bindir}/idle
370%{_bindir}/modulator
371%{_bindir}/msgfmt.py
372%{_bindir}/pydoc
373%{_bindir}/pygettext.py
374%{_bindir}/pynche
375%{_bindir}/smtpd.py
376
377%files docs
378%defattr(-,root,root,755)
379%doc Misc/HISTORY Misc/NEWS  Misc/README Misc/cheatsheet Misc/developers.txt
380%doc Doc/html
381
382%files -n tkinter
383%defattr(-,root,root,755)
384%{python_lib}/lib-tk
385%{python_lib}/lib-dynload/_tkinter.so
386
387
388%changelog
389* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-4
390- rebuilt with tcl/tk-8.4.19-2
391
392* Mon Mar 22 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-3
393- fixed missing of python-docs files
394- dropt '--with doc' option
395- dropt BR: latex2html
396- replaced descriptions (from Misc/RPM/python-2.6.spec in tar-ball)
397
398* Sun Mar 21 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-2
399- replaced Patch0: python-2.6.?-Setup.dist.patch
400- replaced Patch1: python-2.6.?-lib64.patch
401- added python-2.6.5-docs-html.tar.bz2
402- dropt Python-2.6.4-Doc.78718.tgz
403
404* Sat Mar 20 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-1
405- updated python to 2.6.5
406- updated Patch0: Python-2.6.4-Setup.dist.patch
407- added macro bsddb_ver
408- added Patch11: python-support_bdb-4.8-v2.patch (instead of Patch10: python-2.6-db48.patch)
409
410* Sat Mar 06 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-5
411- added Python-2.6.4-Doc.78718.tgz (documents from http://svn.python.org/projects)
412- changed default to '--with doc' again
413
414* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.4-4
415- rebuilt with gcc-4.4.3-3 on ppc
416- s/BuildPreReq/BuildRequires/
417
418* Thu Feb 04 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
419- replaced Python-%%{version}-Setup.dist.patch
420- added BR: sqlite3-devel
421
422* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-2
423- add Patch10 to build with db-4.8
424
425* Mon Feb 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-1
426- updated python to 2.6.4
427- changed default to '--without doc'
428- added Setup.dist.patch instead of Setup.dist{32,64}.patch
429- updated python-*-lib64.patch to 2.6.3
430
431* Mon Feb 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.5.5-1
432- updated python to 2.5.5
433
434* Wed May 06 2009 Shu KONNO <owa@bg.wakwak.com> 2.5.4-4vl5
435- added Python-2.5.4-{Setup,Setup64}.patch
436  - added _bsddb module
437  - dropt patch{0,9,10}
438
439* Sun May  3 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.4-3vl5
440- updated Patch0 for building with db-4.6.21
441
442* Thu Feb 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.4-2vl5
443- add patch10
444  - add -lcrypt for cryptmodule
445
446* Wed Dec 24 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.4-1vl5
447- new upstream release
448- changed typo of summary(ja)
449
450* Sat Dec 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.3-1vl5
451- new upstream release
452- dropt python-2.4.4_CVE-2007-4965.patch
453- dropt python-2.4.4_CVE-2008-1721.patch
454- dropt python-2.4.4-CVE-2008-1679.patch
455
456* Fri Jul 18 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.2-1vl5
457- updated python to 2.5.2
458- added python-2.5.2-config.patch instead of python-2.5c1-config.patch
459- added python-2.5.2-config64.patch instead of python-2.4.3-config.lib64.patch
460- added python-2.5.2-lib64.patch instead of python-2.4.2-lib64.patch
461- added modules ctypes, sqlite3, and wsgiref
462- dropt modules lib-old
463- dropt python-2.4.4_CVE-2008-1887.patch
464- dropt python-2.4.4_CVE-2007-2052.patch
465- fixed the file permissions
466
467* Sun Jun 08 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-1vl5
468- applied new versioning policy and spec in utf-8
469- added BuildPrereq: xorg-x11-devel
470- imported updates from Vine4.2
471        * Fri Apr 25 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.4vl4
472        - add patch120 for fix CVE-2008-1679 (added fix of CVE-2007-4965)
473        - add patch130 for fix CVE-2008-1887 (PyString_FromStringAndSize)
474        - add patch140 for fix CVE-2007-2052 (_localemodule.c off-by-one err)
475        * Mon Apr 21 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.3vl4
476        - add patch110 CVE-2008-1721 (zlib module)
477        - add remove unneeded files in Lib/test/
478        #- new versioning policy
479
480* Wed Mar 12 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-0vl1
481- updated python to 2.4.5
482
483* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.4-0vl7
484- rebuild with expat-2.0.1
485
486* Mon Feb 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl6
487- fix typo on Patch0 (s/db-4.2/db-4.3/)
488
489* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl5
490- rebuild with tcl/tk-8.4.18
491
492* Sat Dec 01 2007 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl4
493- imported updates from Vine4.2 Plus
494        * Thu Nov 01 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.2
495        - add BuildPrereq: nkf
496        * Wed Oct 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.1
497        - add patch100 for fix CVE-2007-4965 (imageop Module integer OF)
498
499* Sat Jun 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.4-0vl3
500- rebuilt with openssl-0.9.8e and tix-8.4.2
501- fixed spec file encoding
502
503* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl2
504- rebuilt with new toolchain and db4-4.3.x
505- modified Patch0 (s/db-4.2/db-4.3/)
506
507* Thu Oct 19 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl1
508- updated python to 2.4.4 (included security fix PSF-2006-001)
509- added japanese summary
510- updated patch8 (python-2.4.2-lib64.patch)
511- added patch9 (python-2.4.4c1-setup.lib64.patch)
512
513* Wed Sep 13 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.4.3-0vl4
514- change docs Group to Applications/Documentation. <BTS:VineLinux:163>
515
516* Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.4.3-0vl3
517- rebuild with readline-5.1 (x86_64)
518
519* Fri Apr 14 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl2
520- fixed python-2.4.3-config.patch cause undefined symbol: crypt
521
522* Thu Mar 30 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl1
523- updated python to 2.4.3
524- added python-2.4.3-config.patch instead of python-2.4.1c1-config.patch
525
526* Wed Feb 15 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl5
527- set permition of lib-dynload/*.so to 755
528- added without_doc option
529- rebuilt with x86_64
530
531* Thu Nov 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl4
532- add run_test option
533
534* Fri Nov  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3.2
535- add BuildPrereq: bzip2-devel
536- arrange testing script
537
538* Wed Nov 02 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl3.1
539- back to %%configure macro
540- change testing script
541
542* Mon Oct 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3
543- update Patch8 (VineSeed:10306)
544- use ./configure instead of %%configure script
545- add forgotten popd
546
547* Fri Oct 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl2
548- add --enable-shared to confiugre option
549- add %%{_libdir}/libpython2.4.so* to python package
550- add LD_LIBRARY_PATH=$topdir to use pathfix.py
551- change build method of Doc
552- add files for make test
553- change install method
554
555* Wed Sep 28 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl1
556- update python to 2.4.2 (final)
557
558* Wed Mar 30 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl1
559- update python to 2.4.1 (final)
560
561* Sat Mar 19 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c2
562- update python to 2.4.1c2
563- moved all site-packages files to python-tools package
564
565* Sat Mar 12 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c1
566- update python to 2.4.1c1
567- droped aspython2 macros
568- droped japanese-codecs module
569- droped Source2 idle, now it's provided from original source
570- droped Source3 modulator, now it's generated in a spec file
571- droped Source4 pynche, now it's generated in a spec file
572- droped Python-2.3.3-buildroot-bytecode.patch
573- changed python-2.3.3-config2.patch to python-2.4.1c1-config.patch
574
575* Wed Feb 09 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.5-0vl1
576- update python to 2.3.5
577
578* Fri Feb 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl6
579- add PSF-2005-001.patch
580
581* Wed Nov 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl4
582- rebuilt
583
584* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl3
585- modified Patch0 and Patch8 (-ldb-4.0 -> -ldb-4.2)
586
587* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl2
588- rebuilt with db4-4.2.25
589
590* Thu May 27 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl1
591- updated python to 2.3.4
592- fixed patch10, patch11
593
594* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl1
595- rebuild
596
597* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.3
598- updated python-2.3.3-config2.patch
599
600* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.2
601- added librarys 'logging, bsddb, idlelib' to /usr/lib/python2.3
602
603* Wed Apr 07 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.1
604- updated python to 2.3.3
605- changed version code 2.2.3 to 2.3.3 in source{2,3,4}
606- updated config2.patch for 2.3.3
607- updated nowhatsnew.patch for 2.3.3
608- updated distutilrpm.patch in which tabstops have made indent error
609- updated buildroot-bytecode.patch for 2.3.3
610- deleted buildroot.patch which fixed in 2.3.3
611- changed Tools/idle with Lib/idlelib
612
613* Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-3vl3
614- rebuild with openssl-0.9.7d
615
616* Wed Mar 03 2004 Shu KONNO <owa@bg.wakwak.com> 2.2.3-3vl2
617- updated JapaneseCodecs to 1.4.10
618
619* Wed Jul 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.3-3vl1
620- synced with RawHide 2.2.3-3 (substantially source ver up)
621
622* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.2-26vl1
623- rebuild with tcltk-8.4.2
624- synced with RawHide 2.2.2-26
625  * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
626  - rebuilt
627
628  * Mon Feb 24 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-25
629  - Fixed bug #84886: pydoc dies when run w/o arguments
630  - Fixed bug #84205: add python shm module back (used to be shipped with 1.5.2)
631  - Fixed bug #84966: path in byte-compiled code still wrong
632
633  * Thu Feb 20 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-23
634  - ftp uri's should be able to specify being rooted at the root instead of
635    where you login via ftp (#84692)
636
637  * Mon Feb 10 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-22
638  - Using newer Japanese codecs (1.4.9). Thanks to
639    Peter Bowen <pzb@datastacks.com> for pointing this out.
640
641  * Thu Feb  6 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-21
642  - Rebuild
643
644  * Wed Feb  5 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-20
645  - Release number bumped really high: turning on UCS4 (ABI compatibility
646    breakage)
647
648  * Fri Jan 31 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-13
649  - Attempt to look both in /usr/lib64 and /usr/lib/python2.2/site-packages/:
650    some work on python-2.2.2-lib64.patch
651
652  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-12
653  - Rebuild to incorporate the removal of .lib64 and - files.
654
655  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-11.7.3
656  - Fixed bug #82544: Errata removes most tools
657  - Fixed bug #82435: Python 2.2.2 errata breaks redhat-config-users
658  - Removed .lib64 and - files that get installed after we fix the multilib
659    .py files.
660
661  * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
662  - rebuilt
663
664  * Wed Jan 15 2003 Jens Petersen <petersen@redhat.com> 2.2.2-10
665  - rebuild to update tkinter's tcltk deps
666  - convert changelog to utf-8
667
668
669* Wed Jan 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.2-9vl0
670- rebuilt for Vine Linux against db4
671- obsolete python-base (which comes with python-2.2.1 of TestPkg)
672
673* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 2.2.2-9
674- rebuild
675
676* Fri Jan  3 2003 Nalin Dahyabhai <nalin@redhat.com>
677- pick up OpenSSL cflags and ldflags from pkgconfig if available
678
679* Thu Jan  2 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-8
680- urllib2 didn't support non-anonymous ftp.  add support based on how
681  urllib did it (#80676, #78168)
682
683* Mon Dec 16 2002 Mihai Ibanescu <misa@redhat.com> 2.2.2-7
684- Fix bug #79647 (Rebuild of SRPM fails if python isn't installed)
685- Added a bunch of missing BuildRequires found while fixing the
686  above-mentioned bug
687
688* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 2.2.2-6
689- rebuild to fix broken tcltk deps for tkinter
690
691* Fri Nov 22 2002 Mihai Ibanescu <misa@redhat.com>
6922.2.2-3.7.3
693- Recompiled for 7.3 (to fix the -lcrypt bug)
694- Fix for the spurious error message at the end of the build (build-requires
695  gets confused by executable files starting with """"): make the tests
696  non-executable.
697
698* Wed Nov 20 2002 Mihai Ibanescu <misa@redhat.com>
6992.2.2-5
700- Fixed configuration patch to add -lcrypt when compiling cryptmodule.c
701
7022.2.2-4
703- Spec file change from Matt Wilson <msw@redhat.com> to disable linking
704  with the C++ compiler.
705
706* Mon Nov 11 2002 Mihai Ibanescu <misa@redhat.com>
7072.2.2-3.*
708- Merged patch from Karsten Hopp <karsten@redhat.de> from 2.2.1-17hammer to
709  use %%{_libdir}
710- Added XFree86-libs as BuildRequires (because of tkinter)
711- Fixed duplicate listing of plat-linux2
712- Fixed exclusion of lib-dynload/japanese
713- Added lib64 patch for the japanese codecs
714- Use setup magic instead of using tar directly on JapaneseCodecs
715
716* Tue Nov  5 2002 Mihai Ibanescu <misa@redhat.com>
7172.2.2-2
718- Fix #76912 (python-tools contains idle, which uses tkinter, but there is no
719  requirement of tkinter from python-tools).
720- Fix #74013 (rpm is missing the /usr/lib/python2.2/test directory)
721
722* Mon Nov  4 2002 Mihai Ibanescu <misa@redhat.com>
723- builds as python2 require a different libdb
724- changed the buildroot name of python to match python2 builds
725
726* Fri Nov  1 2002 Mihai Ibanescu <misa@redhat.com>
727- updated python to 2.2.2 and adjusted the patches accordingly
728
729* Mon Oct 21 2002 Mihai Ibanescu <misa@redhat.com>
730- Fix #53930 (Python-2.2.1-buildroot-bytecode.patch)
731- Added BuildPrereq dependency on gcc-c++
732
733* Fri Aug 30 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-17
734- security fix for _execvpe
735
736* Tue Aug 13 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-16
737- Fix  #71011,#71134, #58157
738
739* Wed Aug  7 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-15
740- Resurrect tkinter
741- Fix for distutils (#67671)
742- Fix #69962
743
744* Thu Jul 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-14
745- Obsolete tkinter/tkinter2 (#69838)
746
747* Tue Jul 23 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-13
748- Doc fixes (#53951) - not on alpha at the momemt
749
750* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-12
751- fix pydoc (#68082)
752
753* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-11
754- Add db4-devel as a BuildPrereq
755
756* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.2.1-10
757- automated rebuild
758
759* Mon Jun 17 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-9
760- Add Japanese codecs (#66352)
761
762* Tue Jun 11 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-8
763- No more tkinter...
764
765* Wed May 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-7
766- Rebuild
767
768* Tue May 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-6
769- Add the email subcomponent (#65301)
770
771* Fri May 10 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-5
772- Rebuild
773
774* Thu May 02 2002 Than Ngo <than@redhat.com> 2.2.1-4
775- rebuild i new enviroment
776
777* Tue Apr 23 2002 Trond Eivind Glomsroed <teg@redhat.com>
778- Use ucs2, not ucs4, to avoid breaking tkinter (#63965)
779
780* Mon Apr 22 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-2
781- Make it use db4
782
783* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-1
784- 2.2.1 - a bugfix-only release
785
786* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-16
787- the same, but in builddirs - this will remove them from the
788  docs package, which doesn't look in the buildroot for files.
789
790* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-15
791- Get rid of temporary files and .cvsignores included
792  in the tarball and make install
793
794* Fri Apr  5 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-14
795- Don't own lib-tk in main package, only in tkinter (#62753)
796
797* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-13
798- rebuild
799
800* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-12
801- rebuild
802
803* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-11
804- Add a not to the Distutils obsoletes test (doh!)
805
806* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-10
807- Rebuild
808
809* Mon Feb 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-9
810- Only obsolete Distutils when built as python
811
812* Thu Feb 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-8
813- Make files in /usr/bin install side by side with python 1.5 when
814- Drop explicit requirement of db4
815  built as python2
816
817* Thu Jan 31 2002 Elliot Lee <sopwith@redhat.com> 2.2-7
818- Use version and pybasever macros to make updating easy
819- Use _smp_mflags macro
820
821* Tue Jan 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-6
822- Add db4-devel to BuildPrereq
823
824* Fri Jan 25 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-5
825- disable ndbm support, which is db2 in disguise (really interesting things
826  can happen when you mix db2 and db4 in a single application)
827
828* Thu Jan 24 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-4
829- Obsolete subpackages if necesarry
830- provide versioned python2
831- build with db4
832
833* Wed Jan 16 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-3
834- Alpha toolchain broken. Disable build on alpha.
835- New openssl
836
837* Wed Dec 26 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-1
838- 2.2 final
839
840* Fri Dec 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.11c1
841- 2.2 RC 1
842- Don't include the _tkinter module in the main package - it's
843  already in the tkiter packace
844- Turn off the mpzmodule, something broke in the buildroot
845
846* Wed Nov 28 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.10b2
847- Use -fPIC for OPT as well, in lack of a proper libpython.so
848
849* Mon Nov 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.9b2
850- changed DESTDIR to point to / so that distutils will install dynload
851  modules properly in the installroot
852
853* Fri Nov 16 2001 Matt Wilson <msw@redhat.com> 2.2-0.8b2
854- 2.2b2
855
856* Fri Oct 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.7b1
857- python2ify
858
859* Fri Oct 19 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.5b1
860- 2.2b1
861
862* Sun Sep 30 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.4a4
863- 2.2a4
864- Enable UCS4 support
865- Enable IPv6
866- Provide distutils
867- Include msgfmt.py and pygettext.py
868
869* Fri Sep 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.3a3
870- Obsolete Distutils, which is now part of the main package
871- Obsolete python2
872
873* Thu Sep 13 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.2a3
874- Add docs, tools and tkinter subpackages, to match the 1.5 layout
875
876* Wed Sep 12 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.1a3
877- 2.2a3
878- don't build tix and blt extensions
879
880* Mon Aug 13 2001 Trond Eivind Glomsroed <teg@redhat.com>
881- Add tk and tix to build dependencies
882
883* Sat Jul 21 2001 Trond Eivind Glomsroed <teg@redhat.com>
884- 2.1.1 bugfix release - with a GPL compatible license
885
886* Fri Jul 20 2001 Trond Eivind Glomsroed <teg@redhat.com>
887- Add new build dependencies (#49753)
888
889* Tue Jun 26 2001 Nalin Dahyabhai <nalin@redhat.com>
890- build with -fPIC
891
892* Fri Jun  1 2001 Trond Eivind Glomsroed <teg@redhat.com>
893- 2.1
894- reorganization of file includes
895
896* Wed Dec 20 2000 Trond Eivind Glomsroed <teg@redhat.com>
897- fix the "requires" clause, it lacked a space causing problems
898- use %%{_tmppath}
899- don't define name, version etc
900- add the available patches from the Python home page
901
902* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
903- added devel subpackage
904
905* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
906- modify all files to use "python2.0" as the intrepter
907- don't build the Expat bindings
908- build against db1
909
910* Mon Oct 16 2000 Jeremy Hylton <jeremy@beopen.com>
911- updated for 2.0 final
912
913* Mon Oct  9 2000 Jeremy Hylton <jeremy@beopen.com>
914- updated for 2.0c1
915- build audioop, imageop, and rgbimg extension modules
916- include xml.parsers subpackage
917- add test.xml.out to files list
918
919* Thu Oct  5 2000 Jeremy Hylton <jeremy@beopen.com>
920- added bin/python2.0 to files list (suggested by Martin v. Loewis)
921
922* Tue Sep 26 2000 Jeremy Hylton <jeremy@beopen.com>
923- updated for release 1 of 2.0b2
924- use .bz2 version of Python source
925
926* Tue Sep 12 2000 Jeremy Hylton <jeremy@beopen.com>
927- Version 2 of 2.0b1
928- Make the package relocatable.  Thanks to Suchandra Thapa.
929- Exclude Tkinter from main RPM.  If it is in a separate RPM, it is
930  easier to track Tk releases.
Note: See TracBrowser for help on using the repository browser.