source: projects/specs/trunk/p/python/python-vl.spec @ 1672

Revision 1672, 30.6 KB checked in by owa, 14 years ago (diff)

up to python-2.6.6

Line 
1# If you want to run test, add "--define '_run_test 1'" to rpm option
2%define run_test %{?_run_test:1}%{!?_run_test:0}
3%define unicode  ucs4
4%define bsddb_ver 4.8
5%define tcl_major 8.4
6%define tk_major 8.4
7%define tix_major 8.4
8%define pybasever 2.6
9%define python_lib %{_libdir}/python%{pybasever}
10
11Summary: An interpreted, interactive, object-oriented programming language.
12Summary(ja): オブジェクト指向言語 Python インタプリタ
13Name: python
14Version: %{pybasever}.6
15Release: 1%{?_dist_release}
16License: Modified CNRI Open Source License
17Group: Development/Languages
18URL: http://www.python.org/%{pybasever}/
19Source0: http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.bz2
20Source1: http://docs.python.org/archives/python-%{version}-docs-html.tar.bz2
21Source6: shmmodule.c
22
23# For TEST
24Source7: http://people.freebsd.org/~perky/i18n/EUC-CN.TXT
25Source8: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP936.TXT
26Source9: http://people.freebsd.org/~perky/i18n/BIG5HKSCS.TXT
27Source10: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP932.TXT
28Source11: http://people.freebsd.org/~perky/i18n/EUC-JP.TXT
29Source12: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/JIS/SHIFTJIS.TXT
30Source13: http://people.freebsd.org/~perky/i18n/EUC-JISX0213.TXT
31Source14: http://people.freebsd.org/~perky/i18n/SHIFT_JISX0213.TXT
32Source15: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP949.TXT
33Source16: http://people.freebsd.org/~perky/i18n/EUC-KR.TXT
34Source17: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/KSC/JOHAB.TXT
35Source18: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/OTHER/BIG5.TXT
36Source19: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP950.TXT
37Source20: http://www.unicode.org/Public/3.2-Update/NormalizationTest-3.2.0.txt
38
39Patch0: python-2.6.5-Setup.dist.patch
40Patch1: python-2.6.6-lib64.patch
41Patch3: Python-2.2.1-pydocnogui.patch
42Patch5: Python-2.3.3-distutilrpm.patch
43
44Patch10: python-2.6-db48.patch
45Patch11: http://bugs.python.org/file16549/python-support_bdb-4.8-v2.patch
46
47Obsoletes: python2
48Obsoletes: Distutils
49Obsoletes: python-base
50Provides: Distutils
51
52BuildRequires: db4-devel >= 4.8
53BuildRequires: gzip tar gcc-c++ pkgconfig sed findutils
54BuildRequires: bzip2-devel
55BuildRequires: gdbm-devel
56BuildRequires: glibc-devel
57BuildRequires: ncurses-devel
58BuildRequires: openssl-devel
59BuildRequires: readline-devel
60BuildRequires: sqlite3-devel
61BuildRequires: zlib-devel
62BuildRequires: expat-devel
63BuildRequires: libtermcap-devel, gmp-devel
64#BuildRequires: tetex-latex
65Requires: bzip2
66Requires: gdbm
67Requires: ncurses
68Requires: openssl
69Requires: readline
70Requires: sqlite3
71Requires: zlib
72BuildRoot: %{_tmppath}/%{name}-%{version}-root
73
74
75%description
76Python is an interpreted, interactive, object-oriented programming
77language.  It incorporates modules, exceptions, dynamic typing, very high
78level dynamic data types, and classes. Python combines remarkable power
79with very clear syntax. It has interfaces to many system calls and
80libraries, as well as to various window systems, and is extensible in C or
81C++. It is also usable as an extension language for applications that need
82a programmable interface.  Finally, Python is portable: it runs on many
83brands of UNIX, on PCs under Windows, MS-DOS, and OS/2, and on the
84Mac.
85
86%package devel
87Summary: The libraries and header files needed for Python development.
88Summary(ja): Python での開発に必要なライブラリやヘッダファイル
89Group: Development/Libraries
90Obsoletes: python2-devel
91
92%description devel
93The Python programming language's interpreter can be extended with
94dynamically loaded extensions and can be embedded in other programs.
95This package contains the header files and libraries needed to do
96these types of tasks.
97
98Install python-devel if you want to develop Python extensions.  The
99python package will also need to be installed.  You'll probably also
100want to install the python-docs package, which contains Python
101documentation.
102
103%package tools
104Summary: A collection of development tools included with Python.
105Summary(ja): Python に含まれる開発ツール一式
106Group: Development/Tools
107Requires: %{name} = %{version}
108Requires: tkinter = %{version}
109Obsoletes: python2-tools
110
111%description tools
112The Python package includes several development tools that are used
113to build python programs.  This package contains a selection of those
114tools, including the IDLE Python IDE.
115
116Install python-tools if you want to use these tools to develop
117Python programs.  You will also need to install the python and
118tkinter packages.
119
120%package docs
121Summary: Documentation for the Python programming language.
122Summary(ja): Python プログラミング言語のドキュメント
123Group: Applications/Documentation
124Obsoletes: python2-docs
125
126%description docs
127Documentation relating to the Python programming language in HTML and info
128formats.
129
130%package -n tkinter
131Summary: A graphical user interface for the Python scripting language.
132Summary(ja): Python スクリプト言語のグラフィカルインターフェイス
133Group: Development/Languages
134Obsoletes: tkinter2
135BuildRequires: tcl, tk
136Requires: %{name} = %{version}
137Requires: tcl, tk, tix
138BuildRequires: nkf
139BuildRequires: tcl, tk, tix
140BuildRequires: xorg-x11-devel mesa-libGL-devel
141
142
143%description -n tkinter
144The Tkinter (Tk interface) program is an graphical user interface for
145the Python scripting language.
146
147You should install the tkinter package if you'd like to use a graphical
148user interface for Python programming.
149
150%prep
151%setup -q -n Python-%{version}
152%patch0 -p1 -b .~Setup
153%if %{_lib} == lib64
154%patch1 -p2 -b .~lib64
155%endif
156%patch3 -p1 -b .~no_gui
157%patch5 -p1 -b .~distutilrpm
158
159## for bsddb-4.8
160# %patch10 -p1 -b .db48
161%patch11 -p0 -b .~db48-v2
162
163# shm module
164cp %{SOURCE6} Modules
165cat >> Modules/Setup.dist << EOF
166
167# Shared memory module
168shm shmmodule.c
169EOF
170
171# Fix library flags
172pushd Modules
173mv Setup.dist Setup.dist.tmp
174cat Setup.dist.tmp \
175        | sed "s^-ldb-^-ldb-%{bsddb_ver}^" \
176        | sed "s^-ltcl^-ltcl%{tcl_major}^" \
177        | sed "s^-ltk^-ltk%{tk_major}^" \
178        | sed "s^-ltix^-ltix%{tix_major}^" \
179        > Setup.dist
180rm -f Setup.dist.tmp
181popd
182
183
184%build
185topdir=`pwd`
186export CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
187export CXXFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
188export OPT="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
189export LINKCC="gcc"
190if pkg-config openssl ; then
191        export CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
192        export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
193fi
194%configure --enable-ipv6 --enable-unicode=%{unicode} --enable-shared
195make OPT="$CFLAGS" %{?_smp_mflags}
196
197export LD_LIBRARY_PATH=$topdir
198export PATH="$topdir:$PATH"
199cp $topdir/python $topdir/python%{pybasever}
200$topdir/python Tools/scripts/pathfix.py -i "/usr/bin/env python%{pybasever}" .
201make OPT="$CFLAGS" %{?_smp_mflags}
202
203
204%if %{run_test}
205## Test
206#cp %{SOURCE7} ./
207#cp %{SOURCE8} ./
208#cp %{SOURCE9} ./
209#cp %{SOURCE10} ./
210#cp %{SOURCE11} ./
211#cp %{SOURCE12} ./
212#cp %{SOURCE13} ./
213#cp %{SOURCE14} ./
214#cp %{SOURCE15} ./
215#cp %{SOURCE16} ./
216#cp %{SOURCE17} ./
217#cp %{SOURCE18} ./
218#cp %{SOURCE19} ./
219#cp %{SOURCE20} ./
220# not nesessary?
221
222## This runs the test set twice (once with no compiled files, once with
223## the compiled files left by the previous test run).
224find ./Lib -name '*.py[co]' -print | xargs rm -f
225LD_LIBRARY_PATH=$topdir:$topdir/Modules:$topdir/build/lib.linux-%{_host_cpu}-%{pybasever}
226PYTHONPATH=$topdir/Lib:$topdir/Lib/test:$topdir/Lib/lib-tk:$topdir/Lib/site-packages
227PYTHONPATH=$PYTHONPATH:$LD_LIBRARY_PATH
228PYTHONHOME=$topdir
229export PYTHONHOME PYTHONPATH LD_LIBRARY_PATH
230./python -tt -E ./Lib/test/regrtest.py -l -w
231./python -tt -E ./Lib/test/regrtest.py -l -w
232## Mon Mar 22 2010: last tested
233## 328 tests OK.
234## 1 test failed: test_pydoc
235## 37 tests skipped:
236%endif
237
238
239%install
240rm -fr $RPM_BUILD_ROOT
241mkdir -p $RPM_BUILD_ROOT/usr $RPM_BUILD_ROOT%{_mandir}
242
243# Clean up patched .py files that are saved as .lib64
244for f in distutils/command/install distutils/sysconfig; do
245    rm -f Lib/$f.py.lib64
246done
247
248# Temporary workaround to avoid confusing find-requires: don't ship the tests
249# as executable files
250chmod 0644 Lib/test/test_*.py
251
252make DESTDIR=$RPM_BUILD_ROOT install
253
254# Fix the interpreter path in binaries installed by distutils
255# (which changes them by itself)
256# Make sure we preserve the file permissions
257for fixed in $RPM_BUILD_ROOT/usr/bin/pydoc; do
258    sed 's,#!.*/python$,#!/usr/bin/env python%{pybasever},' $fixed > $fixed- \
259        && cat $fixed- > $fixed && rm -f $fixed-
260done
261
262
263## tools
264mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages
265
266echo "#!/bin/bash
267exec %{python_lib}/site-packages/pynche/pynche" \
268        > $RPM_BUILD_ROOT/usr/bin/pynche
269chmod 755 $RPM_BUILD_ROOT/usr/bin/pynche
270
271echo "#!/bin/bash
272exec %{python_lib}/site-packages/modulator/modulator.py" \
273        > $RPM_BUILD_ROOT/usr/bin/modulator
274chmod 755 $RPM_BUILD_ROOT/usr/bin/modulator
275
276# idle
277mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
278install -m 755 ./Lib/idlelib/idle.py $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
279chmod 755 $RPM_BUILD_ROOT/usr/bin/idle
280
281#modulator
282cp -r Tools/modulator ${RPM_BUILD_ROOT}%{python_lib}/site-packages/
283
284#pynche
285rm -f Tools/pynche/*.pyw
286cp -r Tools/pynche $RPM_BUILD_ROOT%{python_lib}/site-packages/
287
288(mv Tools/modulator/README Tools/modulator/README.modulator)
289(mv Tools/pynche/README Tools/pynche/README.pynche)
290
291#gettext
292install -m755  Tools/i18n/pygettext.py $RPM_BUILD_ROOT/usr/bin/
293install -m755  Tools/i18n/msgfmt.py $RPM_BUILD_ROOT/usr/bin/
294
295# Get rid of crap
296find $RPM_BUILD_ROOT/ -name "*~"|xargs rm -f
297find $RPM_BUILD_ROOT/ -name ".cvsignore"|xargs rm -f
298find . -name "*~"|xargs rm -f
299find . -name ".cvsignore"|xargs rm -f
300#zero length
301rm -f $RPM_BUILD_ROOT%{python_lib}/site-packages/modulator/Templates/copyright
302
303# Clean up the testsuite - we don't need compiled files for it
304find $RPM_BUILD_ROOT%{python_lib}/test \
305    -name "*.pyc" -o -name "*.pyo" | xargs rm -f
306rm -f $RPM_BUILD_ROOT%{python_lib}/LICENSE.txt
307
308find $RPM_BUILD_ROOT%{python_lib}/lib-dynload -type f | grep -v _tkinter.so | sed "s|$RPM_BUILD_ROOT||" > dynfiles
309
310## Fix the file permissions
311chmod 755 $RPM_BUILD_ROOT%{python_lib}/lib-dynload/*.so
312chmod 755 $RPM_BUILD_ROOT%{_libdir}/libpython*.so.*
313find $RPM_BUILD_ROOT%{python_lib} -type f -name '*.py' | xargs chmod -x
314
315## docs
316if [ -d Doc/html ] ; then
317        rm Doc/html
318fi
319tar xvzf %SOURCE1
320mv python-%{version}-docs-html Doc/html
321
322
323%clean
324rm -fr $RPM_BUILD_ROOT
325
326
327%files -f dynfiles
328%defattr(-, root, root)
329%doc LICENSE README
330%{_bindir}/%{name}*
331%{_mandir}/*/*
332%{_libdir}/libpython%{pybasever}.so*
333%dir %{python_lib}
334%dir %{python_lib}/lib-dynload
335%dir %{python_lib}/site-packages
336%{python_lib}/*.py*
337%{python_lib}/*.doc
338%{python_lib}/bsddb
339%{python_lib}/compiler
340%{python_lib}/ctypes
341%{python_lib}/curses
342%{python_lib}/distutils
343%{python_lib}/email
344%{python_lib}/encodings
345%{python_lib}/hotshot
346%{python_lib}/idlelib
347%{python_lib}/json
348%{python_lib}/lib2to3
349%{python_lib}/logging
350%{python_lib}/multiprocessing
351%{python_lib}/plat-linux2
352%{python_lib}/sqlite3
353%{python_lib}/wsgiref
354%{python_lib}/wsgiref.egg-info
355%{python_lib}/xml
356
357%files devel
358%defattr(-,root,root)
359%{_includedir}/*
360%{python_lib}/config
361%{python_lib}/test
362
363%files tools
364%defattr(-,root,root,755)
365%doc Tools/modulator/README.modulator
366%doc Tools/pynche/README.pynche
367%{python_lib}/site-packages
368%{_bindir}/2to3
369%{_bindir}/idle
370%{_bindir}/modulator
371%{_bindir}/msgfmt.py
372%{_bindir}/pydoc
373%{_bindir}/pygettext.py
374%{_bindir}/pynche
375%{_bindir}/smtpd.py
376
377%files docs
378%defattr(-,root,root,755)
379%doc Misc/HISTORY Misc/NEWS  Misc/README Misc/cheatsheet Misc/developers.txt
380%doc Doc/html
381
382%files -n tkinter
383%defattr(-,root,root,755)
384%{python_lib}/lib-tk
385%{python_lib}/lib-dynload/_tkinter.so
386
387
388%changelog
389* Wed Aug 25 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.6-1
390- updated python to 2.6.6
391- updated python-docs to 2.6.6
392- updated python-2.6.?-lib64.patch
393
394* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-4
395- rebuilt with tcl/tk-8.4.19-2
396
397* Mon Mar 22 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-3
398- fixed missing of python-docs files
399- dropt '--with doc' option
400- dropt BR: latex2html
401- replaced descriptions (from Misc/RPM/python-2.6.spec in tar-ball)
402
403* Sun Mar 21 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-2
404- replaced Patch0: python-2.6.?-Setup.dist.patch
405- replaced Patch1: python-2.6.?-lib64.patch
406- added python-2.6.5-docs-html.tar.bz2
407- dropt Python-2.6.4-Doc.78718.tgz
408
409* Sat Mar 20 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-1
410- updated python to 2.6.5
411- updated Patch0: Python-2.6.4-Setup.dist.patch
412- added macro bsddb_ver
413- added Patch11: python-support_bdb-4.8-v2.patch (instead of Patch10: python-2.6-db48.patch)
414
415* Sat Mar 06 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-5
416- added Python-2.6.4-Doc.78718.tgz (documents from http://svn.python.org/projects)
417- changed default to '--with doc' again
418
419* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.4-4
420- rebuilt with gcc-4.4.3-3 on ppc
421- s/BuildPreReq/BuildRequires/
422
423* Thu Feb 04 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
424- replaced Python-%%{version}-Setup.dist.patch
425- added BR: sqlite3-devel
426
427* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-2
428- add Patch10 to build with db-4.8
429
430* Mon Feb 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-1
431- updated python to 2.6.4
432- changed default to '--without doc'
433- added Setup.dist.patch instead of Setup.dist{32,64}.patch
434- updated python-*-lib64.patch to 2.6.3
435
436* Mon Feb 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.5.5-1
437- updated python to 2.5.5
438
439* Wed May 06 2009 Shu KONNO <owa@bg.wakwak.com> 2.5.4-4vl5
440- added Python-2.5.4-{Setup,Setup64}.patch
441  - added _bsddb module
442  - dropt patch{0,9,10}
443
444* Sun May  3 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.4-3vl5
445- updated Patch0 for building with db-4.6.21
446
447* Thu Feb 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.4-2vl5
448- add patch10
449  - add -lcrypt for cryptmodule
450
451* Wed Dec 24 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.4-1vl5
452- new upstream release
453- changed typo of summary(ja)
454
455* Sat Dec 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.3-1vl5
456- new upstream release
457- dropt python-2.4.4_CVE-2007-4965.patch
458- dropt python-2.4.4_CVE-2008-1721.patch
459- dropt python-2.4.4-CVE-2008-1679.patch
460
461* Fri Jul 18 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.2-1vl5
462- updated python to 2.5.2
463- added python-2.5.2-config.patch instead of python-2.5c1-config.patch
464- added python-2.5.2-config64.patch instead of python-2.4.3-config.lib64.patch
465- added python-2.5.2-lib64.patch instead of python-2.4.2-lib64.patch
466- added modules ctypes, sqlite3, and wsgiref
467- dropt modules lib-old
468- dropt python-2.4.4_CVE-2008-1887.patch
469- dropt python-2.4.4_CVE-2007-2052.patch
470- fixed the file permissions
471
472* Sun Jun 08 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-1vl5
473- applied new versioning policy and spec in utf-8
474- added BuildPrereq: xorg-x11-devel
475- imported updates from Vine4.2
476        * Fri Apr 25 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.4vl4
477        - add patch120 for fix CVE-2008-1679 (added fix of CVE-2007-4965)
478        - add patch130 for fix CVE-2008-1887 (PyString_FromStringAndSize)
479        - add patch140 for fix CVE-2007-2052 (_localemodule.c off-by-one err)
480        * Mon Apr 21 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.3vl4
481        - add patch110 CVE-2008-1721 (zlib module)
482        - add remove unneeded files in Lib/test/
483        #- new versioning policy
484
485* Wed Mar 12 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-0vl1
486- updated python to 2.4.5
487
488* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.4-0vl7
489- rebuild with expat-2.0.1
490
491* Mon Feb 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl6
492- fix typo on Patch0 (s/db-4.2/db-4.3/)
493
494* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl5
495- rebuild with tcl/tk-8.4.18
496
497* Sat Dec 01 2007 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl4
498- imported updates from Vine4.2 Plus
499        * Thu Nov 01 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.2
500        - add BuildPrereq: nkf
501        * Wed Oct 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.1
502        - add patch100 for fix CVE-2007-4965 (imageop Module integer OF)
503
504* Sat Jun 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.4-0vl3
505- rebuilt with openssl-0.9.8e and tix-8.4.2
506- fixed spec file encoding
507
508* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl2
509- rebuilt with new toolchain and db4-4.3.x
510- modified Patch0 (s/db-4.2/db-4.3/)
511
512* Thu Oct 19 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl1
513- updated python to 2.4.4 (included security fix PSF-2006-001)
514- added japanese summary
515- updated patch8 (python-2.4.2-lib64.patch)
516- added patch9 (python-2.4.4c1-setup.lib64.patch)
517
518* Wed Sep 13 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.4.3-0vl4
519- change docs Group to Applications/Documentation. <BTS:VineLinux:163>
520
521* Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.4.3-0vl3
522- rebuild with readline-5.1 (x86_64)
523
524* Fri Apr 14 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl2
525- fixed python-2.4.3-config.patch cause undefined symbol: crypt
526
527* Thu Mar 30 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl1
528- updated python to 2.4.3
529- added python-2.4.3-config.patch instead of python-2.4.1c1-config.patch
530
531* Wed Feb 15 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl5
532- set permition of lib-dynload/*.so to 755
533- added without_doc option
534- rebuilt with x86_64
535
536* Thu Nov 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl4
537- add run_test option
538
539* Fri Nov  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3.2
540- add BuildPrereq: bzip2-devel
541- arrange testing script
542
543* Wed Nov 02 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl3.1
544- back to %%configure macro
545- change testing script
546
547* Mon Oct 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3
548- update Patch8 (VineSeed:10306)
549- use ./configure instead of %%configure script
550- add forgotten popd
551
552* Fri Oct 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl2
553- add --enable-shared to confiugre option
554- add %%{_libdir}/libpython2.4.so* to python package
555- add LD_LIBRARY_PATH=$topdir to use pathfix.py
556- change build method of Doc
557- add files for make test
558- change install method
559
560* Wed Sep 28 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl1
561- update python to 2.4.2 (final)
562
563* Wed Mar 30 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl1
564- update python to 2.4.1 (final)
565
566* Sat Mar 19 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c2
567- update python to 2.4.1c2
568- moved all site-packages files to python-tools package
569
570* Sat Mar 12 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c1
571- update python to 2.4.1c1
572- droped aspython2 macros
573- droped japanese-codecs module
574- droped Source2 idle, now it's provided from original source
575- droped Source3 modulator, now it's generated in a spec file
576- droped Source4 pynche, now it's generated in a spec file
577- droped Python-2.3.3-buildroot-bytecode.patch
578- changed python-2.3.3-config2.patch to python-2.4.1c1-config.patch
579
580* Wed Feb 09 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.5-0vl1
581- update python to 2.3.5
582
583* Fri Feb 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl6
584- add PSF-2005-001.patch
585
586* Wed Nov 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl4
587- rebuilt
588
589* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl3
590- modified Patch0 and Patch8 (-ldb-4.0 -> -ldb-4.2)
591
592* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl2
593- rebuilt with db4-4.2.25
594
595* Thu May 27 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl1
596- updated python to 2.3.4
597- fixed patch10, patch11
598
599* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl1
600- rebuild
601
602* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.3
603- updated python-2.3.3-config2.patch
604
605* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.2
606- added librarys 'logging, bsddb, idlelib' to /usr/lib/python2.3
607
608* Wed Apr 07 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.1
609- updated python to 2.3.3
610- changed version code 2.2.3 to 2.3.3 in source{2,3,4}
611- updated config2.patch for 2.3.3
612- updated nowhatsnew.patch for 2.3.3
613- updated distutilrpm.patch in which tabstops have made indent error
614- updated buildroot-bytecode.patch for 2.3.3
615- deleted buildroot.patch which fixed in 2.3.3
616- changed Tools/idle with Lib/idlelib
617
618* Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-3vl3
619- rebuild with openssl-0.9.7d
620
621* Wed Mar 03 2004 Shu KONNO <owa@bg.wakwak.com> 2.2.3-3vl2
622- updated JapaneseCodecs to 1.4.10
623
624* Wed Jul 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.3-3vl1
625- synced with RawHide 2.2.3-3 (substantially source ver up)
626
627* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.2-26vl1
628- rebuild with tcltk-8.4.2
629- synced with RawHide 2.2.2-26
630  * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
631  - rebuilt
632
633  * Mon Feb 24 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-25
634  - Fixed bug #84886: pydoc dies when run w/o arguments
635  - Fixed bug #84205: add python shm module back (used to be shipped with 1.5.2)
636  - Fixed bug #84966: path in byte-compiled code still wrong
637
638  * Thu Feb 20 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-23
639  - ftp uri's should be able to specify being rooted at the root instead of
640    where you login via ftp (#84692)
641
642  * Mon Feb 10 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-22
643  - Using newer Japanese codecs (1.4.9). Thanks to
644    Peter Bowen <pzb@datastacks.com> for pointing this out.
645
646  * Thu Feb  6 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-21
647  - Rebuild
648
649  * Wed Feb  5 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-20
650  - Release number bumped really high: turning on UCS4 (ABI compatibility
651    breakage)
652
653  * Fri Jan 31 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-13
654  - Attempt to look both in /usr/lib64 and /usr/lib/python2.2/site-packages/:
655    some work on python-2.2.2-lib64.patch
656
657  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-12
658  - Rebuild to incorporate the removal of .lib64 and - files.
659
660  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-11.7.3
661  - Fixed bug #82544: Errata removes most tools
662  - Fixed bug #82435: Python 2.2.2 errata breaks redhat-config-users
663  - Removed .lib64 and - files that get installed after we fix the multilib
664    .py files.
665
666  * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
667  - rebuilt
668
669  * Wed Jan 15 2003 Jens Petersen <petersen@redhat.com> 2.2.2-10
670  - rebuild to update tkinter's tcltk deps
671  - convert changelog to utf-8
672
673
674* Wed Jan 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.2-9vl0
675- rebuilt for Vine Linux against db4
676- obsolete python-base (which comes with python-2.2.1 of TestPkg)
677
678* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 2.2.2-9
679- rebuild
680
681* Fri Jan  3 2003 Nalin Dahyabhai <nalin@redhat.com>
682- pick up OpenSSL cflags and ldflags from pkgconfig if available
683
684* Thu Jan  2 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-8
685- urllib2 didn't support non-anonymous ftp.  add support based on how
686  urllib did it (#80676, #78168)
687
688* Mon Dec 16 2002 Mihai Ibanescu <misa@redhat.com> 2.2.2-7
689- Fix bug #79647 (Rebuild of SRPM fails if python isn't installed)
690- Added a bunch of missing BuildRequires found while fixing the
691  above-mentioned bug
692
693* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 2.2.2-6
694- rebuild to fix broken tcltk deps for tkinter
695
696* Fri Nov 22 2002 Mihai Ibanescu <misa@redhat.com>
6972.2.2-3.7.3
698- Recompiled for 7.3 (to fix the -lcrypt bug)
699- Fix for the spurious error message at the end of the build (build-requires
700  gets confused by executable files starting with """"): make the tests
701  non-executable.
702
703* Wed Nov 20 2002 Mihai Ibanescu <misa@redhat.com>
7042.2.2-5
705- Fixed configuration patch to add -lcrypt when compiling cryptmodule.c
706
7072.2.2-4
708- Spec file change from Matt Wilson <msw@redhat.com> to disable linking
709  with the C++ compiler.
710
711* Mon Nov 11 2002 Mihai Ibanescu <misa@redhat.com>
7122.2.2-3.*
713- Merged patch from Karsten Hopp <karsten@redhat.de> from 2.2.1-17hammer to
714  use %%{_libdir}
715- Added XFree86-libs as BuildRequires (because of tkinter)
716- Fixed duplicate listing of plat-linux2
717- Fixed exclusion of lib-dynload/japanese
718- Added lib64 patch for the japanese codecs
719- Use setup magic instead of using tar directly on JapaneseCodecs
720
721* Tue Nov  5 2002 Mihai Ibanescu <misa@redhat.com>
7222.2.2-2
723- Fix #76912 (python-tools contains idle, which uses tkinter, but there is no
724  requirement of tkinter from python-tools).
725- Fix #74013 (rpm is missing the /usr/lib/python2.2/test directory)
726
727* Mon Nov  4 2002 Mihai Ibanescu <misa@redhat.com>
728- builds as python2 require a different libdb
729- changed the buildroot name of python to match python2 builds
730
731* Fri Nov  1 2002 Mihai Ibanescu <misa@redhat.com>
732- updated python to 2.2.2 and adjusted the patches accordingly
733
734* Mon Oct 21 2002 Mihai Ibanescu <misa@redhat.com>
735- Fix #53930 (Python-2.2.1-buildroot-bytecode.patch)
736- Added BuildPrereq dependency on gcc-c++
737
738* Fri Aug 30 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-17
739- security fix for _execvpe
740
741* Tue Aug 13 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-16
742- Fix  #71011,#71134, #58157
743
744* Wed Aug  7 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-15
745- Resurrect tkinter
746- Fix for distutils (#67671)
747- Fix #69962
748
749* Thu Jul 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-14
750- Obsolete tkinter/tkinter2 (#69838)
751
752* Tue Jul 23 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-13
753- Doc fixes (#53951) - not on alpha at the momemt
754
755* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-12
756- fix pydoc (#68082)
757
758* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-11
759- Add db4-devel as a BuildPrereq
760
761* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.2.1-10
762- automated rebuild
763
764* Mon Jun 17 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-9
765- Add Japanese codecs (#66352)
766
767* Tue Jun 11 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-8
768- No more tkinter...
769
770* Wed May 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-7
771- Rebuild
772
773* Tue May 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-6
774- Add the email subcomponent (#65301)
775
776* Fri May 10 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-5
777- Rebuild
778
779* Thu May 02 2002 Than Ngo <than@redhat.com> 2.2.1-4
780- rebuild i new enviroment
781
782* Tue Apr 23 2002 Trond Eivind Glomsroed <teg@redhat.com>
783- Use ucs2, not ucs4, to avoid breaking tkinter (#63965)
784
785* Mon Apr 22 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-2
786- Make it use db4
787
788* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-1
789- 2.2.1 - a bugfix-only release
790
791* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-16
792- the same, but in builddirs - this will remove them from the
793  docs package, which doesn't look in the buildroot for files.
794
795* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-15
796- Get rid of temporary files and .cvsignores included
797  in the tarball and make install
798
799* Fri Apr  5 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-14
800- Don't own lib-tk in main package, only in tkinter (#62753)
801
802* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-13
803- rebuild
804
805* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-12
806- rebuild
807
808* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-11
809- Add a not to the Distutils obsoletes test (doh!)
810
811* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-10
812- Rebuild
813
814* Mon Feb 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-9
815- Only obsolete Distutils when built as python
816
817* Thu Feb 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-8
818- Make files in /usr/bin install side by side with python 1.5 when
819- Drop explicit requirement of db4
820  built as python2
821
822* Thu Jan 31 2002 Elliot Lee <sopwith@redhat.com> 2.2-7
823- Use version and pybasever macros to make updating easy
824- Use _smp_mflags macro
825
826* Tue Jan 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-6
827- Add db4-devel to BuildPrereq
828
829* Fri Jan 25 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-5
830- disable ndbm support, which is db2 in disguise (really interesting things
831  can happen when you mix db2 and db4 in a single application)
832
833* Thu Jan 24 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-4
834- Obsolete subpackages if necesarry
835- provide versioned python2
836- build with db4
837
838* Wed Jan 16 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-3
839- Alpha toolchain broken. Disable build on alpha.
840- New openssl
841
842* Wed Dec 26 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-1
843- 2.2 final
844
845* Fri Dec 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.11c1
846- 2.2 RC 1
847- Don't include the _tkinter module in the main package - it's
848  already in the tkiter packace
849- Turn off the mpzmodule, something broke in the buildroot
850
851* Wed Nov 28 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.10b2
852- Use -fPIC for OPT as well, in lack of a proper libpython.so
853
854* Mon Nov 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.9b2
855- changed DESTDIR to point to / so that distutils will install dynload
856  modules properly in the installroot
857
858* Fri Nov 16 2001 Matt Wilson <msw@redhat.com> 2.2-0.8b2
859- 2.2b2
860
861* Fri Oct 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.7b1
862- python2ify
863
864* Fri Oct 19 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.5b1
865- 2.2b1
866
867* Sun Sep 30 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.4a4
868- 2.2a4
869- Enable UCS4 support
870- Enable IPv6
871- Provide distutils
872- Include msgfmt.py and pygettext.py
873
874* Fri Sep 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.3a3
875- Obsolete Distutils, which is now part of the main package
876- Obsolete python2
877
878* Thu Sep 13 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.2a3
879- Add docs, tools and tkinter subpackages, to match the 1.5 layout
880
881* Wed Sep 12 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.1a3
882- 2.2a3
883- don't build tix and blt extensions
884
885* Mon Aug 13 2001 Trond Eivind Glomsroed <teg@redhat.com>
886- Add tk and tix to build dependencies
887
888* Sat Jul 21 2001 Trond Eivind Glomsroed <teg@redhat.com>
889- 2.1.1 bugfix release - with a GPL compatible license
890
891* Fri Jul 20 2001 Trond Eivind Glomsroed <teg@redhat.com>
892- Add new build dependencies (#49753)
893
894* Tue Jun 26 2001 Nalin Dahyabhai <nalin@redhat.com>
895- build with -fPIC
896
897* Fri Jun  1 2001 Trond Eivind Glomsroed <teg@redhat.com>
898- 2.1
899- reorganization of file includes
900
901* Wed Dec 20 2000 Trond Eivind Glomsroed <teg@redhat.com>
902- fix the "requires" clause, it lacked a space causing problems
903- use %%{_tmppath}
904- don't define name, version etc
905- add the available patches from the Python home page
906
907* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
908- added devel subpackage
909
910* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
911- modify all files to use "python2.0" as the intrepter
912- don't build the Expat bindings
913- build against db1
914
915* Mon Oct 16 2000 Jeremy Hylton <jeremy@beopen.com>
916- updated for 2.0 final
917
918* Mon Oct  9 2000 Jeremy Hylton <jeremy@beopen.com>
919- updated for 2.0c1
920- build audioop, imageop, and rgbimg extension modules
921- include xml.parsers subpackage
922- add test.xml.out to files list
923
924* Thu Oct  5 2000 Jeremy Hylton <jeremy@beopen.com>
925- added bin/python2.0 to files list (suggested by Martin v. Loewis)
926
927* Tue Sep 26 2000 Jeremy Hylton <jeremy@beopen.com>
928- updated for release 1 of 2.0b2
929- use .bz2 version of Python source
930
931* Tue Sep 12 2000 Jeremy Hylton <jeremy@beopen.com>
932- Version 2 of 2.0b1
933- Make the package relocatable.  Thanks to Suchandra Thapa.
934- Exclude Tkinter from main RPM.  If it is in a separate RPM, it is
935  easier to track Tk releases.
Note: See TracBrowser for help on using the repository browser.