source: projects/specs/trunk/p/python-zope-interface/python-zope-interface-vl.spec @ 521

Revision 521, 1.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2%define pyver %(python -c 'import sys;print(sys.version[0:3])')
3%define pkg_release     2%{?_dist_release}
4
5Summary:        Zope 3 Interface Infrastructure
6Summary(ja):    Zope 3 インターフェース・インフラストラクチャ
7Name:           python-zope-interface
8Version:        3.5.0
9Release:        %{pkg_release}
10Source0:        http://pypi.python.org/packages/source/z/zope.interface/zope.interface-%{version}.zip
11License:        ZPL (Zope Public License 2.1)
12Group:          Development/Languages
13URL:            http://pypi.python.org/pypi/zope.interface
14
15Requires:       python
16BuildRequires:  python, python-devel, python-setuptools
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19
20%description
21This is a separate distribution of the zope.interface package
22used in Zope 3.
23
24%description -l ja
25python-zope-interface は Zope 3 で利用されている zope.interface
26を、単体で分離して配布しているパッケージです。
27
28%prep
29
30%setup -q -n zope.interface-%{version}
31
32
33%build
34%{__python} setup.py build
35
36
37%install
38%{__rm} -rf ${RPM_BUILD_ROOT}
39%{__python} setup.py install --root ${RPM_BUILD_ROOT}
40
41
42%clean
43%{__rm} -rf ${RPM_BUILD_ROOT}
44
45
46%files
47%defattr(-,root,root)
48%doc CHANGES.txt PKG-INFO README.txt
49%{python_sitearch}/zope
50#%{python_sitearch}/zope.interface-3.5.0-py2.5.egg-info
51#%{python_sitearch}/zope.interface-3.5.0-py2.5-nspkg.pth
52%{python_sitearch}/zope.interface-3.5.0-py%{pyver}.egg-info
53%{python_sitearch}/zope.interface-3.5.0-py%{pyver}-nspkg.pth
54
55%changelog
56* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 3.5.0-2
57- rebuild with python-2.6
58- fixed path
59
60* Tue Dec 23 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.5.0-1
61- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.