source: projects/specs/trunk/p/python-whoosh/python-whoosh-vl.spec @ 11940

Revision 11940, 5.6 KB checked in by tomop, 5 years ago (diff)

python-sphinx-1.7.9-1 and requirements

Line 
1%global with_python3 1
2
3# For bootstrapping sphinxcontrib-websupport
4%bcond_with docs
5
6%global mod_name Whoosh
7
8Name:           python-whoosh
9Version:        2.7.4
10Release:        13%{?_dist_release}
11Summary:        Fast, pure-Python full text indexing, search, and spell checking library
12
13License:        BSD
14URL:            http://pythonhosted.org/Whoosh/
15
16Vendor:         Project Vine
17Distribution:   Vine Linux
18
19Source0:        https://pypi.python.org/packages/source/W/%{mod_name}/%{mod_name}-%{version}.tar.gz
20
21BuildArch:      noarch
22BuildRequires:  python-rpm-macros
23BuildRequires:  python-devel
24BuildRequires:  python-setuptools
25
26%if %{with docs}
27BuildRequires:  python-sphinx
28%endif
29
30%{?python_provide:%python_provide python2-whoosh}
31
32%if 0%{?with_python3}
33BuildRequires: python3-rpm-macros
34BuildRequires: python3-devel
35BuildRequires: python3-setuptools
36%endif
37
38%description
39Whoosh is a fast, featureful full-text indexing and searching library
40implemented in pure Python. Programmers can use it to easily add search
41functionality to their applications and websites. Every part of how Whoosh
42works can be extended or replaced to meet your needs exactly.
43
44%if 0%{?with_python3}
45%package -n python3-whoosh
46Summary:    Fast, Python3 full text indexing, search, and spell checking library
47%{?python_provide:%python_provide python%{python3_pkgversion}-whoosh}
48
49%description -n python3-whoosh
50Whoosh is a fast, featureful full-text indexing and searching library
51implemented in pure Python. Programmers can use it to easily add search
52functionality to their applications and websites. Every part of how Whoosh
53works can be extended or replaced to meet your needs exactly.
54%endif
55
56%prep
57%setup -q -n %{mod_name}-%{version}
58
59%build
60%py_build
61
62%if %{with docs}
63sphinx-build docs/source docs/html
64rm -f docs/html/.buildinfo
65rm -rf docs/html/.doctrees
66%endif
67
68%if 0%{?with_python3}
69%py3_build
70rm -f docs/html/.buildinfo
71rm -rf docs/html/.doctrees
72%endif
73
74%install
75%py_install
76
77%if 0%{?with_python3}
78%py3_install
79%endif
80
81%check
82%{__python} setup.py test
83
84%if 0%{?with_python3}
85%{__python3} setup.py test
86%endif
87
88%files
89%license LICENSE.txt
90%doc README.txt
91%if %{with docs}
92%doc docs/html/
93%endif
94%{python_sitelib}/*.egg-info/
95%{python_sitelib}/whoosh
96
97%if 0%{?with_python3}
98%files -n python%{python3_pkgversion}-whoosh
99%license LICENSE.txt
100%doc README.txt
101%if %{with docs}
102%doc docs/html/
103%endif
104%{python3_sitelib}/whoosh
105%{python3_sitelib}/*.egg-info/
106%endif
107
108%changelog
109* Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.7.4-13
110- initial build for Vine Linux.
111
112* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.4-12
113- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
114
115* Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 2.7.4-11
116- Rebuilt for Python 3.7
117
118* Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 2.7.4-10
119- Bootstrap for Python 3.7
120
121* Wed Feb 28 2018 Iryna Shcherbina <ishcherb@redhat.com> - 2.7.4-9
122- Update Python 2 dependency declarations to new packaging standards
123  (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
124
125* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.4-8
126- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
127
128* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.4-7
129- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
130
131* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.4-6
132- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
133
134* Tue Dec 13 2016 Charalampos Stratakis <cstratak@redhat.com> - 2.7.4-5
135- Enable tests
136
137* Mon Dec 12 2016 Charalampos Stratakis <cstratak@redhat.com> - 2.7.4-4
138- Rebuild for Python 3.6
139- Disable python3 tests for now
140
141* Wed Oct 12 2016 Orion Poplawski <orion@cora.nwra.com> - 2.7.4-3
142- Ship python2-whoosh
143- Build python3 package for EPEL7
144- Modernize spec
145
146* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7.4-2
147- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
148
149* Sun May 01 2016 Robert Kuska <rkuska@gmail.com> - 2.7.4-1
150- Update to version 2.7.4
151
152* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.0-2
153- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
154
155* Mon Oct 12 2015 Robert Kuska <rkuska@redhat.com> 2.7.0-1
156- Update to version 2.7.0
157
158* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.7-5
159- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
160
161* Wed Jul 30 2014 Robert Kuska <rkuska@redhat.com> - 2.7.5-4
162- Change spec for el6 and epel7
163
164* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.7-3
165- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
166
167* Fri May 16 2014 Robert Kuska <rkuska@redhat.com> - 2.7.5-2
168- Rebuilt for https://fedoraproject.org/wiki/Changes/Python_3.4
169
170* Mon Mar 03 2014 Robert Kuska <rkuska@redhat.com> - 2.5.7-1
171- Rebase to 2.5.7
172
173* Mon Jan 27 2014 Robert Kuska <rkuska@redhat.com> - 2.5.6-1
174- Rebase to 2.5.6
175
176* Tue Nov 19 2013 Robert Kuska <rkuska@redhat.com> - 2.5.5-1
177- Rebase to 2.5.5
178
179* Mon Sep 09 2013 Robert Kuska <rkuska@redhat.com> - 2.5.3-1
180- Rebase to 2.5.3
181
182* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.1-2
183- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
184
185* Mon Jul 08 2013 Robert Kuska <rkuska@redhat.com> - 2.5.1-1
186- Update source
187- Add python3 subpackage (rhbz#979235)
188
189* Mon Apr 08 2013 Robert Kuska <rkuska@redhat.com> - 2.4.1-2
190- Review fixes
191
192* Fri Apr 05 2013 Robert Kuska <rkuska@redhat.com> - 2.4.1-1
193- Initial package
194
Note: See TracBrowser for help on using the repository browser.