source: projects/specs/trunk/p/python-which/python-which-vl.spec @ 4375

Revision 4375, 2.5 KB checked in by munepi, 13 years ago (diff)

added d/dblatex/dblatex-vl.spec, p/python-which/python-which-vl.spec

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           python-which
4Version:        1.1.0
5Release:        1%{?_dist_release}
6Summary:        Small which replacement that can be used as a Python module
7
8Group:          Development/Languages
9License:        MIT
10URL:            http://trentm.com/projects/which/
11Source0:        http://trentm.com/downloads/which/%{version}/which-%{version}.zip
12BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13
14BuildArch:      noarch
15BuildRequires:  python-devel
16
17%description
18which.py is a small which replacement. It has the following features:
19
20 * it can print all matches on the PATH;
21 * it can note "near misses" on the PATH (e.g. files that match but
22   may not, say, have execute permissions); and
23 * it can be used as a Python module.
24
25
26%prep
27%setup -q -n which-%{version}
28
29
30%build
31%{__python} setup.py build
32
33
34%install
35%__rm -rf $RPM_BUILD_ROOT
36%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
37# add a script that calls the python module
38cat << \EOF > which-python
39#!/bin/sh
40python -m which $@
41EOF
42%__mkdir_p $RPM_BUILD_ROOT%{_bindir}
43%__install -m0755 -p which-python $RPM_BUILD_ROOT%{_bindir}
44
45 
46%clean
47%__rm -rf $RPM_BUILD_ROOT
48
49
50%files
51%defattr(-,root,root,-)
52%doc LICENSE.txt README.txt TODO.txt
53%{_bindir}/which-python
54%{python_sitelib}/which.py*
55%{python_sitelib}/which-*.egg-info
56
57
58%changelog
59* Thu Jul 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 1.1.0-1
60- initial build
61
62* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-8
63- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
64
65* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.1.0-7
66- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
67
68* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-6
69- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
70
71* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-5
72- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
73
74* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.1.0-4
75- Rebuild for Python 2.6
76
77* Mon Jan  7 2008 Patrice Dumas <pertusus@free.fr> - 1.1.0-3
78- ship egg file
79
80* Sun Oct 28 2007  <ndbecker2@gmail.com> - 1.1.0-2
81- Remove ref to GNU
82
83* Sat Oct 27 2007  <ndbecker2@gmail.com> - 1.1.0-1
84- Package for fedora
85
86* Thu Jul 19 2007 Patrice Dumas <pertusus@free.fr> 1.1.0-1
87- initial packaging
Note: See TracBrowser for help on using the repository browser.