source: projects/specs/trunk/p/python-wheel/python-wheel-vl.spec @ 11270

Revision 11270, 6.0 KB checked in by tomop, 6 years ago (diff)

python-wheel-0.30.0a0-8

Line 
1%bcond_with bootstrap
2%bcond_with signatures
3%bcond_without tool
4%bcond_with test
5
6%global pypi_name wheel
7
8Name:           python-%{pypi_name}
9Version:        0.30.0a0
10Release:        8%{?_dist_release}
11Summary:        A built-package format for Python
12
13Group:          Development/Libraries
14License:        MIT
15URL:            https://bitbucket.org/pypa/wheel
16Source0:        https://files.pythonhosted.org/packages/source/%(n=%{pypi_name}; echo ${n:0:1})/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
17BuildArch:      noarch
18
19Vendor:         Project Vine
20Distribution:   Vine Linux
21
22# Latest version of wheel requires the package keyrings.alt in order for the tests to pass,
23# however it can't be packaged for Fedora as of yet since the code is not licensed,
24# and as a result wheel fails to build from source.
25# Review request of keyrings.alt: https://bugzilla.redhat.com/show_bug.cgi?id=1365794
26# Until the license issue is resolved upstream, this patch is added to revert
27# the commit from wheel, that introduced this dependency.
28# https://bitbucket.org/pypa/wheel/commits/06841295888fdb430abe12aae29da92107e7360a
29Patch0: remove-keyrings.alt-dependency.patch
30
31BuildRequires:  python-devel
32BuildRequires:  python-setuptools
33%if ! %{with bootstrap}
34%if %{with test}
35BuildRequires:  python3-pytest
36BuildRequires:  python-jsonschema
37%endif
38%if %{with signatures}
39BuildRequires:  pyxdg
40BuildRequires:  python-keyring
41%endif
42%endif
43%{?python_provide:%python_provide python2-%{pypi_name}}
44
45%global _description \
46A built-package format for Python.\
47\
48A wheel is a ZIP-format archive with a specially formatted filename and the\
49.whl extension. It is designed to contain all the files for a PEP 376\
50compatible install in a way that is very close to the on-disk format.
51
52%description %{_description}
53
54Python 2 version.
55
56
57%package -n     python3-%{pypi_name}
58Summary:        %{summary}
59BuildRequires:  python3-devel
60BuildRequires:  python3-setuptools
61%if ! %{with bootstrap}
62%if %{with test}
63BuildRequires:  python3-pytest
64BuildRequires:  python3-jsonschema
65%endif
66%if %{with signatures}
67BuildRequires:  python3-pyxdg
68BuildRequires:  python3-keyring
69%endif
70%endif
71%{?python_provide:%python_provide python3-%{pypi_name}}
72
73%description -n python3-%{pypi_name} %{_description}
74
75Python 3 version.
76
77%prep
78%setup -q -n %{pypi_name}-%{version}
79# remove unneeded shebangs
80sed -ie '1d' %{pypi_name}/{egg2wheel,wininst2wheel}.py
81%patch0 -p1
82
83%build
84%py_build
85%py3_build
86
87%install
88rm -rf %{buildroot}
89
90%py_install
91%if %{with tool}
92mv %{buildroot}%{_bindir}/%{pypi_name}{,-%{python_version}}
93ln -s %{pypi_name}-%{python_version} %{buildroot}%{_bindir}/%{pypi_name}-2
94%endif
95
96%py3_install
97%if %{with tool}
98mv %{buildroot}%{_bindir}/%{pypi_name}{,-%{python3_version}}
99ln -s %{pypi_name}-%{python3_version} %{buildroot}%{_bindir}/%{pypi_name}-3
100
101ln -s %{pypi_name}-2 %{buildroot}%{_bindir}/%{pypi_name}
102%endif
103
104%if %{with test}
105%check
106rm setup.cfg
107PYTHONPATH=%{buildroot}%{python_sitelib} py.test-2 -v --ignore build
108PYTHONPATH=%{buildroot}%{python3_sitelib} py.test-3 -v --ignore build
109%endif
110
111%files
112%license LICENSE.txt
113%doc CHANGES.txt README.txt
114%if %{with tool}
115%{_bindir}/%{pypi_name}
116%{_bindir}/%{pypi_name}-2
117%{_bindir}/%{pypi_name}-%{python_version}
118%endif
119%{python_sitelib}/%{pypi_name}*
120%exclude %{python_sitelib}/%{pypi_name}/test
121
122%files -n python3-%{pypi_name}
123%license LICENSE.txt
124%doc CHANGES.txt README.txt
125%if %{with tool}
126%{_bindir}/%{pypi_name}-3
127%{_bindir}/%{pypi_name}-%{python3_version}
128%endif
129%{python3_sitelib}/%{pypi_name}*
130%exclude %{python3_sitelib}/%{pypi_name}/test
131
132%changelog
133* Mon Dec 18 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.30.0a0-8
134- initial build for Vine Linux.
135
136* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.30.0a0-7
137- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
138
139* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.30.0a0-6
140- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
141
142* Tue Jan 03 2017 Charalampos Stratakis <cstratak@redhat.com> - 0.30.0a0-5
143- Enable tests
144
145* Fri Dec 09 2016 Charalampos Stratakis <cstratak@redhat.com> - 0.30.0a0-4
146- Rebuild for Python 3.6 without tests
147
148* Tue Dec 06 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.30.0a0-3
149- Add bootstrap method
150
151* Mon Sep 19 2016 Charalampos Stratakis <cstratak@redhat.com> - 0.30.0a0-2
152- Use the python_provide macro
153
154* Mon Sep 19 2016 Charalampos Stratakis <cstratak@redhat.com> - 0.30.0a0-1
155- Update to 0.30.0a0
156- Added patch to remove keyrings.alt dependency
157
158* Wed Aug 10 2016 Igor Gnatenko <ignatenko@redhat.com> - 0.29.0-1
159- Update to 0.29.0
160- Cleanups and fixes
161
162* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.26.0-3
163- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
164
165* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.26.0-2
166- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
167
168* Tue Oct 13 2015 Robert Kuska <rkuska@redhat.com> - 0.26.0-1
169- Update to 0.26.0
170- Rebuilt for Python3.5 rebuild
171
172* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.24.0-4
173- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
174
175* Tue Jan 13 2015 Slavek Kabrda <bkabrda@redhat.com> - 0.24.0-3
176- Make spec buildable in EPEL 6, too.
177- Remove additional sources added to upstream tarball.
178
179* Sat Jan 03 2015 Matej Cepl <mcepl@redhat.com> - 0.24.0-2
180- Make python3 conditional (switched off for RHEL-7; fixes #1131111).
181
182* Mon Nov 10 2014 Slavek Kabrda <bkabrda@redhat.com> - 0.24.0-1
183- Update to 0.24.0
184- Remove patches merged upstream
185
186* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.22.0-4
187- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
188
189* Fri Apr 25 2014 Matej Stuchlik <mstuchli@redhat.com> - 0.22.0-3
190- Another rebuild with python 3.4
191
192* Fri Apr 18 2014 Matej Stuchlik <mstuchli@redhat.com> - 0.22.0-2
193- Rebuild with python 3.4
194
195* Thu Nov 28 2013 Bohuslav Kabrda <bkabrda@redhat.com> - 0.22.0-1
196- Initial package.
Note: See TracBrowser for help on using the repository browser.