source: projects/specs/trunk/p/python-virtualenv/python-virtualenv-vl.spec @ 1763

Revision 1763, 4.4 KB checked in by daisuke, 14 years ago (diff)

python-virtualenv: new package, 1.4.8-1

Line 
1%global oname virtualenv
2
3Summary:        Tool to create isolated Python environments
4Summary(ja):    隔離されたPython環境を構築するためのツール
5Name:           python-%{oname}
6Version:        1.4.8
7Release:        1%{?_dist_release}
8
9Group:          Development/Languages
10License:        MIT
11URL:            http://pypi.python.org/pypi/%{oname}
12Source0:        http://pypi.python.org/packages/source/v/%{oname}/%{oname}-%{version}.tar.gz
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
14
15BuildArch:      noarch
16BuildRequires:  python-devel
17Requires:       python-setuptools, python-devel
18
19BuildRequires:  python-setuptools
20Requires:       python-setuptools
21
22
23%description
24virtualenv is a tool to create isolated Python environments. virtualenv
25is a successor to workingenv, and an extension of virtual-python. It is
26written by Ian Bicking, and sponsored by the Open Planning Project. It is
27licensed under an MIT-style permissive license.
28
29
30%prep
31%setup -q -n %{oname}-%{version}
32%{__sed} -i -e "1s|#!/usr/bin/env python||" virtualenv.py
33
34
35%build
36%{__python} setup.py build
37
38
39%install
40rm -rf $RPM_BUILD_ROOT
41%{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
42
43 
44%clean
45rm -rf $RPM_BUILD_ROOT
46
47
48%files
49%defattr(-,root,root,-)
50%doc docs/index.txt docs/license.txt docs/news.txt PKG-INFO
51# For noarch packages: sitelib
52%{python_sitelib}/*
53%attr(755,root,root) %{_bindir}/virtualenv
54
55
56%changelog
57* Sat Sep 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.8-1
58- initial build for Vine Linux
59
60* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.4.8-4
61- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
62
63* Tue Jul  7 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-3
64- Fixed EPEL installation issue from BZ#611536
65
66* Tue Jun  8 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-2
67- Only replace the python shebang on the first line (Robert Buchholz)
68
69* Fri Apr 28 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-1
70- update pip to 0.7
71- move regen-docs into bin/
72- Fix #31, make activate_this.py work on Windows (use Lib/site-packages)
73unset PYTHONHOME envioronment variable -- first step towards fixing the PYTHONHOME issue; see e.g. https://bugs.launchpad.net/virtualenv/+bug/290844
74- unset PYTHONHOME in the (Unix) activate script (and reset it in deactivate())
75- use the activate.sh in virtualenv.py via running bin/rebuild-script.py
76- add warning message if PYTHONHOME is set
77
78* Fri Apr 2 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.6-1
79- allow script creation without setuptools
80- fix problem with --relocate when bin/ has subdirs (fixes #12)
81- Allow more flexible .pth file fixup
82- make nt a required module, along with posix. it may not be a builtin module on jython
83- don't mess with PEP 302-supplied __file__, from CPython, and merge in a small startup optimization for Jython, from Jython
84
85* Tue Dec 22 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.3-1
86- Updated for upstream release.
87
88* Thu Nov 12 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.2-1
89- Updated for upstream release.
90
91* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.3-2
92- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
93
94* Tue Apr 28 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.3-1
95- Updated for upstream release.
96
97* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-2
98- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
99
100* Thu Dec 25 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.2-1
101- Updated for upstream release.
102
103* Thu Dec 04 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.3.1-4
104- Rebuild for Python 2.6
105
106* Mon Dec  1 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.1-3
107- Added missing dependencies.
108
109* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.3.1-2
110- Rebuild for Python 2.6
111
112* Fri Nov 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.1-1
113- Updated for upstream release
114
115* Sun Sep 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3-1
116- Updated for upstream release
117
118* Sat Aug 30 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.2-1
119- Updated for upstream release
120
121* Fri Aug 29 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-3
122- Updated from review notes
123
124* Thu Aug 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-2
125- Updated from review notes
126
127* Tue Aug 26 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-1
128- Initial Version
Note: See TracBrowser for help on using the repository browser.