source: projects/specs/trunk/p/python-virtualenv/python-virtualenv-vl.spec @ 11273

Revision 11273, 6.7 KB checked in by tomop, 6 years ago (diff)

python-virtualenv-15.1.0-1

Line 
1%global oname virtualenv
2
3Summary:        Tool to create isolated Python environments
4Summary(ja):    隔離されたPython環境を構築するためのツール
5Name:           python-%{oname}
6Version:        15.1.0
7Release:        1%{?_dist_release}
8
9Group:          Development/Languages
10License:        MIT
11URL:            http://pypi.python.org/pypi/%{oname}
12Source0:        http://pypi.python.org/packages/source/v/%{oname}/%{oname}-%{version}.tar.gz
13# virtualenv -p "/usr/bin/python3" venv fails if there are not packages installed
14# under /usr/local/lib/pythonX.Y/site-packages. Check if exec_dir exists before
15# listing it's content.
16Patch0:         check-exec_dir.patch
17BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildArch:      noarch
19
20Vendor:         Project Vine
21Distribution:   Vine Linux
22Packager:       yasumichi
23
24BuildRequires:  python-rpm-macros
25BuildRequires:  python3-rpm-macros
26
27BuildRequires:  python-devel
28Requires:       python-devel
29
30BuildRequires:  python-setuptools
31Requires:       python-setuptools
32
33
34%description
35virtualenv is a tool to create isolated Python environments. virtualenv
36is a successor to workingenv, and an extension of virtual-python. It is
37written by Ian Bicking, and sponsored by the Open Planning Project. It is
38licensed under an MIT-style permissive license.
39
40
41%package -n     python3-virtualenv
42Summary:        Tool to create isolated Python environments
43Summary(ja):    隔離されたPython環境を構築するためのツール
44
45Requires:       python3-setuptools
46Requires:       python3-devel
47
48%description -n python3-virtualenv
49virtualenv is a tool to create isolated Python environments. virtualenv
50is a successor to workingenv, and an extension of virtual-python. It is
51written by Ian Bicking, and sponsored by the Open Planning Project. It is
52licensed under an MIT-style permissive license
53
54
55%prep
56%setup -q -n %{oname}-%{version}
57%{__sed} -i -e "1s|#!/usr/bin/env python||" virtualenv.py
58
59%patch0 -p1
60
61%build
62# Build code
63%{py_build}
64%{py3_build}
65
66%install
67rm -rf %{buildroot}
68%{py3_install}
69# rename binaries to use python3
70mv %{buildroot}/%{_bindir}/virtualenv %{buildroot}/%{_bindir}/py3-virtualenv
71# The versioned 3.x script was removed from upstream. Add it back.
72cp %{buildroot}/%{_bindir}/py3-virtualenv %{buildroot}/%{_bindir}/virtualenv-%{python3_version}
73cp %{buildroot}/%{_bindir}/py3-virtualenv %{buildroot}/%{_bindir}/virtualenv-3
74
75%{py_install}
76# The versioned 2.x script was removed from upstream. Add it back.
77cp %{buildroot}/%{_bindir}/virtualenv %{buildroot}/%{_bindir}/virtualenv-%{python_version}
78cp %{buildroot}/%{_bindir}/virtualenv %{buildroot}/%{_bindir}/virtualenv-2
79
80
81%clean
82rm -rf %{buildroot}
83
84
85%files
86%defattr(-,root,root,-)
87%license LICENSE.txt
88%doc docs/*rst PKG-INFO AUTHORS.txt
89%{python_sitelib}/*
90%{_bindir}/virtualenv
91%{_bindir}/virtualenv-2
92%{_bindir}/virtualenv-%{python_version}
93
94%files -n python3-virtualenv
95%license LICENSE.txt
96%doc docs/*rst PKG-INFO AUTHORS.txt
97%{_bindir}/py3-virtualenv
98%{_bindir}/virtualenv-3
99%{_bindir}/virtualenv-%{python3_version}
100%{python3_sitelib}/virtualenv.py
101%{python3_sitelib}/virtualenv_support/
102%{python3_sitelib}/virtualenv-*.egg-info/
103%{python3_sitelib}/__pycache__/*
104
105%changelog
106* Mon Dec 18 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.1.0-1
107- new upstream release.
108- added Patch0.
109- made to use python{,3}-rpm-macros.
110- added a sub-package for python3.
111
112* Sat Aug 02 2014 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.11.6-1
113- new upstream release
114- add Vendor, Distribution and Packager
115
116* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.1-2
117- rebuild with python-2.7.2
118
119* Mon Nov 22 2010 Shu KONNO <owa@bg.wakwak.com> 1.5.1-1
120- updated virtualenv to 1.5.1
121
122* Sat Sep 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.8-1
123- initial build for Vine Linux
124
125* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.4.8-4
126- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
127
128* Wed Jul  7 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-3
129- Fixed EPEL installation issue from BZ#611536
130
131* Tue Jun  8 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-2
132- Only replace the python shebang on the first line (Robert Buchholz)
133
134* Wed Apr 28 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-1
135- update pip to 0.7
136- move regen-docs into bin/
137- Fix #31, make activate_this.py work on Windows (use Lib/site-packages)
138unset PYTHONHOME envioronment variable -- first step towards fixing the PYTHONHOME issue; see e.g. https://bugs.launchpad.net/virtualenv/+bug/290844
139- unset PYTHONHOME in the (Unix) activate script (and reset it in deactivate())
140- use the activate.sh in virtualenv.py via running bin/rebuild-script.py
141- add warning message if PYTHONHOME is set
142
143* Fri Apr 2 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.6-1
144- allow script creation without setuptools
145- fix problem with --relocate when bin/ has subdirs (fixes #12)
146- Allow more flexible .pth file fixup
147- make nt a required module, along with posix. it may not be a builtin module on jython
148- don't mess with PEP 302-supplied __file__, from CPython, and merge in a small startup optimization for Jython, from Jython
149
150* Tue Dec 22 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.3-1
151- Updated for upstream release.
152
153* Thu Nov 12 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.2-1
154- Updated for upstream release.
155
156* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.3-2
157- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
158
159* Tue Apr 28 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.3-1
160- Updated for upstream release.
161
162* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-2
163- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
164
165* Thu Dec 25 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.2-1
166- Updated for upstream release.
167
168* Thu Dec 04 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.3.1-4
169- Rebuild for Python 2.6
170
171* Mon Dec  1 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.1-3
172- Added missing dependencies.
173
174* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.3.1-2
175- Rebuild for Python 2.6
176
177* Fri Nov 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.1-1
178- Updated for upstream release
179
180* Sun Sep 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3-1
181- Updated for upstream release
182
183* Sat Aug 30 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.2-1
184- Updated for upstream release
185
186* Fri Aug 29 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-3
187- Updated from review notes
188
189* Thu Aug 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-2
190- Updated from review notes
191
192* Tue Aug 26 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-1
193- Initial Version
Note: See TracBrowser for help on using the repository browser.