source: projects/specs/trunk/p/python-virtualenv-clone/python-virtualenv-clone-vl.spec @ 8880

Revision 8880, 1.7 KB checked in by yasumichi, 10 years ago (diff)

new upstream release

Line 
1%define oname   virtualenv-clone
2
3# Basic Information
4Name:           python-%{oname}
5Version:        0.2.5
6Release:        1%{?_dist_release}
7License:        MIT
8Group:          Development/Tools
9URL:            http://github.com/edwardgeorge/virtualenv-clone
10Source0:        http://pypi.python.org/packages/source/v/%{oname}/%{oname}-%{version}.tar.gz
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12BuildArch:      noarch
13
14Vendor:         Project Vine
15Distribution:   Vine Linux
16Packager:       yasumichi
17
18Summary:        script to clone virtualenvs.
19Summary(ja):    virtualenv 環境を複製するスクリプト
20
21# Dependency
22Requires:       python
23Requires:       python-virtualenv
24BuildRequires:  python
25BuildRequires:  python-setuptools
26
27%description
28virtualenv cloning script.
29
30A script for cloning a non-relocatable virtualenv.
31
32Virtualenv provides a way to make virtualenv's relocatable which could then
33be copied as we wanted. However making a virtualenv relocatable this way
34breaks the no-site-packages isolation of the virtualenv as well as other
35aspects that come with relative paths and '/usr/bin/env' shebangs that may
36be undesirable.
37
38#%%description -l ja
39#ここに日本語で詳細を記述してください。
40
41%prep
42%setup -q -n %{oname}-%{version}
43
44%build
45%{__python} setup.py build
46
47%install
48%{__rm} -rf ${RPM_BUILD_ROOT}
49%{__python} setup.py install --root=${RPM_BUILD_ROOT}
50
51
52%clean
53%{__rm} -rf ${RPM_BUILD_ROOT}
54
55
56%files
57%defattr(-,root,root)
58%doc README
59/usr/bin/%{oname}
60%{python_sitelib}/clonevirtualenv.py
61%{python_sitelib}/clonevirtualenv.pyc
62%{python_sitelib}/virtualenv_clone-%{version}-py%{pyver}.egg-info
63
64
65%changelog
66* Sat Aug 02 2014 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.2.5-1
67- new upstream release
68
69* Fri Aug 03 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.2.4-1
70- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.