source: projects/specs/trunk/p/python-urllib3/python-urllib3-vl.spec @ 12545

Revision 12545, 11.9 KB checked in by tomop, 3 years ago (diff)

rpm-4.16.1.2-1 and requirements

Line 
1%global srcname urllib3
2
3# When bootstrapping Python, we cannot test this yet
4%bcond_without tests
5
6Summary:        Python HTTP library with thread-safe connection pooling and file post
7Name:           python-%{srcname}
8Version:        1.26.3
9Release:        1%{?_dist_release}
10Group:          programming
11Vendor:         Project Vine
12Distribution:   Vine Linux
13
14License:        MIT
15URL:            https://github.com/urllib3/urllib3
16
17Source0:        %{url}/archive/%{version}/%{srcname}-%{version}.tar.gz
18# Unbundle ssl_match_hostname since we depend on it
19Source1:        ssl_match_hostname_py3.py
20BuildArch:      noarch
21
22%{?python_provide:%python_provide python2-%{srcname}}
23
24Requires:       ca-certificates
25
26# Previously bundled things:
27Requires:       python-six
28#Requires:       python-backports-ssl_match_hostname
29
30# Secure extra requirements
31Requires:       python-ipaddress
32Requires:       python-pysocks
33
34BuildRequires:  python-devel
35BuildRequires:  python-rpm-macros
36BuildRequires:  python2-rpm-macros
37BuildRequires:  python2-setuptools
38
39%description
40Python HTTP module with connection pooling and file POST abilities.
41
42
43%package -n python3-%{srcname}
44Summary:        Python3 HTTP library with thread-safe connection pooling and file post
45Group:          programming
46
47BuildRequires:  python3-devel
48BuildRequires:  python3-rpm-macros
49BuildRequires:  python3-setuptools
50
51Requires:       ca-certificates
52Requires:       python3-six
53Requires:       python3-pysocks
54
55%description -n python3-%{srcname}
56Python3 HTTP module with connection pooling and file POST abilities.
57
58
59%prep
60%autosetup -p1 -n %{srcname}-%{version}
61# Drop the dummyserver tests in koji.  They fail there in real builds, but not
62# in scratch builds (weird).
63rm -rf test/with_dummyserver/
64# Don't run the Google App Engine tests
65rm -rf test/appengine/
66# Lots of these tests started failing, even for old versions, so it has something
67# to do with Fedora in particular. They don't fail in upstream build infrastructure
68rm -rf test/contrib/
69
70# Tests for Python built without SSL, but Fedora builds with SSL. These tests
71# fail when combined with the unbundling of backports-ssl_match_hostname
72rm -f test/test_no_ssl.py
73
74%build
75%py_build
76%py3_build
77
78
79%install
80%py_install
81%py3_install
82
83# Unbundle the Python 2 build
84rm -rf %{buildroot}/%{python_sitelib}/urllib3/packages/six.py*
85#rm -rf %{buildroot}/%{python_sitelib}/urllib3/packages/ssl_match_hostname/
86
87mkdir -p %{buildroot}/%{python_sitelib}/urllib3/packages/
88ln -s %{python_sitelib}/six.py %{buildroot}/%{python_sitelib}/urllib3/packages/six.py
89ln -s %{python_sitelib}/six.pyc %{buildroot}/%{python_sitelib}/urllib3/packages/six.pyc
90ln -s %{python_sitelib}/six.pyo %{buildroot}/%{python_sitelib}/urllib3/packages/six.pyo
91#ln -s %{python_sitelib}/backports/ssl_match_hostname \
92#      %{buildroot}/%{python_sitelib}/urllib3/packages/ssl_match_hostname
93
94# Unbundle the Python 3 build
95rm -rf %{buildroot}/%{python3_sitelib}/urllib3/packages/six.py*
96rm -rf %{buildroot}/%{python3_sitelib}/urllib3/packages/__pycache__/six*
97rm -rf %{buildroot}/%{python3_sitelib}/urllib3/packages/ssl_match_hostname/
98
99mkdir -p %{buildroot}/%{python3_sitelib}/urllib3/packages/
100cp -a %{SOURCE1} %{buildroot}/%{python3_sitelib}/urllib3/packages/ssl_match_hostname.py
101ln -s %{python3_sitelib}/six.py %{buildroot}/%{python3_sitelib}/urllib3/packages/six.py
102ln -s %{python3_sitelib}/__pycache__/six.cpython-%{python3_version_nodots}.opt-1.pyc \
103      %{buildroot}/%{python3_sitelib}/urllib3/packages/__pycache__/
104ln -s %{python3_sitelib}/__pycache__/six.cpython-%{python3_version_nodots}.pyc \
105      %{buildroot}/%{python3_sitelib}/urllib3/packages/__pycache__/
106
107
108%files
109%license LICENSE.txt
110%doc CHANGES.rst README.rst CONTRIBUTORS.txt
111%{python_sitelib}/urllib3/
112%{python_sitelib}/urllib3-*.egg-info
113
114
115%files -n python3-%{srcname}
116%license LICENSE.txt
117%doc CHANGES.rst README.rst CONTRIBUTORS.txt
118%{python3_sitelib}/urllib3/
119%{python3_sitelib}/urllib3-*.egg-info
120
121
122%changelog
123* Tue Feb 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.26.3-1
124- new upstream release.
125
126* Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.25.10-1
127- new upstream release.
128
129* Sun Mar 22 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.25.8-1
130- new upstream release.
131
132* Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.24.1-3
133- initial build for Vine Linux.
134
135* Tue Nov 13 2018 Jeremy Cline <jeremy@jcline.org> - 1.24.1-2
136- Adjust unbundling of ssl_match_hostname
137
138* Mon Oct 29 2018 Jeremy Cline <jeremy@jcline.org> - 1.24.1-1
139- Update to v1.24.1
140
141* Wed Jun 20 2018 Lumír Balhar <lbalhar@redhat.com> - 1.23-4
142- Removed unneeded dependency python[23]-psutil
143
144* Mon Jun 18 2018 Miro Hrončok <mhroncok@redhat.com> - 1.23-3
145- Rebuilt for Python 3.7
146
147* Thu Jun 14 2018 Miro Hrončok <mhroncok@redhat.com> - 1.23-2
148- Bootstrap for Python 3.7
149
150* Tue Jun 05 2018 Jeremy Cline <jeremy@jcline.org> - 1.23-1
151- Update to the latest upstream release (rhbz 1586072)
152
153* Wed May 30 2018 Jeremy Cline <jeremy@jcline.org> - 1.22-10
154- Backport patch to support Python 3.7 (rhbz 1584112)
155
156* Thu May 03 2018 Lukas Slebodnik <lslebodn@fedoraproject.org> - 1.22-9
157- Do not lowercase hostnames with custom-protocol (rhbz 1567862)
158- upstream: https://github.com/urllib3/urllib3/issues/1267
159
160* Wed Apr 18 2018 Jeremy Cline <jeremy@jcline.org> - 1.22-8
161- Drop the dependency on idna and cryptography (rhbz 1567862)
162
163* Mon Apr 16 2018 Jeremy Cline <jeremy@jcline.org> - 1.22-7
164- Drop the dependency on PyOpenSSL, it's not needed (rhbz 1567862)
165
166* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.22-6
167- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
168
169* Wed Jan 31 2018 Iryna Shcherbina <ishcherb@redhat.com> - 1.22-5
170- Update Python 2 dependency declarations to new packaging standards
171  (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
172
173* Thu Jan 25 2018 Tomas Hoger <thoger@redhat.com> - 1.22-4
174- Fix FTBFS - Move RECENT_DATE to 2017-06-30
175
176* Fri Dec 01 2017 Jeremy Cline <jeremy@jcline.org> - 1.22-3
177- Symlink the Python 3 bytecode for six (rbhz 1519147)
178
179* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.22-2
180- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
181
182* Fri Jul 21 2017 Jeremy Cline <jeremy@jcline.org> - 1.22-1
183- Update to 1.22 (#1473293)
184
185* Wed May 17 2017 Jeremy Cline <jeremy@jcline.org> - 1.21.1-1
186- Update to 1.21.1 (#1445280)
187
188* Thu Feb 09 2017 Jeremy Cline <jeremy@jcline.org> - 1.20-1
189- Update to 1.20 (#1414775)
190
191* Tue Dec 13 2016 Stratakis Charalampos <cstratak@redhat.com> - 1.19.1-2
192- Rebuild for Python 3.6
193
194* Thu Nov 17 2016 Jeremy Cline <jeremy@jcline.org> 1.19.1-1
195- Update to 1.19.1
196- Clean up the specfile to only support Fedora 26
197
198* Wed Aug 10 2016 Kevin Fenzi <kevin@scrye.com> - 1.16-3
199- Rebuild now that python-requests is ready to update.
200
201* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.16-2
202- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
203
204* Wed Jun 15 2016 Kevin Fenzi <kevin@scrye.com> - 1.16-1
205- Update to 1.16
206
207* Thu Jun 02 2016 Ralph Bean <rbean@redhat.com> - 1.15.1-3
208- Create python2 subpackage to comply with guidelines.
209
210* Wed Jun 01 2016 Ralph Bean <rbean@redhat.com> - 1.15.1-2
211- Remove broken symlinks to unbundled python3-six files
212  https://bugzilla.redhat.com/show_bug.cgi?id=1295015
213
214* Fri Apr 29 2016 Ralph Bean <rbean@redhat.com> - 1.15.1-1
215- Removed patch for ipv6 support, now applied upstream.
216- Latest version.
217- New dep on pysocks.
218
219* Fri Feb 26 2016 Ralph Bean <rbean@redhat.com> - 1.13.1-3
220- Apply patch from upstream to fix ipv6.
221
222* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.13.1-2
223- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
224
225* Mon Dec 21 2015 Ralph Bean <rbean@redhat.com> - 1.13.1-1
226- new version
227
228* Fri Dec 18 2015 Ralph Bean <rbean@redhat.com> - 1.13-1
229- new version
230
231* Mon Dec 14 2015 Ralph Bean <rbean@redhat.com> - 1.12-1
232- new version
233
234* Thu Oct 15 2015 Robert Kuska <rkuska@redhat.com> - 1.10.4-7
235- Rebuilt for Python3.5 rebuild
236
237* Sat Oct 10 2015 Ralph Bean <rbean@redhat.com> - 1.10.4-6
238- Sync from PyPI instead of a git checkout.
239
240* Tue Sep 08 2015 Ralph Bean <rbean@redhat.com> - 1.10.4-5.20150503gita91975b
241- Drop requirement on python-backports-ssl_match_hostname on F22 and newer.
242
243* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.10.4-4.20150503gita91975b
244- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
245
246* Mon Jun 08 2015 Ralph Bean <rbean@redhat.com> - 1.10.4-3.20150503gita91975b
247- Apply pyopenssl injection for an outdated cpython as per upstream advice
248  https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning
249  https://urllib3.readthedocs.org/en/latest/security.html#pyopenssl
250
251* Tue May 19 2015 Ralph Bean <rbean@redhat.com> - 1.10.4-2.20150503gita91975b
252- Specify symlinks for six.py{c,o}, fixing rhbz #1222142.
253
254* Sun May 03 2015 Ralph Bean <rbean@redhat.com> - 1.10.4-1.20150503gita91975b
255- Latest release for python-requests-2.7.0
256
257* Wed Apr 29 2015 Ralph Bean <rbean@redhat.com> - 1.10.3-2.20150429git585983a
258- Grab a git snapshot to get around this chunked encoding failure.
259
260* Wed Apr 22 2015 Ralph Bean <rbean@redhat.com> - 1.10.3-1
261- new version
262
263* Thu Feb 26 2015 Ralph Bean <rbean@redhat.com> - 1.10.2-1
264- new version
265
266* Wed Feb 18 2015 Ralph Bean <rbean@redhat.com> - 1.10.1-1
267- new version
268
269* Wed Feb 18 2015 Ralph Bean <rbean@redhat.com> - 1.10.1-1
270- new version
271
272* Mon Jan 05 2015 Ralph Bean <rbean@redhat.com> - 1.10-2
273- Copy in a shim for ssl_match_hostname on python3.
274
275* Sun Dec 14 2014 Ralph Bean <rbean@redhat.com> - 1.10-1
276- Latest upstream 1.10, for python-requests-2.5.0.
277- Re-do unbundling without patch, with symlinks.
278- Modernize python2 macros.
279- Remove the with_dummyserver tests which fail only sometimes.
280
281* Wed Nov 05 2014 Ralph Bean <rbean@redhat.com> - 1.9.1-1
282- Latest upstream, 1.9.1 for latest python-requests.
283
284* Mon Aug  4 2014 Tom Callaway <spot@fedoraproject.org> - 1.8.2-4
285- fix license handling
286
287* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.2-3
288- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
289
290* Wed May 14 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 1.8.2-2
291- Rebuilt for https://fedoraproject.org/wiki/Changes/Python_3.4
292
293* Mon Apr 21 2014 Arun S A G <sagarun@gmail.com> - 1.8.2-1
294- Update to latest upstream version
295
296* Mon Oct 28 2013 Ralph Bean <rbean@redhat.com> - 1.7.1-2
297- Update patch to find ca_certs in the correct location.
298
299* Wed Sep 25 2013 Ralph Bean <rbean@redhat.com> - 1.7.1-1
300- Latest upstream with support for a new timeout class and py3.4.
301
302* Wed Aug 28 2013 Ralph Bean <rbean@redhat.com> - 1.7-3
303- Bump release again, just to push an unpaired update.
304
305* Mon Aug 26 2013 Ralph Bean <rbean@redhat.com> - 1.7-2
306- Bump release to pair an update with python-requests.
307
308* Thu Aug 22 2013 Ralph Bean <rbean@redhat.com> - 1.7-1
309- Update to latest upstream.
310- Removed the accept-header proxy patch which is included in upstream now.
311- Removed py2.6 compat patch which is included in upstream now.
312
313* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-7
314- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
315
316* Tue Jun 11 2013 Toshio Kuratomi <toshio@fedoraproject.org> - 1.5-6
317- Fix Requires of python-ordereddict to only apply to RHEL
318
319* Fri Mar  1 2013 Toshio Kuratomi <toshio@fedoraproject.org> - 1.5-5
320- Unbundling finished!
321
322* Fri Mar 01 2013 Ralph Bean <rbean@redhat.com> - 1.5-4
323- Upstream patch to fix Accept header when behind a proxy.
324- Reorganize patch numbers to more clearly distinguish them.
325
326* Wed Feb 27 2013 Ralph Bean <rbean@redhat.com> - 1.5-3
327- Renamed patches to python-urllib3-*
328- Fixed ssl check patch to use the correct cert path for Fedora.
329- Included dependency on ca-certificates
330- Cosmetic indentation changes to the .spec file.
331
332* Tue Feb  5 2013 Toshio Kuratomi <toshio@fedoraproject.org> - 1.5-2
333- python3-tornado BR and run all unittests on python3
334
335* Mon Feb 04 2013 Toshio Kuratomi <toshio@fedoraproject.org> 1.5-1
336- Initial fedora build.
Note: See TracBrowser for help on using the repository browser.