source: projects/specs/trunk/p/python-urllib3/python-urllib3-vl.spec @ 12347

Revision 12347, 11.7 KB checked in by tomop, 4 years ago (diff)

updated 4 packages

bluez-5.54-1

gthumb-3.8.3-1

ipmitool-1.8.18-1

python-urllib3-1.25.8-1

Line 
1%global srcname urllib3
2
3# When bootstrapping Python, we cannot test this yet
4%bcond_without tests
5
6Name:           python-%{srcname}
7Version:        1.25.8
8Release:        1%{?_dist_release}
9Summary:        Python HTTP library with thread-safe connection pooling and file post
10
11License:        MIT
12URL:            https://github.com/urllib3/urllib3
13
14Vendor:         Project Vine
15Distribution:   Vine Linux
16
17Source0:        %{url}/archive/%{version}/%{srcname}-%{version}.tar.gz
18# Unbundle ssl_match_hostname since we depend on it
19Source1:        ssl_match_hostname_py3.py
20BuildArch:      noarch
21
22%{?python_provide:%python_provide python2-%{srcname}}
23
24Requires:       ca-certificates
25
26# Previously bundled things:
27Requires:       python-six
28#Requires:       python-backports-ssl_match_hostname
29
30# Secure extra requirements
31Requires:       python-ipaddress
32Requires:       python-pysocks
33
34BuildRequires:  python-devel
35BuildRequires:  python-rpm-macros
36BuildRequires:  python-setuptools
37
38%description
39Python HTTP module with connection pooling and file POST abilities.
40
41
42%package -n python3-%{srcname}
43Summary:        Python3 HTTP library with thread-safe connection pooling and file post
44
45BuildRequires:  python3-devel
46BuildRequires:  python3-rpm-macros
47BuildRequires:  python3-setuptools
48
49Requires:       ca-certificates
50Requires:       python3-six
51Requires:       python3-pysocks
52
53%description -n python3-%{srcname}
54Python3 HTTP module with connection pooling and file POST abilities.
55
56
57%prep
58%autosetup -p1 -n %{srcname}-%{version}
59# Drop the dummyserver tests in koji.  They fail there in real builds, but not
60# in scratch builds (weird).
61rm -rf test/with_dummyserver/
62# Don't run the Google App Engine tests
63rm -rf test/appengine/
64# Lots of these tests started failing, even for old versions, so it has something
65# to do with Fedora in particular. They don't fail in upstream build infrastructure
66rm -rf test/contrib/
67
68# Tests for Python built without SSL, but Fedora builds with SSL. These tests
69# fail when combined with the unbundling of backports-ssl_match_hostname
70rm -f test/test_no_ssl.py
71
72%build
73%py_build
74%py3_build
75
76
77%install
78%py_install
79%py3_install
80
81# Unbundle the Python 2 build
82rm -rf %{buildroot}/%{python_sitelib}/urllib3/packages/six.py*
83#rm -rf %{buildroot}/%{python_sitelib}/urllib3/packages/ssl_match_hostname/
84
85mkdir -p %{buildroot}/%{python_sitelib}/urllib3/packages/
86ln -s %{python_sitelib}/six.py %{buildroot}/%{python_sitelib}/urllib3/packages/six.py
87ln -s %{python_sitelib}/six.pyc %{buildroot}/%{python_sitelib}/urllib3/packages/six.pyc
88ln -s %{python_sitelib}/six.pyo %{buildroot}/%{python_sitelib}/urllib3/packages/six.pyo
89#ln -s %{python_sitelib}/backports/ssl_match_hostname \
90#      %{buildroot}/%{python_sitelib}/urllib3/packages/ssl_match_hostname
91
92# Unbundle the Python 3 build
93rm -rf %{buildroot}/%{python3_sitelib}/urllib3/packages/six.py*
94rm -rf %{buildroot}/%{python3_sitelib}/urllib3/packages/__pycache__/six*
95rm -rf %{buildroot}/%{python3_sitelib}/urllib3/packages/ssl_match_hostname/
96
97mkdir -p %{buildroot}/%{python3_sitelib}/urllib3/packages/
98cp -a %{SOURCE1} %{buildroot}/%{python3_sitelib}/urllib3/packages/ssl_match_hostname.py
99ln -s %{python3_sitelib}/six.py %{buildroot}/%{python3_sitelib}/urllib3/packages/six.py
100ln -s %{python3_sitelib}/__pycache__/six.cpython-%{python3_version_nodots}.opt-1.pyc \
101      %{buildroot}/%{python3_sitelib}/urllib3/packages/__pycache__/
102ln -s %{python3_sitelib}/__pycache__/six.cpython-%{python3_version_nodots}.pyc \
103      %{buildroot}/%{python3_sitelib}/urllib3/packages/__pycache__/
104
105
106%files
107%license LICENSE.txt
108%doc CHANGES.rst README.rst CONTRIBUTORS.txt
109%{python_sitelib}/urllib3/
110%{python_sitelib}/urllib3-*.egg-info
111
112
113%files -n python3-%{srcname}
114%license LICENSE.txt
115%doc CHANGES.rst README.rst CONTRIBUTORS.txt
116%{python3_sitelib}/urllib3/
117%{python3_sitelib}/urllib3-*.egg-info
118
119
120%changelog
121* Sun Mar 22 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.25.8-1
122- new upstream release.
123
124* Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.24.1-3
125- initial build for Vine Linux.
126
127* Tue Nov 13 2018 Jeremy Cline <jeremy@jcline.org> - 1.24.1-2
128- Adjust unbundling of ssl_match_hostname
129
130* Mon Oct 29 2018 Jeremy Cline <jeremy@jcline.org> - 1.24.1-1
131- Update to v1.24.1
132
133* Wed Jun 20 2018 Lumír Balhar <lbalhar@redhat.com> - 1.23-4
134- Removed unneeded dependency python[23]-psutil
135
136* Mon Jun 18 2018 Miro Hrončok <mhroncok@redhat.com> - 1.23-3
137- Rebuilt for Python 3.7
138
139* Thu Jun 14 2018 Miro Hrončok <mhroncok@redhat.com> - 1.23-2
140- Bootstrap for Python 3.7
141
142* Tue Jun 05 2018 Jeremy Cline <jeremy@jcline.org> - 1.23-1
143- Update to the latest upstream release (rhbz 1586072)
144
145* Wed May 30 2018 Jeremy Cline <jeremy@jcline.org> - 1.22-10
146- Backport patch to support Python 3.7 (rhbz 1584112)
147
148* Thu May 03 2018 Lukas Slebodnik <lslebodn@fedoraproject.org> - 1.22-9
149- Do not lowercase hostnames with custom-protocol (rhbz 1567862)
150- upstream: https://github.com/urllib3/urllib3/issues/1267
151
152* Wed Apr 18 2018 Jeremy Cline <jeremy@jcline.org> - 1.22-8
153- Drop the dependency on idna and cryptography (rhbz 1567862)
154
155* Mon Apr 16 2018 Jeremy Cline <jeremy@jcline.org> - 1.22-7
156- Drop the dependency on PyOpenSSL, it's not needed (rhbz 1567862)
157
158* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.22-6
159- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
160
161* Wed Jan 31 2018 Iryna Shcherbina <ishcherb@redhat.com> - 1.22-5
162- Update Python 2 dependency declarations to new packaging standards
163  (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
164
165* Thu Jan 25 2018 Tomas Hoger <thoger@redhat.com> - 1.22-4
166- Fix FTBFS - Move RECENT_DATE to 2017-06-30
167
168* Fri Dec 01 2017 Jeremy Cline <jeremy@jcline.org> - 1.22-3
169- Symlink the Python 3 bytecode for six (rbhz 1519147)
170
171* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.22-2
172- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
173
174* Fri Jul 21 2017 Jeremy Cline <jeremy@jcline.org> - 1.22-1
175- Update to 1.22 (#1473293)
176
177* Wed May 17 2017 Jeremy Cline <jeremy@jcline.org> - 1.21.1-1
178- Update to 1.21.1 (#1445280)
179
180* Thu Feb 09 2017 Jeremy Cline <jeremy@jcline.org> - 1.20-1
181- Update to 1.20 (#1414775)
182
183* Tue Dec 13 2016 Stratakis Charalampos <cstratak@redhat.com> - 1.19.1-2
184- Rebuild for Python 3.6
185
186* Thu Nov 17 2016 Jeremy Cline <jeremy@jcline.org> 1.19.1-1
187- Update to 1.19.1
188- Clean up the specfile to only support Fedora 26
189
190* Wed Aug 10 2016 Kevin Fenzi <kevin@scrye.com> - 1.16-3
191- Rebuild now that python-requests is ready to update.
192
193* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.16-2
194- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
195
196* Wed Jun 15 2016 Kevin Fenzi <kevin@scrye.com> - 1.16-1
197- Update to 1.16
198
199* Thu Jun 02 2016 Ralph Bean <rbean@redhat.com> - 1.15.1-3
200- Create python2 subpackage to comply with guidelines.
201
202* Wed Jun 01 2016 Ralph Bean <rbean@redhat.com> - 1.15.1-2
203- Remove broken symlinks to unbundled python3-six files
204  https://bugzilla.redhat.com/show_bug.cgi?id=1295015
205
206* Fri Apr 29 2016 Ralph Bean <rbean@redhat.com> - 1.15.1-1
207- Removed patch for ipv6 support, now applied upstream.
208- Latest version.
209- New dep on pysocks.
210
211* Fri Feb 26 2016 Ralph Bean <rbean@redhat.com> - 1.13.1-3
212- Apply patch from upstream to fix ipv6.
213
214* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.13.1-2
215- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
216
217* Mon Dec 21 2015 Ralph Bean <rbean@redhat.com> - 1.13.1-1
218- new version
219
220* Fri Dec 18 2015 Ralph Bean <rbean@redhat.com> - 1.13-1
221- new version
222
223* Mon Dec 14 2015 Ralph Bean <rbean@redhat.com> - 1.12-1
224- new version
225
226* Thu Oct 15 2015 Robert Kuska <rkuska@redhat.com> - 1.10.4-7
227- Rebuilt for Python3.5 rebuild
228
229* Sat Oct 10 2015 Ralph Bean <rbean@redhat.com> - 1.10.4-6
230- Sync from PyPI instead of a git checkout.
231
232* Tue Sep 08 2015 Ralph Bean <rbean@redhat.com> - 1.10.4-5.20150503gita91975b
233- Drop requirement on python-backports-ssl_match_hostname on F22 and newer.
234
235* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.10.4-4.20150503gita91975b
236- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
237
238* Mon Jun 08 2015 Ralph Bean <rbean@redhat.com> - 1.10.4-3.20150503gita91975b
239- Apply pyopenssl injection for an outdated cpython as per upstream advice
240  https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning
241  https://urllib3.readthedocs.org/en/latest/security.html#pyopenssl
242
243* Tue May 19 2015 Ralph Bean <rbean@redhat.com> - 1.10.4-2.20150503gita91975b
244- Specify symlinks for six.py{c,o}, fixing rhbz #1222142.
245
246* Sun May 03 2015 Ralph Bean <rbean@redhat.com> - 1.10.4-1.20150503gita91975b
247- Latest release for python-requests-2.7.0
248
249* Wed Apr 29 2015 Ralph Bean <rbean@redhat.com> - 1.10.3-2.20150429git585983a
250- Grab a git snapshot to get around this chunked encoding failure.
251
252* Wed Apr 22 2015 Ralph Bean <rbean@redhat.com> - 1.10.3-1
253- new version
254
255* Thu Feb 26 2015 Ralph Bean <rbean@redhat.com> - 1.10.2-1
256- new version
257
258* Wed Feb 18 2015 Ralph Bean <rbean@redhat.com> - 1.10.1-1
259- new version
260
261* Wed Feb 18 2015 Ralph Bean <rbean@redhat.com> - 1.10.1-1
262- new version
263
264* Mon Jan 05 2015 Ralph Bean <rbean@redhat.com> - 1.10-2
265- Copy in a shim for ssl_match_hostname on python3.
266
267* Sun Dec 14 2014 Ralph Bean <rbean@redhat.com> - 1.10-1
268- Latest upstream 1.10, for python-requests-2.5.0.
269- Re-do unbundling without patch, with symlinks.
270- Modernize python2 macros.
271- Remove the with_dummyserver tests which fail only sometimes.
272
273* Wed Nov 05 2014 Ralph Bean <rbean@redhat.com> - 1.9.1-1
274- Latest upstream, 1.9.1 for latest python-requests.
275
276* Mon Aug  4 2014 Tom Callaway <spot@fedoraproject.org> - 1.8.2-4
277- fix license handling
278
279* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.2-3
280- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
281
282* Wed May 14 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 1.8.2-2
283- Rebuilt for https://fedoraproject.org/wiki/Changes/Python_3.4
284
285* Mon Apr 21 2014 Arun S A G <sagarun@gmail.com> - 1.8.2-1
286- Update to latest upstream version
287
288* Mon Oct 28 2013 Ralph Bean <rbean@redhat.com> - 1.7.1-2
289- Update patch to find ca_certs in the correct location.
290
291* Wed Sep 25 2013 Ralph Bean <rbean@redhat.com> - 1.7.1-1
292- Latest upstream with support for a new timeout class and py3.4.
293
294* Wed Aug 28 2013 Ralph Bean <rbean@redhat.com> - 1.7-3
295- Bump release again, just to push an unpaired update.
296
297* Mon Aug 26 2013 Ralph Bean <rbean@redhat.com> - 1.7-2
298- Bump release to pair an update with python-requests.
299
300* Thu Aug 22 2013 Ralph Bean <rbean@redhat.com> - 1.7-1
301- Update to latest upstream.
302- Removed the accept-header proxy patch which is included in upstream now.
303- Removed py2.6 compat patch which is included in upstream now.
304
305* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-7
306- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
307
308* Tue Jun 11 2013 Toshio Kuratomi <toshio@fedoraproject.org> - 1.5-6
309- Fix Requires of python-ordereddict to only apply to RHEL
310
311* Fri Mar  1 2013 Toshio Kuratomi <toshio@fedoraproject.org> - 1.5-5
312- Unbundling finished!
313
314* Fri Mar 01 2013 Ralph Bean <rbean@redhat.com> - 1.5-4
315- Upstream patch to fix Accept header when behind a proxy.
316- Reorganize patch numbers to more clearly distinguish them.
317
318* Wed Feb 27 2013 Ralph Bean <rbean@redhat.com> - 1.5-3
319- Renamed patches to python-urllib3-*
320- Fixed ssl check patch to use the correct cert path for Fedora.
321- Included dependency on ca-certificates
322- Cosmetic indentation changes to the .spec file.
323
324* Tue Feb  5 2013 Toshio Kuratomi <toshio@fedoraproject.org> - 1.5-2
325- python3-tornado BR and run all unittests on python3
326
327* Mon Feb 04 2013 Toshio Kuratomi <toshio@fedoraproject.org> 1.5-1
328- Initial fedora build.
Note: See TracBrowser for help on using the repository browser.