source: projects/specs/trunk/p/python-urllib3/python-urllib3-vl.spec @ 11940

Revision 11940, 11.4 KB checked in by tomop, 5 years ago (diff)

python-sphinx-1.7.9-1 and requirements

Line 
1%global srcname urllib3
2
3# When bootstrapping Python, we cannot test this yet
4%bcond_without tests
5
6Name:           python-%{srcname}
7Version:        1.24.1
8Release:        3%{?_dist_release}
9Summary:        Python HTTP library with thread-safe connection pooling and file post
10
11License:        MIT
12URL:            https://github.com/urllib3/urllib3
13
14Vendor:         Project Vine
15Distribution:   Vine Linux
16
17Source0:        %{url}/archive/%{version}/%{srcname}-%{version}.tar.gz
18# Unbundle ssl_match_hostname since we depend on it
19Source1:        ssl_match_hostname_py3.py
20BuildArch:      noarch
21
22%{?python_provide:%python_provide python2-%{srcname}}
23
24Requires:       ca-certificates
25
26# Previously bundled things:
27Requires:       python-six
28#Requires:       python-backports-ssl_match_hostname
29
30# Secure extra requirements
31Requires:       python-ipaddress
32Requires:       python-pysocks
33
34BuildRequires:  python-devel
35
36%description
37Python HTTP module with connection pooling and file POST abilities.
38
39
40%package -n python3-%{srcname}
41Summary:        Python3 HTTP library with thread-safe connection pooling and file post
42
43BuildRequires:  python3-devel
44
45Requires:       ca-certificates
46Requires:       python3-six
47Requires:       python3-pysocks
48
49%description -n python3-%{srcname}
50Python3 HTTP module with connection pooling and file POST abilities.
51
52
53%prep
54%autosetup -p1 -n %{srcname}-%{version}
55# Drop the dummyserver tests in koji.  They fail there in real builds, but not
56# in scratch builds (weird).
57rm -rf test/with_dummyserver/
58# Don't run the Google App Engine tests
59rm -rf test/appengine/
60# Lots of these tests started failing, even for old versions, so it has something
61# to do with Fedora in particular. They don't fail in upstream build infrastructure
62rm -rf test/contrib/
63
64# Tests for Python built without SSL, but Fedora builds with SSL. These tests
65# fail when combined with the unbundling of backports-ssl_match_hostname
66rm -f test/test_no_ssl.py
67
68%build
69%py_build
70%py3_build
71
72
73%install
74%py_install
75%py3_install
76
77# Unbundle the Python 2 build
78rm -rf %{buildroot}/%{python_sitelib}/urllib3/packages/six.py*
79#rm -rf %{buildroot}/%{python_sitelib}/urllib3/packages/ssl_match_hostname/
80
81mkdir -p %{buildroot}/%{python_sitelib}/urllib3/packages/
82ln -s %{python_sitelib}/six.py %{buildroot}/%{python_sitelib}/urllib3/packages/six.py
83ln -s %{python_sitelib}/six.pyc %{buildroot}/%{python_sitelib}/urllib3/packages/six.pyc
84ln -s %{python_sitelib}/six.pyo %{buildroot}/%{python_sitelib}/urllib3/packages/six.pyo
85#ln -s %{python_sitelib}/backports/ssl_match_hostname \
86#      %{buildroot}/%{python_sitelib}/urllib3/packages/ssl_match_hostname
87
88# Unbundle the Python 3 build
89rm -rf %{buildroot}/%{python3_sitelib}/urllib3/packages/six.py*
90rm -rf %{buildroot}/%{python3_sitelib}/urllib3/packages/__pycache__/six*
91rm -rf %{buildroot}/%{python3_sitelib}/urllib3/packages/ssl_match_hostname/
92
93mkdir -p %{buildroot}/%{python3_sitelib}/urllib3/packages/
94cp -a %{SOURCE1} %{buildroot}/%{python3_sitelib}/urllib3/packages/ssl_match_hostname.py
95ln -s %{python3_sitelib}/six.py %{buildroot}/%{python3_sitelib}/urllib3/packages/six.py
96ln -s %{python3_sitelib}/__pycache__/six.cpython-%{python3_version_nodots}.opt-1.pyc \
97      %{buildroot}/%{python3_sitelib}/urllib3/packages/__pycache__/
98ln -s %{python3_sitelib}/__pycache__/six.cpython-%{python3_version_nodots}.pyc \
99      %{buildroot}/%{python3_sitelib}/urllib3/packages/__pycache__/
100
101
102%files
103%license LICENSE.txt
104%doc CHANGES.rst README.rst CONTRIBUTORS.txt
105%{python_sitelib}/urllib3/
106%{python_sitelib}/urllib3-*.egg-info
107
108
109%files -n python3-%{srcname}
110%license LICENSE.txt
111%doc CHANGES.rst README.rst CONTRIBUTORS.txt
112%{python3_sitelib}/urllib3/
113%{python3_sitelib}/urllib3-*.egg-info
114
115
116%changelog
117* Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.24.1-3
118- initial build for Vine Linux.
119
120* Tue Nov 13 2018 Jeremy Cline <jeremy@jcline.org> - 1.24.1-2
121- Adjust unbundling of ssl_match_hostname
122
123* Mon Oct 29 2018 Jeremy Cline <jeremy@jcline.org> - 1.24.1-1
124- Update to v1.24.1
125
126* Wed Jun 20 2018 Lumír Balhar <lbalhar@redhat.com> - 1.23-4
127- Removed unneeded dependency python[23]-psutil
128
129* Mon Jun 18 2018 Miro Hrončok <mhroncok@redhat.com> - 1.23-3
130- Rebuilt for Python 3.7
131
132* Thu Jun 14 2018 Miro Hrončok <mhroncok@redhat.com> - 1.23-2
133- Bootstrap for Python 3.7
134
135* Tue Jun 05 2018 Jeremy Cline <jeremy@jcline.org> - 1.23-1
136- Update to the latest upstream release (rhbz 1586072)
137
138* Wed May 30 2018 Jeremy Cline <jeremy@jcline.org> - 1.22-10
139- Backport patch to support Python 3.7 (rhbz 1584112)
140
141* Thu May 03 2018 Lukas Slebodnik <lslebodn@fedoraproject.org> - 1.22-9
142- Do not lowercase hostnames with custom-protocol (rhbz 1567862)
143- upstream: https://github.com/urllib3/urllib3/issues/1267
144
145* Wed Apr 18 2018 Jeremy Cline <jeremy@jcline.org> - 1.22-8
146- Drop the dependency on idna and cryptography (rhbz 1567862)
147
148* Mon Apr 16 2018 Jeremy Cline <jeremy@jcline.org> - 1.22-7
149- Drop the dependency on PyOpenSSL, it's not needed (rhbz 1567862)
150
151* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.22-6
152- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
153
154* Wed Jan 31 2018 Iryna Shcherbina <ishcherb@redhat.com> - 1.22-5
155- Update Python 2 dependency declarations to new packaging standards
156  (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
157
158* Thu Jan 25 2018 Tomas Hoger <thoger@redhat.com> - 1.22-4
159- Fix FTBFS - Move RECENT_DATE to 2017-06-30
160
161* Fri Dec 01 2017 Jeremy Cline <jeremy@jcline.org> - 1.22-3
162- Symlink the Python 3 bytecode for six (rbhz 1519147)
163
164* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.22-2
165- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
166
167* Fri Jul 21 2017 Jeremy Cline <jeremy@jcline.org> - 1.22-1
168- Update to 1.22 (#1473293)
169
170* Wed May 17 2017 Jeremy Cline <jeremy@jcline.org> - 1.21.1-1
171- Update to 1.21.1 (#1445280)
172
173* Thu Feb 09 2017 Jeremy Cline <jeremy@jcline.org> - 1.20-1
174- Update to 1.20 (#1414775)
175
176* Tue Dec 13 2016 Stratakis Charalampos <cstratak@redhat.com> - 1.19.1-2
177- Rebuild for Python 3.6
178
179* Thu Nov 17 2016 Jeremy Cline <jeremy@jcline.org> 1.19.1-1
180- Update to 1.19.1
181- Clean up the specfile to only support Fedora 26
182
183* Wed Aug 10 2016 Kevin Fenzi <kevin@scrye.com> - 1.16-3
184- Rebuild now that python-requests is ready to update.
185
186* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.16-2
187- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
188
189* Wed Jun 15 2016 Kevin Fenzi <kevin@scrye.com> - 1.16-1
190- Update to 1.16
191
192* Thu Jun 02 2016 Ralph Bean <rbean@redhat.com> - 1.15.1-3
193- Create python2 subpackage to comply with guidelines.
194
195* Wed Jun 01 2016 Ralph Bean <rbean@redhat.com> - 1.15.1-2
196- Remove broken symlinks to unbundled python3-six files
197  https://bugzilla.redhat.com/show_bug.cgi?id=1295015
198
199* Fri Apr 29 2016 Ralph Bean <rbean@redhat.com> - 1.15.1-1
200- Removed patch for ipv6 support, now applied upstream.
201- Latest version.
202- New dep on pysocks.
203
204* Fri Feb 26 2016 Ralph Bean <rbean@redhat.com> - 1.13.1-3
205- Apply patch from upstream to fix ipv6.
206
207* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.13.1-2
208- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
209
210* Mon Dec 21 2015 Ralph Bean <rbean@redhat.com> - 1.13.1-1
211- new version
212
213* Fri Dec 18 2015 Ralph Bean <rbean@redhat.com> - 1.13-1
214- new version
215
216* Mon Dec 14 2015 Ralph Bean <rbean@redhat.com> - 1.12-1
217- new version
218
219* Thu Oct 15 2015 Robert Kuska <rkuska@redhat.com> - 1.10.4-7
220- Rebuilt for Python3.5 rebuild
221
222* Sat Oct 10 2015 Ralph Bean <rbean@redhat.com> - 1.10.4-6
223- Sync from PyPI instead of a git checkout.
224
225* Tue Sep 08 2015 Ralph Bean <rbean@redhat.com> - 1.10.4-5.20150503gita91975b
226- Drop requirement on python-backports-ssl_match_hostname on F22 and newer.
227
228* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.10.4-4.20150503gita91975b
229- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
230
231* Mon Jun 08 2015 Ralph Bean <rbean@redhat.com> - 1.10.4-3.20150503gita91975b
232- Apply pyopenssl injection for an outdated cpython as per upstream advice
233  https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning
234  https://urllib3.readthedocs.org/en/latest/security.html#pyopenssl
235
236* Tue May 19 2015 Ralph Bean <rbean@redhat.com> - 1.10.4-2.20150503gita91975b
237- Specify symlinks for six.py{c,o}, fixing rhbz #1222142.
238
239* Sun May 03 2015 Ralph Bean <rbean@redhat.com> - 1.10.4-1.20150503gita91975b
240- Latest release for python-requests-2.7.0
241
242* Wed Apr 29 2015 Ralph Bean <rbean@redhat.com> - 1.10.3-2.20150429git585983a
243- Grab a git snapshot to get around this chunked encoding failure.
244
245* Wed Apr 22 2015 Ralph Bean <rbean@redhat.com> - 1.10.3-1
246- new version
247
248* Thu Feb 26 2015 Ralph Bean <rbean@redhat.com> - 1.10.2-1
249- new version
250
251* Wed Feb 18 2015 Ralph Bean <rbean@redhat.com> - 1.10.1-1
252- new version
253
254* Wed Feb 18 2015 Ralph Bean <rbean@redhat.com> - 1.10.1-1
255- new version
256
257* Mon Jan 05 2015 Ralph Bean <rbean@redhat.com> - 1.10-2
258- Copy in a shim for ssl_match_hostname on python3.
259
260* Sun Dec 14 2014 Ralph Bean <rbean@redhat.com> - 1.10-1
261- Latest upstream 1.10, for python-requests-2.5.0.
262- Re-do unbundling without patch, with symlinks.
263- Modernize python2 macros.
264- Remove the with_dummyserver tests which fail only sometimes.
265
266* Wed Nov 05 2014 Ralph Bean <rbean@redhat.com> - 1.9.1-1
267- Latest upstream, 1.9.1 for latest python-requests.
268
269* Mon Aug  4 2014 Tom Callaway <spot@fedoraproject.org> - 1.8.2-4
270- fix license handling
271
272* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.2-3
273- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
274
275* Wed May 14 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 1.8.2-2
276- Rebuilt for https://fedoraproject.org/wiki/Changes/Python_3.4
277
278* Mon Apr 21 2014 Arun S A G <sagarun@gmail.com> - 1.8.2-1
279- Update to latest upstream version
280
281* Mon Oct 28 2013 Ralph Bean <rbean@redhat.com> - 1.7.1-2
282- Update patch to find ca_certs in the correct location.
283
284* Wed Sep 25 2013 Ralph Bean <rbean@redhat.com> - 1.7.1-1
285- Latest upstream with support for a new timeout class and py3.4.
286
287* Wed Aug 28 2013 Ralph Bean <rbean@redhat.com> - 1.7-3
288- Bump release again, just to push an unpaired update.
289
290* Mon Aug 26 2013 Ralph Bean <rbean@redhat.com> - 1.7-2
291- Bump release to pair an update with python-requests.
292
293* Thu Aug 22 2013 Ralph Bean <rbean@redhat.com> - 1.7-1
294- Update to latest upstream.
295- Removed the accept-header proxy patch which is included in upstream now.
296- Removed py2.6 compat patch which is included in upstream now.
297
298* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-7
299- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
300
301* Tue Jun 11 2013 Toshio Kuratomi <toshio@fedoraproject.org> - 1.5-6
302- Fix Requires of python-ordereddict to only apply to RHEL
303
304* Fri Mar  1 2013 Toshio Kuratomi <toshio@fedoraproject.org> - 1.5-5
305- Unbundling finished!
306
307* Fri Mar 01 2013 Ralph Bean <rbean@redhat.com> - 1.5-4
308- Upstream patch to fix Accept header when behind a proxy.
309- Reorganize patch numbers to more clearly distinguish them.
310
311* Wed Feb 27 2013 Ralph Bean <rbean@redhat.com> - 1.5-3
312- Renamed patches to python-urllib3-*
313- Fixed ssl check patch to use the correct cert path for Fedora.
314- Included dependency on ca-certificates
315- Cosmetic indentation changes to the .spec file.
316
317* Tue Feb  5 2013 Toshio Kuratomi <toshio@fedoraproject.org> - 1.5-2
318- python3-tornado BR and run all unittests on python3
319
320* Mon Feb 04 2013 Toshio Kuratomi <toshio@fedoraproject.org> 1.5-1
321- Initial fedora build.
Note: See TracBrowser for help on using the repository browser.