source: projects/specs/trunk/p/python-urlgrabber/python-urlgrabber-vl.spec @ 9328

Revision 9328, 12.2 KB checked in by inagaki, 9 years ago (diff)

2015-02-04 Ryoichi INAGAKI <ryo1@…>

  • MySQL-python, kio-upnp-ms, kio_mtp, python-oauth python-urlgrabber: new package
  • amarok: updated


Line 
1%{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Summary: A high-level cross-protocol url-grabber
4Name: python-urlgrabber
5Version: 3.10.1
6Release: 7%{?_dist_release}
7
8License: LGPLv2+
9Group: Development/Libraries
10URL: http://urlgrabber.baseurl.org/
11
12Source0: http://urlgrabber.baseurl.org/download/urlgrabber-%{version}.tar.gz
13Patch1: urlgrabber-HEAD.patch
14Patch2: BZ-1051554-speed-on-404-mirror.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17BuildArch: noarch
18BuildRequires: python-devel
19BuildRequires: python-pycurl
20Requires: python-pycurl
21Provides: urlgrabber = %{version}-%{release}
22
23%description
24A high-level cross-protocol url-grabber for python supporting HTTP, FTP
25and file locations.  Features include keepalive, byte ranges, throttling,
26authentication, proxies and more.
27
28%prep
29%setup -q -n urlgrabber-%{version}
30%patch1 -p1
31%patch2 -p1
32
33%build
34python setup.py build
35
36%install
37rm -rf $RPM_BUILD_ROOT
38python setup.py install -O1 --root=$RPM_BUILD_ROOT
39rm -rf $RPM_BUILD_ROOT/%{_docdir}/urlgrabber-%{version}
40
41%clean
42rm -rf $RPM_BUILD_ROOT
43
44%files
45%defattr(-,root,root,-)
46%doc ChangeLog README TODO LICENSE
47%{_bindir}/urlgrabber
48%attr(0755,root,root) %{_libexecdir}/urlgrabber-ext-down
49%{python_sitelib}/urlgrabber*
50
51%changelog
52* Tue Feb  3 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 3.10.1-7
53- Inital build for Vine Linux
54
55* Fri Oct 03 2014 Valentina Mukhamedzhanova <vmukhame@redhat.com> - 3.10.1-6
56- Revert porting to Python 3.
57
58* Tue Sep 09 2014 Tomas Radej <tradej@redhat.com> - 3.10.1-5
59- Really fixed UTF behaviour
60
61* Tue Sep 02 2014 Tomas Radej <tradej@redhat.com> - 3.10.1-4
62- Fixed UTF behaviour (bz #1135632)
63
64* Fri Aug 29 2014 Valentina Mukhamedzhanova <vmukhame@redhat.com> - 3.10.1-3
65- Don't set speed=0 on a new mirror that 404'd. BZ 1051554
66- Support both Python 2 and 3. BZ 985288
67
68* Sun Aug  3 2014 Tom Callaway <spot@fedoraproject.org> - 3.10.1-2
69- fix license handling
70
71* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.10.1-1
72- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
73
74* Wed Dec 18 2013 Zdenek Pavlas <zpavlas@redhat.com> - 3.10.1-0
75- Update to latest HEAD.
76- Decrease the default_speed value. BZ 1043177
77- Added client-side range support. BZ 435076
78
79* Mon Dec  9 2013 Zdenek Pavlas <zpavlas@redhat.com> - 3.10-1
80- Process mirror retries before other queued requests.
81- Tell curl to return immediately on ctrl-c. BZ 1017491
82
83* Wed Oct  9 2013 Zdenek Pavlas <zpavlas@redhat.com> - 3.10-0
84- Update to latest HEAD.
85- clamp timestamps from the future.  BZ 894630, 1013733
86- Fix the condition to enter single-connection mode. BZ 853432
87- Fix unit tests
88
89* Fri Sep 27 2013 Zdenek Pavlas <zpavlas@redhat.com> - 3.9.1-32
90- Update to latest HEAD.
91- Switch to max_connections=1 after refused connect. BZ 853432
92- Never display negative downloading speed. BZ 1001767
93
94* Thu Aug 29 2013 Zdenek Pavlas <zpavlas@redhat.com> - 3.9.1-31
95- Update to latest HEAD.
96- add ftp_disable_epsv option. BZ 849177
97- Spelling fixes.
98- docs: throttling is per-connection, suggest max_connections=1. BZ 998263
99- More robust "Content-Length" parsing. BZ 1000841
100
101* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.9.1-30
102- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
103
104* Tue Jun 18 2013 Zdenek Pavlas <zpavlas@redhat.com> - 3.9.1-29
105- Update to latest HEAD.
106- Fix parsing of FTP 213 responses
107- Switch to max_connections=1 after timing out.  BZ 853432
108- max_connections=0 should imply the default limit.
109
110* Fri May 17 2013 Zdenek Pavlas <zpavlas@redhat.com> - 3.9.1-28
111- Update to latest HEAD.
112- Add the "minrate" option. BZ 964298
113- Workaround progress "!!!" end for file:// repos.
114- add URLGrabError.code to the external downloader API
115- Disable GSSNEGOTIATE to work around a curl bug.  BZ 960163
116
117* Wed Mar 27 2013 Zdenek Pavlas <zpavlas@redhat.com> - 3.9.1-26
118- Update to latest HEAD.
119- Handle HTTP 200 response to range requests correctly.  BZ 919076
120- Reset curl_obj to clear CURLOPT_RANGE from previous requests.  BZ 923951
121
122* Thu Mar  7 2013 Zdeněk Pavlas <zpavlas@redhat.com> - 3.9.1-25
123- Update to latest HEAD.
124- fix some test cases that were failing.  BZ 918658
125- exit(1) or /bin/urlgrabber failures.  BZ 918613
126- clamp timestamps from the future.  BZ 894630
127- enable GSSNEGOTIATE if implemented correctly.
128- make error messages more verbose.
129
130* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.9.1-24
131- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
132
133* Mon Jan  7 2013 Zdeněk Pavlas <zpavlas@redhat.com> - 3.9.1-23
134- Update to latest HEAD.
135- Handle checkfunc unicode exceptions. BZ 672117
136
137* Thu Dec  6 2012 Zdeněk Pavlas <zpavlas@redhat.com> - 3.9.1-22
138- Update to latest HEAD.
139- Improve URLGRABBER_DEBUG, add max_connections.  BZ 853432
140
141* Thu Nov  1 2012 Zdeněk Pavlas <zpavlas@redhat.com> - 3.9.1-21
142- Update to latest HEAD.
143- Get rid of "HTTP 200 OK" errors.  BZ 871835.
144
145* Tue Sep  4 2012 Zdeněk Pavlas <zpavlas@redhat.com> - 3.9.1-20
146- Update to latest HEAD.
147- Fixed BZ 851178, 854075.
148
149* Mon Aug 27 2012 Zdeněk Pavlas <zpavlas@redhat.com> - 3.9.1-19
150- timedhosts: defer 1st update until a 1MB+ download.  BZ 851178
151
152* Wed Aug 22 2012 Zdeněk Pavlas <zpavlas@redhat.com> - 3.9.1-18
153- Update to latest HEAD, lots of enhancements.
154
155* Wed Aug 10 2012 Zdeněk Pavlas <zpavlas@redhat.com> - 3.9.1-17
156- Fix a bug in progress display code. BZ 847105.
157
158* Wed Aug  8 2012 Zdeněk Pavlas <zpavlas@redhat.com> - 3.9.1-16
159- Update to latest head.
160- Improved multi-file progress, small bugfixes.
161
162* Fri Jul 20 2012 Zdeněk Pavlas <zpavlas@redhat.com> - 3.9.1-15
163- Update to latest head, misc bugfixes: BZ 832028, 831904, 831291.
164- Disable Kerberos auth.  BZ 769254
165- copy_local bugfix. BZ 837018
166- send 'tries' counter to mirror failure callback
167
168* Mon May 21 2012 Zdeněk Pavlas <zpavlas@redhat.com> - 3.9.1-14
169- timedhosts: sanity check on dl_time
170
171* Fri May 18 2012 Zdeněk Pavlas <zpavlas@redhat.com> - 3.9.1-13
172- fix file:// profiling.  BZ 822632.
173
174* Mon May 14 2012 Zdeněk Pavlas <zpavlas@redhat.com> - 3.9.1-12
175- Update to latest HEAD
176- Merge multi-downloader patches
177
178* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.9.1-11
179- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
180
181* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.9.1-10
182- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
183
184* Fri Sep  3 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.9.1-9
185- new update to latest head with a number of patches collected from
186  older bug reports.
187
188* Mon Aug 30 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.9.1-8
189- update to latest head patches
190
191* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 3.9.1-7
192- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
193
194* Tue Apr 13 2010 James Antill <james@fedoraproject.org> 3.9.1-6
195- Update to upstream HEAD.
196- LOWSPEEDLIMIT and hdrs
197
198* Fri Feb 19 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.9.1-5
199- add patch to allow reset_curl_obj() to close and reload the cached curl obj
200
201* Thu Nov 12 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.9.1-4
202- reset header values when we redirect and make sure debug output will work
203
204* Wed Nov 11 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.9.1-3
205- fixing a bunch of redirect and max size bugs
206
207* Fri Sep 25 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.9.1-2
208- stupid patch
209
210* Fri Sep 25 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.9.1-1
211- 3.9.1
212
213* Tue Aug 18 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.9.0-8
214- ssl options, http POST string type fixes
215
216* Mon Aug 10 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.9.0-6
217- reget fixes, tmpfiles no longer made for urlopen() calls.
218
219* Wed Aug  5 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.9.0-5
220- apply complete patch to head fixes: timeouts, regets, improves exception raising
221
222* Tue Aug  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.9.0-4
223- timeout patch for https://bugzilla.redhat.com/show_bug.cgi?id=515497
224
225
226* Thu Jul 30 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.9.0-1
227- new version - curl-based
228
229* Wed Apr  8 2009 James Antill <james@fedoraproject.org> 3.0.0-15
230- Fix progress bars for serial consoles.
231- Make C-c behaviour a little nicer.
232
233* Fri Mar 13 2009 Seth Vidal <skvidal at fedoraproject.org>
234- kill deprecation warning from importing md5 if anyone uses keepalive
235
236* Mon Mar  9 2009 Seth Vidal <skvidal at fedoraproject.org>
237- apply patch for urlgrabber to properly check file:// urls with the checkfunc
238
239* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.0-12
240- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
241
242* Fri Nov 28 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> 3.0.0-11
243- Rebuild for Python 2.6
244
245* Wed Oct 14 2008 James Antill <james@fedoraproject.org> 3.0.0-10
246- Have the progress bar have a small bar, for a virtual size doubling.
247
248* Thu Jul 10 2008 James Antill <james@fedoraproject.org> 3.0.0-9
249- Make urlgrabber usable if openssl is broken
250- Relates: bug#454179
251
252* Sun Jun 15 2008 James Antill <james@fedoraproject.org> 3.0.0-9
253- Don't count partial downloads toward the total
254
255* Sat May 18 2008 James Antill <james@fedoraproject.org> 3.0.0-8
256- Tweak progress output so it's hopefully less confusing
257- Add dynamic resizing ability to progress bar
258- Resolves: bug#437197
259
260* Fri May  2 2008 James Antill <james@fedoraproject.org> 3.0.0-7
261- Fix reget's against servers that don't allow Range requests, also tweaks
262- reget == check_timestamp, if anyone/thing uses that.
263- Resolves: bug#435156
264- Fix minor typo in progress for single instance.
265
266* Mon Apr  7 2008 James Antill <james@fedoraproject.org> 3.0.0-6
267- Fix the ftp byterange port problem:
268- Resolves: bug#419241
269- Fixup the progress UI:
270-   add function for total progress
271-   add total progress percentagee current download line
272-   add rate to current download line
273-   use dead space when finished downloading
274-   don't confuse download rate on regets.
275
276* Sat Mar 15 2008 Robert Scheck <robert@fedoraproject.org> 3.0.0-5
277- Make sure, that *.egg-info is catched up during build
278
279* Mon Dec  3 2007 Jeremy Katz <katzj@redhat.com> - 3.0.0-4
280- Ensure fds are closed on exceptions (markmc, #404211)
281
282* Wed Oct 10 2007 Jeremy Katz <katzj@redhat.com> - 3.0.0-3
283- fix type checking of strings to also include unicode strings; fixes
284  regets from yum (#235618)
285
286* Mon Aug 27 2007 Jeremy Katz <katzj@redhat.com> - 3.0.0-2
287- fixes for package review (#226347)
288
289* Thu May 31 2007 Jeremy Katz <katzj@redhat.com> - 3.0.0-1
290- update to 3.0.0
291
292* Wed Dec  6 2006 Jeremy Katz <katzj@redhat.com> - 2.9.9-5
293- rebuild for python 2.5
294
295* Wed Dec  6 2006 Jeremy Katz <katzj@redhat.com> - 2.9.9-4
296- fix keepalive (#218268)
297
298* Sat Nov 11 2006 Florian La Roche <laroche@redhat.com>
299- add version/release to "Provides: urlgrabber"
300
301* Mon Jul 17 2006 James Bowes <jbowes@redhat.com> - 2.9.9-2
302- Add support for byte ranges and keepalive over HTTPS
303
304* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.9.9-1.1
305- rebuild
306
307* Tue May 16 2006 Jeremy Katz <katzj@redhat.com> - 2.9.9-1
308- update to 2.9.9
309
310* Tue Mar 14 2006 Jeremy Katz <katzj@redhat.com> - 2.9.8-2
311- catch read errors so they trigger the failure callback.  helps catch bad cds
312
313* Wed Feb 22 2006 Jeremy Katz <katzj@redhat.com> - 2.9.8-1
314- update to new version fixing progress bars in yum on regets
315
316* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
317- rebuilt
318
319* Wed Sep 21 2005 Jeremy Katz <katzj@redhat.com> - 2.9.6-4
320- don't use --record and list files by hand so that we don't miss
321  directories (#158480)
322
323* Wed Sep 14 2005 Jeremy Katz <katzj@redhat.com> - 2.9.6-3
324- add directory to file list (#168261)
325
326* Fri Jun 03 2005 Phil Knirsch <pknirsch@redhat.com> 2.9.6-2
327- Fixed the reget method to actually work correctly (skip completely transfered
328  files, etc)
329
330* Tue Mar  8 2005 Jeremy Katz <katzj@redhat.com> - 2.9.6-1
331- update to 2.9.6
332
333* Mon Mar  7 2005 Jeremy Katz <katzj@redhat.com> - 2.9.5-1
334- import into dist
335- make the description less of a book
336
337* Mon Mar  7 2005 Seth Vidal <skvidal@phy.duke.edu> 2.9.5-0
338- 2.9.5
339
340* Thu Feb 24 2005 Seth Vidal <skvidal@phy.duke.edu> 2.9.3-0
341- first package for fc3
342- named python-urlgrabber for naming guideline compliance
343
Note: See TracBrowser for help on using the repository browser.