source: projects/specs/trunk/p/python-unipath/python-unipath-vl.spec @ 5701

Revision 5701, 3.0 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3%global oname   Unipath
4
5Summary:        Alternative to Python modules os, os.path and shutil
6Name:           python-unipath
7Version:        0.2.1
8Release:        3%{?_dist_release}
9License:        Python
10Group:          Development/Tools
11URL:            http://pypi.python.org/pypi/Unipath/
12Source0:        http://pypi.python.org/packages/source/U/Unipath/%{oname}-%{version}.tar.gz
13BuildArch:      noarch
14BuildRequires:  python-setuptools python-nose nkf
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16
17%description
18Unipath is a package for doing pathname calculations and filesystem
19access in an object-oriented manner, an alternative to functions in
20os.path, shutil and glob, and even some functions in os.* It's based
21on Jason Orendorff's path.py but does not adhere as strictly to the
22underlying functions' syntax, in order to provide more user
23convenience and higher-level functionality. For example:
24
25 o p.mkdir() succeeds silently if the directory already exists, and
26 o p.mkdir(True) creates intermediate directories a la os.makedirs.
27 o p.rmtree(parents=True) combines shutil.rmtree, os.path.isdir,
28   os.remove, and os.removedirs, to recursively remove whatever it is
29   if it exists.
30 o p.read_file("rb") returns the file's contents in binary mode.
31 o p.needs_update([other_path1, ...]) returns True if p doesn't exist
32   or has an older timestamp than any of the others.
33 o extra convenience functions in the unipath.tools module. dict2dir
34   creates a directory hierarchy described by a dict. dump_path displays
35   an ASCII tree of a directory hierarchy.
36
37%prep
38%setup -q -n %{oname}-%{version}
39for f in doc/reference/{test_,}path_nr.py ; do
40    nkf --unix --overwrite $f
41done
42for f in README.txt doc/reference/path_355.py ; do
43    iconv -f ISO-8859-1 -t UTF-8 -o $f.utf8 $f && \
44    touch -r $f $f.utf8 && \
45    %{__mv} $f.utf8 $f
46done
47
48# To avoid warning about script without execute bit set
49%{__sed} -i -e '1d' unipath/test.py
50
51%build
52%{__python} setup.py build
53
54%install
55%{__rm} -rf %{buildroot}
56%{__python} setup.py install -O1 --skip-build --root %{buildroot}
57
58%clean
59%{__rm} -rf %{buildroot}
60
61%check
62%{__cp} unipath/test.py .
63%{__python} test.py
64
65%files
66%defattr(-, root, root, -)
67%doc BUGS.txt CHANGES doc/reference/ PKG-INFO README.html README.txt
68%{python_sitelib}/unipath/
69%{python_sitelib}/%{oname}-%{version}-py*.*.egg-info
70
71%changelog
72* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.1-3
73- rebuild with python-2.7.2
74
75* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.2.1-2
76- rebuild with python-2.6.4
77
78* Thu Oct 22 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.2.1-1
79- initial build for Vine Linux based on fedora development
80
81* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.1-3
82- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
83
84* Tue Apr 14 2009 Terje Rosten <terje.rosten@ntnu.no> - 0.2.1-2
85- Minor changes taken from review
86
87* Sun Mar 29 2009 Terje Rosten <terje.rosten@ntnu.no> - 0.2.1-1
88- initial build
Note: See TracBrowser for help on using the repository browser.