source: projects/specs/trunk/p/python-twitter/python-twitter-vl.spec @ 5701

Revision 5701, 2.5 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:                   python-twitter
4Summary:                A python wrapper around the Twitter API
5Summary(ja):            Twitter API の python ラッパー
6Version:                0.6
7Release:                2%{?_dist_release}
8License:                ASL 2.0
9Group:                  System Environment/Libraries
10Source0:                http://python-twitter.googlecode.com/files/%{name}-%{version}.tar.gz
11URL:                    http://code.google.com/p/python-twitter/
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
13BuildArch:              noarch
14BuildRequires:          python-devel, python-setuptools, python-simplejson
15Requires:               python-simplejson
16
17%description
18This library provides a pure python interface for the Twitter API. Twitter
19(http://twitter.com) provides a service that allows people to connect via the
20web, IM, and SMS. Twitter exposes a web services API
21(http://twitter.com/help/api) and this library is intended to make it even
22easier for python programmers to use.
23
24%prep
25%setup -q
26# Scrape out python versioning
27for i in examples/twitter-to-xhtml.py examples/tweet.py setup.py twitter.py twitter_test.py; do
28        sed -i 's|python2.4|python|g' $i
29done
30
31
32%build
33%{__python} setup.py build
34
35%install
36rm -rf $RPM_BUILD_ROOT
37%{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
38chmod +x $RPM_BUILD_ROOT%{python_sitelib}/twitter.py
39
40%check
41export PYTHONPATH=$RPM_BUILD_ROOT/%{python_sitelib}
42%{__python} setup.py test
43
44%clean
45rm -rf $RPM_BUILD_ROOT
46
47%files
48%defattr(-,root,root,-)
49%doc README PKG-INFO
50%{python_sitelib}/twitter.*
51%{python_sitelib}/python_twitter-%{version}-py*.egg-info
52
53%changelog
54* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6-2
55- rebuild with python-2.7.2
56
57* Wed Apr 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6-1
58- initial build for Vine Linux
59
60* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-3
61- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
62
63* Mon Jul  6 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 0.6-2
64- fix files so they do not have hardcoded !#/usr/bin/python2.4
65
66* Thu Jul  2 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 0.6-1
67- update to 0.6
68
69* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5-3
70- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
71
72* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.5-2
73- Rebuild for Python 2.6
74
75* Mon Oct 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.5-1
76- Initial package for Fedora
Note: See TracBrowser for help on using the repository browser.