source: projects/specs/trunk/p/python-twisted/python-twisted-vl.spec @ 7027

Revision 7027, 3.2 KB checked in by Takemikaduchi, 12 years ago (diff)

python-bsddb3: new package
task-gnome: add package
others: new upstream release

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2%define pyver           %(python -c 'import sys;print(sys.version[0:3])')
3Summary:        Event-driven networking engine in Python
4Summary(ja):    Pythonで書かれたイベントドリブンなネットワークエンジン
5Name:           python-twisted 
6Version:        12.2.0
7Release:        1%{?_dist_release}
8Source0:        http://pypi.python.org/packages/source/T/Twisted/Twisted-%{version}.tar.bz2
9License:        MIT
10Group:          Development/Languages
11URL:            http://twistedmatrix.com/trac/
12
13Requires:       python
14Requires:       python-zope-interface
15Requires:       pyOpenSSL
16BuildRequires:  python, python-devel
17BuildRequires:  python-zope-interface
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19
20
21%description
22Twisted is a networking engine written in Python, supporting
23numerous protocols. It contains a web server, numerous chat
24clients, chat servers, mail servers, and more.
25
26Twisted is a platform for developing internet applications.
27
28%description -l ja
29Twisted は Python で書かれた、多くのプロトコルをサポートする
30ネットワーク・エンジンです。このパッケージにはウェブサーバや
31多種多様なチャット用クライアント、チャットサーバ、メールサーバ
32等が含まれています。
33
34Twisted はウェブアプリケーション開発用のプラットフォームです。
35
36
37%package docs
38Summary:        Documentation for Twisted
39Summary(ja):    Twisted のドキュメント
40Group:          Applications/Documentation
41# workaround to prevent find-requires error
42AutoReq: No
43
44%description docs
45This package contains various documents and examples for
46Twisted.
47
48%description docs -l ja
49このパッケージには Twisted の各種ドキュメントやサンプルが
50含まれています。
51
52
53%prep
54
55%setup -q -n Twisted-%{version}
56
57
58%build
59%{__python} setup.py build
60# create plugins cache
61python -c "from twisted.plugin import IPlugin, getPlugins;list(getPlugins(IPlugin))" >/dev/null 2>&1
62
63%install
64%{__rm} -rf ${RPM_BUILD_ROOT}
65%{__python} setup.py install --root ${RPM_BUILD_ROOT}
66
67# install man pages
68%{__install} -d -m 755  "$RPM_BUILD_ROOT"/%{_mandir}/man1/
69%{__install} -m 644 doc/core/man/*.1 ${RPM_BUILD_ROOT}/%{_mandir}/man1/
70
71
72%clean
73%{__rm} -rf ${RPM_BUILD_ROOT}
74
75
76%files
77%defattr(-,root,root)
78%doc INSTALL LICENSE NEWS README
79#%{_bindir}/bookify
80%{_bindir}/cftp
81%{_bindir}/ckeygen
82%{_bindir}/conch
83#%{_bindir}/im
84%{_bindir}/lore
85%{_bindir}/mailmail
86%{_bindir}/manhole
87%{_bindir}/pyhtmlizer
88#%{_bindir}/t-im
89%{_bindir}/tap2deb
90%{_bindir}/tap2rpm
91%{_bindir}/tapconvert
92%{_bindir}/tkconch
93%{_bindir}/trial
94%{_bindir}/twistd
95%{python_sitearch}/twisted
96%{python_sitearch}/Twisted-%{version}-py%{pyver}.egg-info
97%{_mandir}/man1/*
98
99%files docs
100%defattr(-,root,root)
101%doc doc/*
102
103
104%changelog
105* Sat Oct 27 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.2.0-1
106- new upstream release
107
108* Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.2.0-2
109- rebuild with python-2.7.2
110
111* Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 10.2.0-1
112- updated twisted to 10.2.0
113
114* Thu Feb 04 2010 Shu KONNO <owa@bg.wakwak.com> 8.1.0-2
115- rebuilt with python-2.6.4-3
116
117* Tue Dec 23 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 8.1.0-1
118- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.