source: projects/specs/trunk/p/python-twisted/python-twisted-vl.spec @ 521

Revision 521, 3.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2%define pyver           %(python -c 'import sys;print(sys.version[0:3])')
3
4%define pkg_release     2%{?_dist_release}
5
6Summary:        Event-driven networking engine in Python
7Summary(ja):    Pythonで書かれたイベントドリブンなネットワークエンジン
8Name:           python-twisted 
9Version:        8.1.0
10Release:        %{pkg_release}
11Source0:        http://tmrc.mit.edu/mirror/twisted/Twisted/8.1/Twisted-%{version}.tar.bz2
12License:        MIT
13Group:          Development/Languages
14URL:            http://twistedmatrix.com/trac/
15
16Requires:       python
17Requires:       python-zope-interface
18Requires:       pyOpenSSL
19BuildRequires:  python, python-devel
20BuildRequires:  python-zope-interface
21BuildRoot:      %{_tmppath}/%{name}-%{version}-root
22
23
24%description
25Twisted is a networking engine written in Python, supporting
26numerous protocols. It contains a web server, numerous chat
27clients, chat servers, mail servers, and more.
28
29Twisted is a platform for developing internet applications.
30
31%description -l ja
32Twisted は Python で書かれた、多くのプロトコルをサポートする
33ネットワーク・エンジンです。このパッケージにはウェブサーバや
34多種多様なチャット用クライアント、チャットサーバ、メールサーバ
35等が含まれています。
36
37Twisted はウェブアプリケーション開発用のプラットフォームです。
38
39
40%package docs
41Summary:        Documentation for Twisted
42Summary(ja):    Twisted のドキュメント
43Group:          Applications/Documentation
44# workaround to prevent find-requires error
45AutoReq: No
46
47%description docs
48This package contains various documents and examples for
49Twisted.
50
51%description docs -l ja
52このパッケージには Twisted の各種ドキュメントやサンプルが
53含まれています。
54
55
56%prep
57
58%setup -q -n Twisted-%{version}
59
60
61%build
62%{__python} setup.py build
63# create plugins cache
64python -c "from twisted.plugin import IPlugin, getPlugins;list(getPlugins(IPlugin))" >/dev/null 2>&1
65
66%install
67%{__rm} -rf ${RPM_BUILD_ROOT}
68%{__python} setup.py install --root ${RPM_BUILD_ROOT}
69
70# install man pages
71%{__install} -d -m 755  "$RPM_BUILD_ROOT"/%{_mandir}/man1/
72%{__install} -m 644 doc/core/man/*.1 ${RPM_BUILD_ROOT}/%{_mandir}/man1/
73
74
75%clean
76%{__rm} -rf ${RPM_BUILD_ROOT}
77
78
79%files
80%defattr(-,root,root)
81%doc INSTALL LICENSE NEWS README
82%{_bindir}/bookify
83%{_bindir}/cftp
84%{_bindir}/ckeygen
85%{_bindir}/conch
86%{_bindir}/im
87%{_bindir}/lore
88%{_bindir}/mailmail
89%{_bindir}/manhole
90%{_bindir}/mktap
91%{_bindir}/pyhtmlizer
92%{_bindir}/t-im
93%{_bindir}/tap2deb
94%{_bindir}/tap2rpm
95%{_bindir}/tapconvert
96%{_bindir}/tkconch
97%{_bindir}/trial
98%{_bindir}/twistd
99%{python_sitearch}/twisted
100%{python_sitearch}/Twisted-%{version}-py%{pyver}.egg-info
101%{_mandir}/man1/*
102
103%files docs
104%defattr(-,root,root)
105%doc doc/*
106
107
108%changelog
109* Thu Feb 04 2010 Shu KONNO <owa@bg.wakwak.com> 8.1.0-2
110- rebuilt with python-2.6.4-3
111
112* Tue Dec 23 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 8.1.0-1
113- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.