source: projects/specs/trunk/p/python-twisted/python-twisted-vl.spec @ 8158

Revision 8158, 3.3 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2%define pyver           %(python -c 'import sys;print(sys.version[0:3])')
3Summary:        Event-driven networking engine in Python
4Summary(ja):    Pythonで書かれたイベントドリブンなネットワークエンジン
5Name:           python-twisted 
6Version:        13.2.0
7Release:        1%{?_dist_release}
8Source0:        http://pypi.python.org/packages/source/T/Twisted/Twisted-%{version}.tar.bz2
9License:        MIT
10Group:          Development/Languages
11URL:            http://twistedmatrix.com/trac/
12
13Requires:       python
14Requires:       python-zope-interface
15Requires:       pyOpenSSL
16BuildRequires:  python, python-devel
17BuildRequires:  python-zope-interface
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19
20Vendor: Project Vine
21Distribution: Vine Linux
22
23%description
24Twisted is a networking engine written in Python, supporting
25numerous protocols. It contains a web server, numerous chat
26clients, chat servers, mail servers, and more.
27
28Twisted is a platform for developing internet applications.
29
30%description -l ja
31Twisted は Python で書かれた、多くのプロトコルをサポートする
32ネットワーク・エンジンです。このパッケージにはウェブサーバや
33多種多様なチャット用クライアント、チャットサーバ、メールサーバ
34等が含まれています。
35
36Twisted はウェブアプリケーション開発用のプラットフォームです。
37
38
39%package docs
40Summary:        Documentation for Twisted
41Summary(ja):    Twisted のドキュメント
42Group:          Applications/Documentation
43# workaround to prevent find-requires error
44AutoReq: No
45
46%description docs
47This package contains various documents and examples for
48Twisted.
49
50%description docs -l ja
51このパッケージには Twisted の各種ドキュメントやサンプルが
52含まれています。
53
54
55%prep
56
57%setup -q -n Twisted-%{version}
58
59
60%build
61%{__python} setup.py build
62# create plugins cache
63python -c "from twisted.plugin import IPlugin, getPlugins;list(getPlugins(IPlugin))" >/dev/null 2>&1
64
65%install
66%{__rm} -rf ${RPM_BUILD_ROOT}
67%{__python} setup.py install --root ${RPM_BUILD_ROOT}
68
69# install man pages
70%{__install} -d -m 755  "$RPM_BUILD_ROOT"/%{_mandir}/man1/
71%{__install} -m 644 doc/core/man/*.1 ${RPM_BUILD_ROOT}/%{_mandir}/man1/
72
73
74%clean
75%{__rm} -rf ${RPM_BUILD_ROOT}
76
77
78%files
79%defattr(-,root,root)
80%doc INSTALL LICENSE NEWS README
81#%{_bindir}/bookify
82%{_bindir}/cftp
83%{_bindir}/ckeygen
84%{_bindir}/conch
85#%{_bindir}/im
86%{_bindir}/lore
87%{_bindir}/mailmail
88%{_bindir}/manhole
89%{_bindir}/pyhtmlizer
90#%{_bindir}/t-im
91%{_bindir}/tap2deb
92%{_bindir}/tap2rpm
93%{_bindir}/tapconvert
94%{_bindir}/tkconch
95%{_bindir}/trial
96%{_bindir}/twistd
97%{python_sitearch}/twisted
98%{python_sitearch}/Twisted-%{version}-py%{pyver}.egg-info
99%{_mandir}/man1/*
100
101%files docs
102%defattr(-,root,root)
103%doc doc/*
104
105
106%changelog
107* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 13.2.0-1
108- new upstream release
109
110* Sat Oct 27 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.2.0-1
111- new upstream release
112
113* Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.2.0-2
114- rebuild with python-2.7.2
115
116* Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 10.2.0-1
117- updated twisted to 10.2.0
118
119* Thu Feb 04 2010 Shu KONNO <owa@bg.wakwak.com> 8.1.0-2
120- rebuilt with python-2.6.4-3
121
122* Tue Dec 23 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 8.1.0-1
123- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.