source: projects/specs/trunk/p/python-tornado/python-tornado-vl.spec @ 521

Revision 521, 2.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1#%define python_sitelib %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(0)')
2#%define python_platlib %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)')
3%define tornado tornado
4Summary: Tornado is a web server and tools
5Summary(ja): Tornado 高速 Web フレームワーク
6Name: python-%{tornado}
7Group: Development/Web Applications
8Version: 0.2
9Release: 2%{?_dist_release}
10License: Apache Licence, Version 2.0
11URL: http://www.tornadoweb.org/
12Source0: %{url}/static/%{tornado}-%{version}.tar.gz
13Requires: python >= 2.5
14Requires: python-pycurl python-simplejson
15BuildRequires: python-devel
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17
18Packager: <owa>
19Vendor: Project Vine
20Distribution: Vine Linux
21
22%description
23Tornado is an open source version of the scalable, non-blocking web server
24and and tools that power FriendFeed. Documentation and downloads are
25available at http://www.tornadoweb.org/
26
27Tornado is licensed under the Apache Licence, Version 2.0
28(http://www.apache.org/licenses/LICENSE-2.0.html).
29
30%prep
31%setup -q -n %{tornado}-%{version}
32
33%build
34python setup.py build
35
36%install
37rm -rf $RPM_BUILD_ROOT
38python setup.py install --prefix=$RPM_BUILD_ROOT/usr
39
40mkdir -p $RPM_BUILD_ROOT/%{_datadir}/%{tornado}-%{version}
41cp -a demos $RPM_BUILD_ROOT/%{_datadir}/%{tornado}-%{version}/
42chmod 644 $RPM_BUILD_ROOT/%{_datadir}/%{tornado}-%{version}/demos/django/testdjango/testapp/tests.py
43
44%clean
45rm -rf $RPM_BUILD_ROOT
46
47%files
48%defattr(-, root, root)
49%doc PKG-INFO README
50#%{python_sitearch}
51%{_datadir}/%{tornado}-%{version}/demos/appengine
52%{_datadir}/%{tornado}-%{version}/demos/auth
53%{_datadir}/%{tornado}-%{version}/demos/blog
54%{_datadir}/%{tornado}-%{version}/demos/chat
55%{_datadir}/%{tornado}-%{version}/demos/django
56%{_datadir}/%{tornado}-%{version}/demos/facebook
57%{_datadir}/%{tornado}-%{version}/demos/helloworld
58%{_datadir}/%{tornado}-%{version}/demos/wsgi
59
60%changelog
61* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.2-2
62- rebuild with python-2.6
63
64* Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.2-1
65- initial build for VineSeed
66
Note: See TracBrowser for help on using the repository browser.