source: projects/specs/trunk/p/python-sphinxcontrib-websupport/python-sphinxcontrib-websupport-vl.spec @ 11940

Revision 11940, 3.7 KB checked in by tomop, 5 years ago (diff)

python-sphinx-1.7.9-1 and requirements

Line 
1%global with_python3 1
2
3%global pypi_name sphinxcontrib-websupport
4
5Name:           python-%{pypi_name}
6Version:        1.1.0
7Release:        1%{?_dist_release}
8Summary:        Sphinx API for Web Apps
9
10License:        BSD
11URL:            http://sphinx-doc.org/
12
13Vendor:         Project Vine
14Distribution:   Vine Linux
15
16Source0:        https://files.pythonhosted.org/packages/source/s/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
17BuildArch:      noarch
18
19%{?python_provide:%python_provide python2-%{pypi_name}}
20BuildRequires:  python-rpm-macros
21BuildRequires:  python-devel
22BuildRequires:  python-setuptools
23BuildRequires:  python-sphinx
24BuildRequires:  python-sqlalchemy
25BuildRequires:  python-whoosh
26Requires:       python-sphinx
27Requires:       python-sqlalchemy
28Requires:       python-whoosh
29
30%description
31sphinxcontrib-websupport provides a Python API to easily integrate Sphinx
32documentation into your Web application.
33
34
35%if 0%{?with_python3}
36%package -n     python3-%{pypi_name}
37Summary:        %{summary}
38%{?python_provide:%python_provide python3-%{pypi_name}}
39BuildRequires:  python3-rpm-macros
40BuildRequires:  python3-devel
41BuildRequires:  python3-docutils
42BuildRequires:  python3-setuptools
43BuildRequires:  python3-jinja2
44BuildRequires:  python3-six
45BuildRequires:  python3-sphinx
46BuildRequires:  python3-sqlalchemy
47BuildRequires:  python3-whoosh
48Requires:       python3-sphinx
49Requires:       python3-sqlalchemy
50Requires:       python3-whoosh
51
52%description -n python3-%{pypi_name}
53sphinxcontrib-websupport provides a Python API to easily integrate Sphinx
54documentation into your Web application.
55%endif
56
57%prep
58%autosetup -n %{pypi_name}-%{version}
59# Remove bundled egg-info
60rm -rf %{pypi_name}.egg-info
61
62%build
63%if 0%{?with_python3}
64%py3_build
65%endif
66%py_build
67
68%install
69%if 0%{?with_python3}
70%py3_install
71%endif
72%py_install
73
74%files
75%license LICENSE
76%doc README.rst
77%{python_sitelib}/sphinxcontrib/websupport
78%{python_sitelib}/sphinxcontrib_websupport-*.pth
79%{python_sitelib}/sphinxcontrib_websupport-*.egg-info
80
81%if 0%{?with_python3}
82%files -n python3-%{pypi_name}
83%license LICENSE
84%doc README.rst
85%{python3_sitelib}/sphinxcontrib/websupport
86%{python3_sitelib}/sphinxcontrib_websupport-*.pth
87%{python3_sitelib}/sphinxcontrib_websupport-*.egg-info
88%endif
89
90%changelog
91* Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.1.0-1
92- new upstream release.
93- initial build for Vine Linux.
94
95* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-10.20180316git
96- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
97
98* Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-9.20180316git
99- Rebuilt for Python 3.7
100
101* Wed May 16 2018 Javier Peña <jpena@redhat.com> - 1.0.1-8.20180316git
102- Update to commit ebe84efc1a869da8d5689c706cdcf6ea864f0d9b
103- Fix build with Sphinx 1.7 (bz#1578132)
104
105* Wed Feb 28 2018 Iryna Shcherbina <ishcherb@redhat.com> - 1.0.1-7.20171013git
106- Update Python 2 dependency declarations to new packaging standards
107  (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
108
109* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-6.20171013git
110- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
111
112* Mon Dec 18 2017 Javier Peña <jpena@redhat.com> - 1.0.1-5.20171013git
113- Fixed Source0 URL (bz#1526646)
114
115* Fri Oct 13 2017 Javier Peña <jpena@redhat.com> - 1.0.1-4.20171013git
116- Updated to latest git commit to fix build in Rawhide
117
118* Wed Oct 11 2017 Troy Dawson <tdawson@redhat.com> - 1.0.1-3
119- Cleanup spec file conditionals
120
121* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-2
122- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
123
124* Fri Jun 30 2017 Javier Peña <jpena@redhat.com> - 1.0.1-1
125- Initial package.
126
Note: See TracBrowser for help on using the repository browser.