source: projects/specs/trunk/p/python-sphinxcontrib-serializinghtml/python-sphinxcontrib-serializinghtml-vl.spec @ 12469

Revision 12469, 3.5 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1%global pypi_name sphinxcontrib-serializinghtml
2
3# when bootstrapping sphinx, we cannot run tests yet
4%bcond_with check
5
6Summary:        Sphinx extension for serialized HTML
7Name:           python-%{pypi_name}
8Version:        1.1.4
9Release:        3%{?_dist_release}
10Group:          programming
11Vendor:         Project Vine
12Distribution:   Vine Linux
13
14License:        BSD
15URL:            http://sphinx-doc.org/
16Source0:        %{pypi_source}
17BuildArch:      noarch
18
19BuildRequires:  gettext
20BuildRequires:  python3-rpm-macros
21BuildRequires:  python3-devel
22BuildRequires:  python3-setuptools
23
24%if %{with check}
25BuildRequires:  python3-pytest
26BuildRequires:  python3-sphinx >= 1:2
27%endif
28
29%description
30sphinxcontrib-serializinghtml is a sphinx extension which outputs "serialized"
31HTML files (json and pickle).
32
33
34%package -n     python3-%{pypi_name}
35Summary:        %{summary}
36Group:          programming
37%{?python_provide:%python_provide python3-%{pypi_name}}
38
39%description -n python3-%{pypi_name}
40sphinxcontrib-serializinghtml is a sphinx extension which outputs "serialized"
41HTML files (json and pickle).
42
43
44%prep
45%autosetup -n %{pypi_name}-%{version}
46find -name '*.mo' -delete
47
48
49%build
50for po in $(find -name '*.po'); do
51  msgfmt --output-file=${po%.po}.mo ${po}
52done
53%py3_build
54
55
56%install
57%py3_install
58
59# Move language files to /usr/share
60pushd %{buildroot}%{python3_sitelib}
61for lang in `find sphinxcontrib/serializinghtml/locales -maxdepth 1 -mindepth 1 -type d -not -path '*/\.*' -printf "%f "`;
62do
63  test $lang == __pycache__ && continue
64  install -d %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES
65  mv sphinxcontrib/serializinghtml/locales/$lang/LC_MESSAGES/*.mo %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/
66done
67rm -rf sphinxcontrib/serializinghtml/locales
68ln -s %{_datadir}/locale sphinxcontrib/serializinghtml/locales
69popd
70
71
72%find_lang sphinxcontrib.serializinghtml
73
74
75%if %{with check}
76%check
77%pytest
78%endif
79
80
81%files -n python3-%{pypi_name} -f sphinxcontrib.serializinghtml.lang
82%license LICENSE
83%doc README.rst
84%{python3_sitelib}/sphinxcontrib/
85%{python3_sitelib}/sphinxcontrib_serializinghtml-%{version}-py%{python3_version}-*.pth
86%{python3_sitelib}/sphinxcontrib_serializinghtml-%{version}-py%{python3_version}.egg-info/
87
88
89%changelog
90* Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.1.4-3
91- initial build for Vine Linux.
92
93* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.4-2
94- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
95
96* Mon Jun 01 2020 Charalampos Stratakis <cstratak@redhat.com> - 1.1.4-1
97- Update to 1.1.4 (#1808637)
98
99* Sat May 23 2020 Miro Hrončok <mhroncok@redhat.com> - 1.1.3-8
100- Rebuilt for Python 3.9
101
102* Fri May 22 2020 Miro Hrončok <mhroncok@redhat.com> - 1.1.3-7
103- Bootstrap for Python 3.9
104
105* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-6
106- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
107
108* Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 1.1.3-5
109- Rebuilt for Python 3.8.0rc1 (#1748018)
110
111* Fri Aug 16 2019 Miro Hrončok <mhroncok@redhat.com> - 1.1.3-4
112- Rebuilt for Python 3.8
113
114* Thu Aug 15 2019 Miro Hrončok <mhroncok@redhat.com> - 1.1.3-3
115- Bootstrap for Python 3.8
116
117* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-2
118- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
119
120* Mon May 20 2019 Miro Hrončok <mhroncok@redhat.com> - 1.1.3-1
121- Update to 1.1.3 (#1697444)
122
123* Mon Mar 04 2019 Miro Hrončok <mhroncok@redhat.com> - 1.1.1-1
124- Initial package.
Note: See TracBrowser for help on using the repository browser.