source: projects/specs/trunk/p/python-sphinxcontrib-htmlhelp/python-sphinxcontrib-htmlhelp-vl.spec @ 12469

Revision 12469, 3.3 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1%global pypi_name sphinxcontrib-htmlhelp
2
3# when bootstrapping sphinx, we cannot run tests yet
4%bcond_with check
5
6Summary:        Sphinx extension for HTML help files
7Name:           python-%{pypi_name}
8Version:        1.0.3
9Release:        3%{?_dist_release}
10Group:          programming
11Vendor:         Project Vine
12Distribution:   Vine Linux
13
14License:        BSD
15URL:            http://sphinx-doc.org/
16Source0:        %{pypi_source}
17
18BuildArch:      noarch
19BuildRequires:  gettext
20BuildRequires:  python3-devel
21BuildRequires:  python3-setuptools
22
23%if %{with check}
24BuildRequires:  python3-pytest
25BuildRequires:  python3-sphinx >= 1:2
26BuildRequires:  python3-html5lib
27%endif
28
29%description
30sphinxcontrib-htmlhelp is a sphinx extension which renders HTML help files.
31
32
33%package -n     python3-%{pypi_name}
34Summary:        %{summary}
35Group:          programming
36%{?python_provide:%python_provide python3-%{pypi_name}}
37
38%description -n python3-%{pypi_name}
39sphinxcontrib-htmlhelp is a sphinx extension which renders HTML help files.
40
41
42%prep
43%autosetup -n %{pypi_name}-%{version}
44find -name '*.mo' -delete
45
46
47%build
48for po in $(find -name '*.po'); do
49  msgfmt --output-file=${po%.po}.mo ${po}
50done
51%py3_build
52
53
54%install
55%py3_install
56
57# Move language files to /usr/share
58pushd %{buildroot}%{python3_sitelib}
59for lang in `find sphinxcontrib/htmlhelp/locales -maxdepth 1 -mindepth 1 -type d -not -path '*/\.*' -printf "%f "`;
60do
61  test $lang == __pycache__ && continue
62  install -d %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES
63  mv sphinxcontrib/htmlhelp/locales/$lang/LC_MESSAGES/*.mo %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/
64done
65rm -rf sphinxcontrib/htmlhelp/locales
66ln -s %{_datadir}/locale sphinxcontrib/htmlhelp/locales
67popd
68
69
70%find_lang sphinxcontrib.htmlhelp
71
72
73%if %{with check}
74%check
75%{__python3} -m pytest
76%endif
77
78
79%files -n python3-%{pypi_name} -f sphinxcontrib.htmlhelp.lang
80%license LICENSE
81%doc README.rst
82%{python3_sitelib}/sphinxcontrib/
83%{python3_sitelib}/sphinxcontrib_htmlhelp-%{version}-py%{python3_version}-*.pth
84%{python3_sitelib}/sphinxcontrib_htmlhelp-%{version}-py%{python3_version}.egg-info/
85
86
87%changelog
88* Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.0.3-3
89- initial build for Vine Linux.
90
91* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.3-2
92- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
93
94* Thu Jun 04 2020 Charalampos Stratakis <cstratak@redhat.com> - 1.0.3-1
95- Update to 1.0.3 (#1699073)
96
97* Sat May 23 2020 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-8
98- Rebuilt for Python 3.9
99
100* Fri May 22 2020 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-7
101- Bootstrap for Python 3.9
102
103* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-6
104- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
105
106* Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-5
107- Rebuilt for Python 3.8.0rc1 (#1748018)
108
109* Fri Aug 16 2019 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-4
110- Rebuilt for Python 3.8
111
112* Thu Aug 15 2019 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-3
113- Bootstrap for Python 3.8
114
115* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-2
116- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
117
118* Fri Mar 01 2019 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-1
119- Initial package
Note: See TracBrowser for help on using the repository browser.