source: projects/specs/trunk/p/python-sphinxcontrib-devhelp/python-sphinxcontrib-devhelp-vl.spec @ 12469

Revision 12469, 3.2 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1%global pypi_name sphinxcontrib-devhelp
2
3# when bootstrapping sphinx, we cannot run tests yet
4%bcond_with check
5
6Summary:        Sphinx extension for Devhelp documents
7Name:           python-%{pypi_name}
8Version:        1.0.2
9Release:        3%{?_dist_release}
10Group:          programming
11Vendor:         Project Vine
12Distribution:   Vine Linux
13
14License:        BSD
15URL:            http://sphinx-doc.org/
16Source0:        %{pypi_source}
17
18BuildArch:      noarch
19BuildRequires:  gettext
20BuildRequires:  python3-devel
21BuildRequires:  python3-setuptools
22
23%if %{with check}
24BuildRequires:  python3-pytest
25BuildRequires:  python3-sphinx >= 1:2
26%endif
27
28%description
29sphinxcontrib-devhelp is a sphinx extension which outputs Devhelp document.
30
31
32%package -n     python3-%{pypi_name}
33Summary:        %{summary}
34Group:          programming
35%{?python_provide:%python_provide python3-%{pypi_name}}
36
37%description -n python3-%{pypi_name}
38sphinxcontrib-devhelp is a sphinx extension which outputs Devhelp document.
39
40
41%prep
42%autosetup -n %{pypi_name}-%{version}
43find -name '*.mo' -delete
44
45
46%build
47for po in $(find -name '*.po'); do
48  msgfmt --output-file=${po%.po}.mo ${po}
49done
50%py3_build
51
52
53%install
54%py3_install
55
56# Move language files to /usr/share
57pushd %{buildroot}%{python3_sitelib}
58for lang in `find sphinxcontrib/devhelp/locales -maxdepth 1 -mindepth 1 -type d -not -path '*/\.*' -printf "%f "`;
59do
60  test $lang == __pycache__ && continue
61  install -d %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES
62  mv sphinxcontrib/devhelp/locales/$lang/LC_MESSAGES/*.mo %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/
63done
64rm -rf sphinxcontrib/devhelp/locales
65ln -s %{_datadir}/locale sphinxcontrib/devhelp/locales
66popd
67
68
69%find_lang sphinxcontrib.devhelp
70
71
72%if %{with check}
73%check
74%pytest
75%endif
76
77
78%files -n python3-%{pypi_name} -f sphinxcontrib.devhelp.lang
79%license LICENSE
80%doc README.rst
81%{python3_sitelib}/sphinxcontrib/
82%{python3_sitelib}/sphinxcontrib_devhelp-%{version}-py%{python3_version}-*.pth
83%{python3_sitelib}/sphinxcontrib_devhelp-%{version}-py%{python3_version}.egg-info/
84
85
86%changelog
87* Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.0.2-3
88- initial build for Vine Linux.
89
90* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.2-2
91- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
92
93* Mon Jun 01 2020 Charalampos Stratakis <cstratak@redhat.com> - 1.0.2-1
94- Update to 1.0.2 (#1808639)
95
96* Sat May 23 2020 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-8
97- Rebuilt for Python 3.9
98
99* Fri May 22 2020 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-7
100- Bootstrap for Python 3.9
101
102* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-6
103- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
104
105* Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-5
106- Rebuilt for Python 3.8.0rc1 (#1748018)
107
108* Fri Aug 16 2019 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-4
109- Rebuilt for Python 3.8
110
111* Thu Aug 15 2019 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-3
112- Bootstrap for Python 3.8
113
114* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-2
115- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
116
117* Fri Mar 01 2019 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-1
118- Initial package
Note: See TracBrowser for help on using the repository browser.