source: projects/specs/trunk/p/python-sphinx-theme-alabaster/python-sphinx-theme-alabaster-vl.spec @ 11940

Revision 11940, 4.5 KB checked in by tomop, 5 years ago (diff)

python-sphinx-1.7.9-1 and requirements

Line 
1%global pypi_name alabaster
2%global srcname sphinx-theme-%{pypi_name}
3
4Name:           python-%{srcname}
5Version:        0.7.12
6Release:        3%{?_dist_release}
7Summary:        Configurable sidebar-enabled Sphinx theme
8
9License:        BSD
10URL:            https://pypi.python.org/pypi/%{pypi_name}
11
12Vendor:         Project Vine
13Distribution:   Vine Linux
14
15Source0:        https://files.pythonhosted.org/packages/cc/b4/ed8dcb0d67d5cfb7f83c4d5463a7614cb1d078ad7ae890c9143edebbf072/alabaster-0.7.12.tar.gz
16
17BuildArch:      noarch
18BuildRequires:  python-devel
19BuildRequires:  python-setuptools
20BuildRequires:  python-rpm-macros
21
22%{?python_provide:%python_provide python2-%{srcname}}
23
24%description
25This theme is a modified "Kr" Sphinx theme from @kennethreitz (especially as
26used in his Requests project), which was itself originally based on @mitsuhiko's
27theme used for Flask & related projects.
28
29
30%package -n     python3-%{srcname}
31Summary:        Configurable sidebar-enabled Sphinx theme
32BuildArch:      noarch
33BuildRequires:  python3-devel
34BuildRequires:  python3-setuptools
35BuildRequires:  python3-rpm-macros
36%{?python_provide:%python_provide python3-%{srcname}}
37
38%description -n python3-%{srcname}
39This theme is a modified "Kr" Sphinx theme from @kennethreitz (especially as
40used in his Requests project), which was itself originally based on @mitsuhiko's
41theme used for Flask & related projects.
42
43
44%prep
45%setup -qn %{pypi_name}-%{version}
46
47# Remove bundled eggs
48rm -rf %{pypi_name}.egg-info
49
50
51%build
52%py_build
53%py3_build
54
55
56%install
57%py_install
58%py3_install
59
60
61%files
62%license LICENSE
63%doc README.rst
64%{python_sitelib}/%{pypi_name}-%{version}-py%{python_version}.egg-info/
65%{python_sitelib}/%{pypi_name}/
66
67%files -n python%{python3_pkgversion}-%{srcname}
68%license LICENSE
69%doc README.rst
70%{python3_sitelib}/%{pypi_name}-%{version}-py%{python3_version}.egg-info/
71%{python3_sitelib}/%{pypi_name}/
72
73
74%changelog
75* Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.7.12-3
76- initial build for Vine Linux.
77
78* Sat Oct 06 2018 Julien Enselme <jujens@jujens.eu> - 0.7.12-2
79- Readd Python 2 subpackage
80
81* Thu Oct 04 2018 Julien Enselme <jujens@jujens.eu> - 0.7.12-1
82- Update to 0.7.12
83- Remove Python 2 subpackage
84
85* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.11-5
86- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
87
88* Mon Jul 02 2018 Miro Hrončok <mhroncok@redhat.com> - 0.7.11-4
89- Rebuilt for Python 3.7
90
91* Mon Jul 02 2018 Miro Hrončok <mhroncok@redhat.com> - 0.7.11-3
92- Rebuilt for Python 3.7
93
94* Sat Jun 30 2018 Julien Enselme <jujens@jujens.eu> - 0.7.11-2
95- Correct source URL
96
97* Sat Jun 30 2018 Julien Enselme <jujens@jujens.eu> - 0.7.11-1
98- Update to 0.7.11
99
100* Thu Jun 14 2018 Miro Hrončok <mhroncok@redhat.com> - 0.7.9-7
101- Rebuilt for Python 3.7
102
103* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.9-6
104- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
105
106* Tue Jan 30 2018 Iryna Shcherbina <ishcherb@redhat.com> - 0.7.9-5
107- Update Python 2 dependency declarations to new packaging standards
108  (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
109
110* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.9-4
111- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
112
113* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.9-3
114- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
115
116* Fri Dec 09 2016 Charalampos Stratakis <cstratak@redhat.com> - 0.7.9-2
117- Rebuild for Python 3.6
118
119* Sun Sep 18 2016 Julien Enselme <jujens@jujens.eu> - 0.7.9-1
120- Update to 0.7.9
121
122* Fri May 13 2016 Julien Enselme <jujens@jujens.eu> - 0.7.8-1
123- Use %%python3_pkgversion macro for EPEL7 release
124
125* Fri May 13 2016 Julien Enselme <jujens@jujens.eu> - 0.7.8-1
126- Update to 0.7.8 (#1334952)
127
128* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.6-6
129- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
130
131* Thu Nov 5 2015 Julien Enselme <jujens@jujens.eu> - 0.7.6-5
132- Rebuilt for python 3.5
133
134* Fri Jul 31 2015 Julien Enseme <jujens@jujens.eu> - 0.7.6-4
135- Use %%py2_build, %%py3build, %%py2_install and %%py2_install
136- Make a python2 subpackage
137
138* Thu Jul 30 2015 Julien Enselme <jujens@jujens.eu> - 0.7.6-3
139- Add provides for python2-sphinx-theme-alabaster
140- Remove usage of python2 and python3 dirs
141
142* Fri Jul 24 2015 Julien Enselme <jujens@jujens.eu> - 0.7.6-2
143- Remove %%py3dir macro
144- Add CFLAGS in %%build
145
146* Sat Jul 18 2015 Julien Enselme <jujens@jujens.eu> - 0.7.6-1
147- Initial packaging
Note: See TracBrowser for help on using the repository browser.