source: projects/specs/trunk/p/python-snowballstemmer/python-snowballstemmer-vl.spec @ 12469

Revision 12469, 3.6 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1%global pypi_name snowballstemmer
2
3Summary:        Provides 16 stemmer algorithms generated from Snowball algorithms
4Name:           python-%{pypi_name}
5Version:        2.0.0
6Release:        1%{?_dist_release}
7Group:          programming
8Vendor:         Project Vine
9Distribution:   Vine Linux
10
11License:        BSD
12URL:            https://pypi.python.org/pypi/%{pypi_name}
13Source0:       %{pypi_name}-%{version}.tar.gz
14
15BuildArch:      noarch
16BuildRequires:  python-rpm-macros
17
18BuildRequires:  python-devel
19BuildRequires:  python2-rpm-macros
20
21BuildRequires:  python3-devel
22BuildRequires:  python3-rpm-macros
23
24%{?python_provide:%python_provide python2-%{pypi_name}}
25
26%description
27It includes following language algorithms:
28
29* Danish
30* Dutch
31* English (Standard, Porter)
32* Finnish
33* French
34* German
35* Hungarian
36* Italian
37* Norwegian
38* Portuguese
39* Romanian
40* Russian
41* Spanish
42* Swedish
43* Turkis
44
45This is a pure Python stemming library. If PyStemmer is available, this module
46uses it to accelerate.
47
48
49%package -n     python3-%{pypi_name}
50Summary:        Provides 16 stemmer algorithms generated from Snowball algorithms
51Group:          programming
52BuildArch:      noarch
53%{?python_provide:%python_provide python3-%{pypi_name}}
54
55%description -n python3-%{pypi_name}
56It includes following language algorithms:
57
58* Danish
59* Dutch
60* English (Standard, Porter)
61* Finnish
62* French
63* German
64* Hungarian
65* Italian
66* Norwegian
67* Portuguese
68* Romanian
69* Russian
70* Spanish
71* Swedish
72* Turkis
73
74This is a pure Python stemming library. If PyStemmer is available, this module
75uses it to accelerate.
76
77
78%prep
79%setup -qn %{pypi_name}-%{version}
80# Remove upstream's egg-info
81rm -rf %{pypi_name}.egg-info
82
83
84%build
85%py2_build
86%py3_build
87
88
89%install
90%py2_install
91%py3_install
92
93
94%check
95# No tests
96
97
98%files
99%license COPYING
100%doc README.rst
101%{python_sitelib}/%{pypi_name}-%{version}-py%{python_version}.egg-info
102%{python_sitelib}/%{pypi_name}/
103
104%files -n python3-%{pypi_name}
105%license COPYING
106%doc README.rst
107%{python3_sitelib}/%{pypi_name}-%{version}-py%{python3_version}.egg-info
108%{python3_sitelib}/%{pypi_name}/
109
110
111%changelog
112* Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.0.0-1
113- new upstream release.
114
115* Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.2.1-8
116- initial build for Vine Linux.
117
118* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.1-7
119- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
120
121* Thu Jun 14 2018 Miro Hrončok <mhroncok@redhat.com> - 1.2.1-6
122- Rebuilt for Python 3.7
123
124* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.1-5
125- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
126
127* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.1-4
128- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
129
130* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.1-3
131- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
132
133* Fri Dec 09 2016 Charalampos Stratakis <cstratak@redhat.com> - 1.2.1-2
134- Rebuild for Python 3.6
135
136* Sun Sep 18 2016 Julien Enselme <jujens@jujens.eu> - 1.2.1-1
137- Update to 1.2.1
138
139* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-4
140- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
141
142* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-3
143- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
144
145* Thu Nov 5 2015 Julien Enselme <jujens@jujens.eu> - 1.2.0-2
146- Rebuilt for python 3.5
147
148* Mon Aug 24 2015 Julien Enselme <jujens@jujens.eu> - 1.2.0-1
149- Initial package
Note: See TracBrowser for help on using the repository browser.