source: projects/specs/trunk/p/python-snowballstemmer/python-snowballstemmer-vl.spec @ 11940

Revision 11940, 3.5 KB checked in by tomop, 5 years ago (diff)

python-sphinx-1.7.9-1 and requirements

Line 
1%global pypi_name snowballstemmer
2
3Name:           python-%{pypi_name}
4Version:        1.2.1
5Release:        8%{?_dist_release}
6Summary:        Provides 16 stemmer algorithms generated from Snowball algorithms
7
8License:        BSD
9URL:            https://pypi.python.org/pypi/%{pypi_name}
10
11Vendor:         Project Vine
12Distribution:   Vine Linux
13
14Source0:        https://pypi.python.org/packages/20/6b/d2a7cb176d4d664d94a6debf52cd8dbae1f7203c8e42426daa077051d59c/%{pypi_name}-%{version}.tar.gz
15
16BuildArch:      noarch
17BuildRequires:  python-devel
18BuildRequires:  python-rpm-macros
19BuildRequires:  python3-devel
20BuildRequires:  python3-rpm-macros
21
22%{?python_provide:%python_provide python2-%{pypi_name}}
23
24%description
25It includes following language algorithms:
26
27* Danish
28* Dutch
29* English (Standard, Porter)
30* Finnish
31* French
32* German
33* Hungarian
34* Italian
35* Norwegian
36* Portuguese
37* Romanian
38* Russian
39* Spanish
40* Swedish
41* Turkis
42
43This is a pure Python stemming library. If PyStemmer is available, this module
44uses it to accelerate.
45
46
47%package -n     python3-%{pypi_name}
48Summary:        Provides 16 stemmer algorithms generated from Snowball algorithms
49BuildArch:      noarch
50%{?python_provide:%python_provide python3-%{pypi_name}}
51
52%description -n python3-%{pypi_name}
53It includes following language algorithms:
54
55* Danish
56* Dutch
57* English (Standard, Porter)
58* Finnish
59* French
60* German
61* Hungarian
62* Italian
63* Norwegian
64* Portuguese
65* Romanian
66* Russian
67* Spanish
68* Swedish
69* Turkis
70
71This is a pure Python stemming library. If PyStemmer is available, this module
72uses it to accelerate.
73
74
75%prep
76%setup -qn %{pypi_name}-%{version}
77# Remove upstream's egg-info
78rm -rf %{pypi_name}.egg-info
79
80
81%build
82%py_build
83%py3_build
84
85
86%install
87%py_install
88%py3_install
89
90
91%check
92# No tests
93
94
95%files
96%license LICENSE.rst
97%doc README.rst
98%{python_sitelib}/%{pypi_name}-%{version}-py%{python_version}.egg-info
99%{python_sitelib}/%{pypi_name}/
100
101%files -n python3-%{pypi_name}
102%license LICENSE.rst
103%doc README.rst
104%{python3_sitelib}/%{pypi_name}-%{version}-py%{python3_version}.egg-info
105%{python3_sitelib}/%{pypi_name}/
106
107
108%changelog
109* Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.2.1-8
110- initial build for Vine Linux.
111
112* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.1-7
113- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
114
115* Thu Jun 14 2018 Miro Hrončok <mhroncok@redhat.com> - 1.2.1-6
116- Rebuilt for Python 3.7
117
118* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.1-5
119- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
120
121* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.1-4
122- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
123
124* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.1-3
125- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
126
127* Fri Dec 09 2016 Charalampos Stratakis <cstratak@redhat.com> - 1.2.1-2
128- Rebuild for Python 3.6
129
130* Sun Sep 18 2016 Julien Enselme <jujens@jujens.eu> - 1.2.1-1
131- Update to 1.2.1
132
133* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-4
134- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
135
136* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-3
137- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
138
139* Thu Nov 5 2015 Julien Enselme <jujens@jujens.eu> - 1.2.0-2
140- Rebuilt for python 3.5
141
142* Mon Aug 24 2015 Julien Enselme <jujens@jujens.eu> - 1.2.0-1
143- Initial package
Note: See TracBrowser for help on using the repository browser.