source: projects/specs/trunk/p/python-six/python-six-vl.spec @ 12469

Revision 12469, 3.4 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1%define pkgname six
2
3# Basic Information
4Name:           python-six
5Version:        1.15.0
6Release:        1%{?_dist_release}
7# /usr/share/doc/rpm-4.11.2/GROUPS_for_vine.txt を参照して Group を修正してください。
8Group:          programming
9Vendor:         Project Vine
10Distribution:   Vine Linux
11Packager:       yasumichi
12
13License:        MIT
14URL:            https://pypi.python.org/pypi/six/
15Source0:        https://pypi.python.org/packages/source/s/%{pkgname}/%{pkgname}-%{version}.tar.gz
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18Summary:        Python 2 and 3 compatibility utilities
19Summary(ja):    Python 2 および 3 の互換ユーテリティ
20
21BuildArch:      noarch
22# Dependency
23Requires:       python
24BuildRequires:  python-devel
25BuildRequires:  python-setuptools
26BuildRequires:  python-rpm-macros
27BuildRequires:  python2-rpm-macros
28BuildRequires:  python3-devel
29BuildRequires:  python3-setuptools
30BuildRequires:  python3-rpm-macros
31
32%description
33for smoothing over the differences between the Python versions with the goal of
34writing Python code that is compatible on both Python versions.  See the
35documentation for more information on what is provided.
36
37Six supports every Python version since 2.5.  It is contained in only one Python
38file, so it can be easily copied into your project. (The copyright and license
39notice must be retained.)
40
41Online documentation is at http://pythonhosted.org/six/.
42
43Bugs can be reported to http://bitbucket.org/gutworth/six.  The code can also be
44found there.
45
46For questions about six or porting in general, email the python-porting mailing
47list: http://mail.python.org/mailman/listinfo/python-porting
48
49%package -n     python3-six
50Summary:        Python 2 and 3 compatibility utilities
51Summary(ja):    Python 2 および 3 の互換ユーテリティ
52Group:          programming
53Requires:       python3
54
55%description -n python3-six
56for smoothing over the differences between the Python versions with the goal of
57writing Python code that is compatible on both Python versions.  See the
58documentation for more information on what is provided.
59
60Six supports every Python version since 2.5.  It is contained in only one Python
61file, so it can be easily copied into your project. (The copyright and license
62notice must be retained.)
63
64Online documentation is at http://pythonhosted.org/six/.
65
66Bugs can be reported to http://bitbucket.org/gutworth/six.  The code can also be
67found there.
68
69For questions about six or porting in general, email the python-porting mailing
70list: http://mail.python.org/mailman/listinfo/python-porting
71
72
73%prep
74%setup -q -n six-%{version}
75
76
77%build
78%py2_build
79%py3_build
80
81
82%install
83%{__rm} -rf ${RPM_BUILD_ROOT}
84%py2_install
85%py3_install
86
87
88%clean
89%{__rm} -rf ${RPM_BUILD_ROOT}
90
91
92%files
93%defattr(-,root,root)
94%license LICENSE
95%doc README*
96%{python_sitelib}/six-%{version}-py*.egg-info
97%{python_sitelib}/six.py*
98
99%files -n python3-six
100%defattr(-,root,root)
101%license LICENSE
102%doc README*
103%{python3_sitelib}/six-%{version}-py*.egg-info
104%{python3_sitelib}/six.py*
105%{python3_sitelib}/__pycache__/six.*
106
107
108%changelog
109* Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.15.0-1
110- new upstream release.
111
112* Sun Apr 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14.0-1
113- new upstream release.
114
115* Wed Jan 31 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.11.0-1
116- new upstream release.
117- added a subpackage for python3.
118
119* Sun Nov 15 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.0-1
120- new upstream release.
121
122* Sat Sep 20 2014 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.8.0-1
123- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.