source: projects/specs/trunk/p/python-simplejson/python-simplejson-vl.spec @ 521

Revision 521, 4.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?pyver: %define pyver %(%{__python} -c "import sys ; print sys.version[:3]")}
2%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4%define pkg_release     2%{?_dist_release}
5
6Name:           python-simplejson
7Version:        2.0.3
8Release:        %{pkg_release}
9Summary:        Simple, fast, extensible JSON encoder/decoder for Python
10Summary(ja):    Python 用のシンプルで速くて拡張可能な JSON エンコーダ/デコーダ
11
12Group:          System Environment/Libraries
13License:        MIT
14URL:            http://undefined.org/python/#simplejson
15Source0:        http://cheeseshop.python.org/packages/source/s/simplejson/simplejson-%{version}.tar.gz
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18BuildRequires:  python-devel
19BuildRequires:  python-setuptools
20BuildRequires:  python-nose
21
22
23%description
24simplejson is a simple, fast, complete, correct and extensible
25JSON <http://json.org> encoder and decoder for Python 2.3+.  It is
26pure Python code with no dependencies.
27
28simplejson was formerly known as simple_json, but changed its name to
29comply with PEP 8 module naming guidelines.
30
31The encoder may be subclassed to provide serialization in any kind of
32situation, without any special support by the objects to be serialized
33(somewhat like pickle).
34
35The decoder can handle incoming JSON strings of any specified encoding
36(UTF-8 by default).
37
38
39%prep
40%setup -q -n simplejson-%{version}
41
42
43%build
44%{__python} setup.py build
45
46
47%install
48%{__rm} -rf ${RPM_BUILD_ROOT}
49%{__python} setup.py install -O1 --skip-build --root=${RPM_BUILD_ROOT} \
50                                 --single-version-externally-managed
51
52%check
53nosetests -q
54
55%clean
56rm -rf ${RPM_BUILD_ROOT}
57
58
59%files
60%defattr(-,root,root,-)
61%doc docs LICENSE.txt
62%dir %{python_sitearch}/simplejson
63%{python_sitearch}/simplejson-%{version}-py%{pyver}.egg-info
64%{python_sitearch}/simplejson/*.py*
65%{python_sitearch}/simplejson/tests/*.py*
66%{python_sitearch}/simplejson/_speedups.so
67
68
69%changelog
70* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.0.3-2
71- rebuild with python-2.6.4
72
73* Sat Dec 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.3-1
74- initial build for Vine Linux based on fedora package
75
76* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.0.3-3
77- Rebuild for Python 2.6
78
79* Thu Oct 23 2008 Luke Macken <lmacken@redhat.com> 2.0.3-2
80- Use nose to run the simplejson test suite
81
82* Mon Oct 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> 2.0.3-1
83- update to 2.0.3
84
85* Wed Oct 01 2008 Luke Macken <lmacken@redhat.com> - 2.0.1-1
86- Update to 2.0.1, which contains many optimizations and bugfixes
87
88* Wed Sep 24 2008 Luke Macken <lmacken@redhat.com> - 1.9.3-1
89- Update to 1.9.3, which includes a significant decoding speed boost, and
90  various bug fixes.
91
92* Tue May 06 2008 Luke Macken <lmacken@redhat.com> - 1.9.1-1
93- Update to 1.9.1
94
95* Wed Apr 02 2008 Luke Macken <lmacken@redhat.com> - 1.8.1-1
96- Update to 1.8.1
97
98* Thu Feb 28 2008 Luke Macken <lmacken@redhat.com> - 1.7.4-1
99- Update to 1.7.4
100
101* Fri Feb  8 2008 Luke Macken <lmacken@redhat.com> - 1.7.3-3
102- Rebuild for gcc 4.3
103
104* Wed Oct 24 2007 Luke Macken <lmacken@redhat.com> - 1.7.3-2
105- Include the LICENSE.txt
106
107* Wed Oct  3 2007 Luke Macken <lmacken@redhat.com> - 1.7.3-1
108- 1.7.3
109
110* Sun Sep  2 2007 Luke Macken <lmacken@redhat.com> - 1.7.1-3
111- Update for python-setuptools changes in rawhide
112
113* Tue Aug 21 2007 Luke Macken <lmacken@redhat.com> - 1.7.1-2
114- Rebuild
115
116* Sun Jul  8 2007 Luke Macken <lmacken@redhat.com> - 1.7.1-1
117- 1.7.1
118
119* Wed Mar 21 2007 Luke Macken <lmacken@redhat.com> - 1.7-2
120- Use python_sitearch instead of sitelib
121
122* Tue Mar 20 2007 Luke Macken <lmacken@redhat.com> - 1.7-1
123- 1.7 (Bug #233212)
124
125* Sat Mar  3 2007 Luke Macken <lmacken@redhat.com> - 1.5
126- 1.5
127
128* Sat Dec  9 2006 Luke Macken <lmacken@redhat.com> - 1.4-4
129- Add python-devel to BuildRequires
130
131* Sat Dec  9 2006 Luke Macken <lmacken@redhat.com> - 1.4-2
132- Rebuild for new python
133
134* Fri Nov 24 2006 Luke Macken <lmacken@redhat.com> - 1.4-1
135- 1.4
136
137* Sun Sep  3 2006 Luke Macken <lmacken@redhat.com> - 1.3-4
138- Rebuild for FC6
139
140* Mon Aug 14 2006 Luke Macken <lmacken@redhat.com> - 1.3-3
141- Include .pyo's instead of just ghosting them
142
143* Wed Jul 12 2006 Luke Macken <lmacken@redhat.com> - 1.3-2
144- Add --single-version-externally-managed flag to install
145
146* Mon Jul 10 2006 Luke Macken <lmacken@redhat.com> - 1.3-1
147- Initial package
Note: See TracBrowser for help on using the repository browser.